Start a Conversation


Go to Solution


June 12th, 2019 12:00

Dell Latitude 5590 Windows 10 1903 upgrade Failure

We have a Dell Latitude 5590 that I am trying to update to 1903 (from 1803, yes it's out of date, I know this), however it keeps running into "There was a program running preinstall.cmd scripts" ( Error Code: 0xc19001e2 ). I think it's the Dell Encryption Management Agent that's blocking it, but I can't seem to find any updates for it. In the Dell Delivery App, there is a Dell Encryption 10.0.1 that wants to get updated. If I update that will the 1903 update go through?

5 Posts

June 20th, 2019 08:00

Uninstalling the Dell Data Security and Dell Encryption applications allowed me to install the update.

5 Posts

June 12th, 2019 12:00

I've used Windows Update, Update Assistant, Media Creation Tool. All fail and give me the 0xc19001e2 error code. No external USB devices are attached at all, and as far as I know, all drivers are updated.

4 Operator


20.1K Posts

June 12th, 2019 12:00

Are you using Windows Update? That will install some required updates first before installing 1903. You might have to go back to Win Updates a couple of times to get everything before it will install. Detach any ext usb hard drives and remove any disks or thumb drives. All driver updates should be applied.

Here is a list of problems and how to solve them--

July 8th, 2019 14:00

@Mary G 

I'm glad to hear you got this resolved. I wanted to take a moment to reply with the reason of your issue.

1903 was not supported on the version of Dell Encryption you are running. If you run 10.3.0 and later, it would allow the update to go through without issues.

Reference Dell Data Security \ Dell Data Protection Windows 10 Feature Update Compatibility for more information. 

Let me know if you end up having any other questions or issues.


L4 | Dell Data Security #IWork4Dell

5 Posts

July 8th, 2019 16:00

I updated to the latest version it would allow. The update still would not go through. But since we didn’t even use Dell Encryption, I just took it off.

July 8th, 2019 17:00


Thank you for the follow-up. Sorry to hear that didn't resolve it, but glad to see you are now able to upgrade. 

If for any reason you want encryption again, you can get a copy from 

Have a great day!


L4 | Dell Data Security #IWork4Dell

2 Posts

August 23rd, 2019 06:00

I get the same error trying to install 1903 (after it runs for 30 minutes or so, THEN Windows decides to fail).

I've tried to uninstall Dell Encryption (which it seems to have done), but Dell Security (whatever that is) refuses to uninstall... it has a list of three other things that supposedly must be uninstalled first.  None of them are on my system as far as I can tell.

I just want to get 1903 upgrade done.  Why is this so difficult?


August 23rd, 2019 09:00

@sas5 ,

 Could you please provide the error(s) and timestamp in the Windows Update log (%windir%\Windowsupdate.log) from when you get the 1903 upgrade failure message?

Do you have encryption active on your endpoint at this time? What version of the product of Dell Encryption do you believe you were running? Have you attempted to upgrade to the latest version of Dell Encryption to see if you are able to upgrade to 1903? 


L4 | Dell Data Security #IWork4Dell

No Events found!