Start a Conversation

This post is more than 5 years old

Solved!

Go to Solution

54231

January 22nd, 2018 07:00

Ethernet Port Stuck

Hi,

I boguht a Latitude 7480 and the ethernet port has a flap.

I put a RJ45 cable in the laptop and when i tried to remove it it was stuck.

I pull off so hard that i think i will broke the port.

How can i fix it and remove the cable?

Here an image of the laptop port: IMAGE LINK

Thanks in advance

8 Wizard

 • 

47K Posts

March 15th, 2018 08:00

A flat Jewelers screwdriver inserted under the area where the press latch is on with gentle tug of the cable will release it even if the tab is broken.

https://www.youtube.com/watch?v=6KJ0PPAy3OQ

8 Wizard

 • 

47K Posts

December 11th, 2020 23:00

how to remove stuck CAT5 cable from latitude 7480 latitude 7490 vostro 5468

A flat Jewelers screwdriver inserted under the area where the press latch is on with gentle tug of the cable will release it even if the tab is broken.

https://www.youtube.com/watch?v=6KJ0PPAy3OQ

Insert small screwdriver hereInsert small screwdriver here

https://www.dell.com/support/article/us/en/04/qna44311/

https://www.dell.com/support/kbdoc/en-us/000063816

Moderator

 • 

16.7K Posts

January 22nd, 2018 08:00

diegoacquani,

Did you push down on the connector tab to remove the cable? You may want to bring it to a local computer store to see if they can remove it for you.

1 Message

March 11th, 2018 12:00

I have the same problem. it's different from usual ethernet ports.

the cable doesn't come out by just press and pull the plastic part of it.

how did you remove the cable?

4 Operator

 • 

14K Posts

March 11th, 2018 17:00

I'm using a Latitude 7480 right now and just tested various Ethernet cables.  I do not have this problem.  If the cables you're using have snagless boots, then those are trickier to remove in general because if the plastic for the boot hardens, it becomes much harder to press down on the plastic clip that the boot covers, but with typical Ethernet cables, the hinged Ethernet port on the 7480 works the same way as every other port -- pinch the plastic clip tightly and pull the cable out.  Worst case, while pinching the clip, try pressing the connector upward toward the top of the laptop (or downward in the orientation of the photo that you posted), but it should not require a lot of force at all to retract.

1 Message

March 15th, 2018 08:00

There are many posts on this topic, both within this forum and on the web. We just purchased several Latitude 5580s and immediately experienced this problem, the cable locked in the ethernet port. This occurs everytime, with every cable. Wouldn't be such a big deal with a stationary PC but this is a laptop. In 20 years of experience with many laptops I may have experienced this once, due to a broken cable connector. This appears to be a class problem with the port and needs to be addressed as such by Dell.

1 Message

June 19th, 2018 15:00

I also had an ethernet cable stuck in the port of my Latitude 7480.  I'm very familiar with how to release the locking tab on an ethernet cable, but it would not work in this case.  I followed the suggestion of pushing the head a small screwdriver over the top of the cord release tab as I pressed it, and it finally released my cable.

Good thing I wasn't traveling and had access to a small screwdriver!

 

2 Posts

October 19th, 2018 13:00

I have had the same problem twice now with the same laptop you have. Had to take the back off to get the LAN cord out. This is a design flaw in this laptop. I won’t Buy a laptop again with the LAN socket in this position. Dell should just admit they made a mistake here. 

2 Posts

October 31st, 2018 10:00

I agree, we have tons of these 7480's and it is a PITA when instructing the user to unplug the LAN cable, only to be met with "I can't".

It has nothing to do with the snagless boots either, does it with any cable, plus the new docking stations suffer from the same problem!

 

10 Elder

 • 

23.1K Posts

October 31st, 2018 10:00

Unplug the system, disconnect the battery and use a thin object or needle-nosed pliers to ease the plug out.  DO NOT do this with power applied - disconnect AC and the battery first.

You'll then have to evaluate what's broken - and replace it.  If the port itself is broken, you'll need to replace the system board (or use a USB Ethernet adapter to bypass the broken one).  If it's part of the case that's broken, you'll need to replace the top or bottom assembly, whichever is broken.  In either case, the investment in the part (system board) or labor (the case assembly will be cheap;  the labor to replace it,not so) will be high.

 

November 15th, 2020 13:00

I just bought one of these refurbished and I could see little clips on the frame where the cable inserts that intruded under the plastic release that we are to push down. Once I bent the metal clips out of the way, the cable came out easily. I concur with other posters that this is a Dell fail that isn't more serious because hardly any of us do wired LANs anymore. But of course it is maddening for those of us who encounter it.

February 26th, 2021 12:00

All the screwdriver seems to do is damage the top of the ethernet port.  There are some sharp edges there.  I'll see if filing the lip down a bit will allow me to remove the cable without a struggle.

If a screwdriver or small shim is required to remove the cable then Dell should both supply the needed equipment and specify as such.

1 Rookie

 • 

4 Posts

November 13th, 2023 15:09

I've had this issue with several Latitude 3520's now (even new ones out of the box) and I just got my first Latitude 3540 (looks like a slight re-design/paint) and the same thing. Tried with two different ethernet cables and they both get stuck/require a small flathead jewler screwdriver to remove. I also have a Latitude 5420 with the same type of lift/gate on the ethernet port and I'm able to plug and unplug from it no problem - it just seems to get stuck with my 3520s and 3540s.

March 28th, 2024 14:34

@speedstep​ this does not work on machines with the hinged ethernet port cover. 

No Events found!

Top