Start a Conversation

This post is more than 5 years old


Go to Solution


February 12th, 2015 00:00

D3100 Docking station for Ubuntu 14.10 (XPS13 2015)


I recently purchased the new XPS13 (2015 model) and a D3100 Docking station. The main reason for choosing a Dell laptop is because of project sputnik and their fantastic linux support. However, the docking station does not work with Ubuntu 14.10 (or any other distros I've tried). The USB, Ethernet, Sound etc. works fine, the displays does not however, none of the ports. This is quite bad as I paid a lot of money for this docking station just because it had multiple monitor support. Dell does not state anywhere on their webpage that the display does not work with this docking station when running Linux.

Does anyone know if dell is working on this issue or is it DisplayLink which is solely responsible to fix this?


1 Message

February 13th, 2015 07:00

Unfortunately there is some kind of issue iwth linux support for displaylink chips that this uses, there is no roadmap to linux support for them as far as I know, if you google for linux and usb3 displaylink you'll find a few forum discussions on this topic,, i've just stopped myself buying one on the basis of the news from the internet, you'll unfortunately be limited to a single displayport connection from your xps13 for now.

there was an ultrasharp mnitor with this hub more or less built in i saw a little while ago, and similarly no support.

July 16th, 2015 08:00

Any news?

I bought a dell laptop to use it...

July 20th, 2015 03:00

This is very disappointing, as I bought Dell because they officially support Linux. 

However there seems to be hope in Q3;postcount=177

2 Posts

August 17th, 2015 01:00

Need this feature: I can't use D3100 with my work laptop (Kubuntu 14.10 + VGA monitor + HDMI monitor)... fustrating :p

76 Posts

September 14th, 2015 16:00

It appears that DisplayLink has a new Linux driver available for the D3100:

September 17th, 2015 07:00

has anyone tried the new drivers? do they work?

1 Message

September 18th, 2015 03:00

Hey thank you for this link, it worked for me!

Yesterday after reading your post i bought a dock and tried it out, most of the stuff worked out of the box, but after installing the driver now have 2 dell 27 inch displays hooked up, and working without any issues.

I reinstalled my XPS13 (9343) to 15.04 because the default install of Ubuntu didn't  have disk encryption enabled, so best of luck on an earlier release.

1 Message

November 26th, 2015 18:00

Has anyone used this new driver with Cinnamon on 14.04? The driver seems to work okay under Unity but really struggles in Cinnamon.

2 Posts

July 15th, 2017 08:00

Hello guys,

I purchased a Dell Inspiron 16 5547 notebook or as better known commercially Dell Inspiron 15 5000 Series.

I am interested in purchasing the DockStation (DELL Dock Station Universal Dell D3100 USB 3.0 UltraHD (4K)), I saw that many commented on the lack of support for the same drivers in linux, this question has already been resolved?

If so, did the people who downloaded the drivers succeed in device support?

Best regards

2 Posts

July 15th, 2017 15:00

Hello Kjeld Flarup,

Even using USB 3.0 was the video streaming slow?

Gbtw, were you slow too?

I need two independent monitors connected to the notebook, nowadays without any device, I can connect only 1 monitor to the HDMI output, and to have two independent screens, but I would need for what I am planning on at least one screen, 3 independent screens counting with the own notebook.

Searching the internet I found on "" a product that claims to do what I need, but I'm giving preference to a product indicated by DELL itself.

The product in question that I found is this:

"UGA USB 3.0 Multi Display Adapter HDMI DVI Graphic Dual Monitor Converter"

July 15th, 2017 15:00

I managed to get it running, sort of.

Unfortunately it was terrible slow, somehow the USB connection is too slow to update the screen fast enough. So I gave up and used the HDMI cable again.

1 Message

January 17th, 2018 10:00

XPS15 9560 (i7-7700Q) with Ubuntu 17.10.

Using latest drivers for D3100 (supports 17.04 and 16.04) works fine with one flaw:

log-in screen enters an infinite loop, i.e. click user, enter pwd, click user, enter pwd, etc.

To solve this, had to restart gdm when on the login window:

  1. CTRL+ALT+F3
  2. Login via the terminal.
  3. sudo service gdm restart
  4. Login via the UI.

This may be caused because my HDD was encrypted and a password is requested during boot when (presumably) the DP ports are still unavailable.

1 Message

February 11th, 2019 17:00

Currently trying the d3100. 



Not Working:





I've checked the displaylink support forums with no answers on any of the user submitted posts. I'm hoping to see a better show here as I can't find a phone number to call to speak with a representative, even a bad one.

1 Message

April 23rd, 2019 12:00

On a Dell XPS 13 (9360) with Linux Mint 19.1 Cinnamon (Ubuntu 18.04 based) with driver version 5.1 (19 Feb 2019)

HDMI is working (after reboot).


USB and Ethernet have been reported to work earlier already:

So most things should work fine now.

No Events found!