Start a Conversation

Unsolved

S

8 Posts

13424

July 18th, 2021 15:00

Dell Latitude 5420 / 5520 S3 Suspend (deep sleep) not working on Ubuntu 21.04

Hello,

I just purchased the latest Latitude 5420 and I cannot get suspend to RAM working. I use Ubuntu 21.04 with kernel 5.11. dmesg shows there is no S3 supported:

# dmesg | grep ACPI | grep support
[ 1.423483] ACPI: (supports S0 S4 S5)

In BIOS I have Sleep S3 specifically unblocked (I also tried to change it to ON):

svlasov_0-1626645647220.png

I also tried to add mem_sleep_default=deep to GRUB kernel boot options and also to force via command line, but mem_sleep file is not editable:

$ cat /sys/power/mem_sleep
[s2idle]
$ echo deep | sudo tee /sys/power/mem_sleep
deep
tee: /sys/power/mem_sleep: Invalid argument



When suspending (via systemctl suspend or from GNOME menu -> Suspend) I see it goes to s2idle always instead:

[ 1144.616225] PM: suspend entry (s2idle)

I tried everything I could find on the Internet but I cannot get it to go to deep sleep.

5 Posts

July 27th, 2021 01:00

Hello,

I've been troubleshooting this ever since I got this laptop back in March of this year, having the same results than you. Apparently Dell has hardcoded this somehow and unless they say the contrary, I'd assume this is how is going to play.

On Windows 10 it seems to work fine as I did some testing and it didn't drain my battery overnight as it does on Linux.

I'm running Debian 10 with kernel 5.10 

8 Posts

July 28th, 2021 06:00

I reached to Dell support and they told me that they don't support S3 simply because Windows 10 may have BSOD after wake. They don't care about other OS and they don't give customers a choice.

I used Ubuntu only for testing, since 5420 if officially Ubuntu certified. Apparently certification doesn't mean anything, since the laptop looses its mobility and always have to be plugged to charger.

I also tried with Debian 11 bullseye and the situation is the same. Which is expected since S3 is blocked in on a low-level BIOS.

I also tested on Windows 10 and deep sleep is also not available there:

svlasov_0-1627476597087.png

Dell should unblock S3 and let customers decide for themselves if they want to use S3 or not. We should also complain to Dell directly to get their attention.

8 Posts

July 28th, 2021 06:00

Dell support also told me there is a registry key that can enable S3 in Windows but I was discouraged to try. It means there is a way to unblock S3 in Linux as well.

2 Posts

August 7th, 2021 14:00

Hi, I'm also struggling with this one. I just noticed that the Live USB stick (Linux Mint) does seem to be able to Suspend!

I had only tested with the installed version of Mint, but with the Live USB loaded I can Suspend and wake the laptop (Dell 5490) again and again! Is there someone who can reproduce this? Might this be an opening to make it work with the installed version? I hope someone knows how to make this work. 

8 Posts

August 16th, 2021 10:00

@jellexcould you please check it really goes into deep sleep? Before entering sleep run:

 

sudo dmesg -w | grep PM:

 

after resuming from sleep you should see this:

 

[164594.621487] PM: suspend entry (deep)
[164595.303880] PM: Saving platform NVS memory
[164595.332682] PM: Restoring platform NVS memory
[164596.536893] PM: suspend exit

 

2 Posts

August 17th, 2021 12:00

Thanks for your suggestion. I already replaced the laptop with another one, so I stopped testing. I still have it, so I tried it out. Strange thing is that now suspend also doesn't come back on the Live USB... So, sorry that won't help troubleshooting.

I'm now using a self built barebone laptop, but even that one struggles with S3. Hibernate does work smoothly.

5 Posts

August 30th, 2021 05:00

This is nice input that confirms what I was suspecting. Good job dell, its time to get back to lenovo... 

5 Posts

September 2nd, 2021 07:00

Just tested this on a Latitude 7420 i7 on windows 10 issuing powercfg /a 

The output is the same than for Latitude 5420. 

2 Posts

December 20th, 2021 06:00

I also have this issue with the Latitude 5420, deep sleep is disabled. Looking at the BIOS settings, it should be enabled. I'd like to know when we can expect a bios update for this or I'll have to send this back as it's unacceptable to have a laptop that can't sleep.

January 20th, 2022 02:00

There are actually some people who managed to have their recent Dell laptop work by patching the ACPI DSDT table. You can find more information here

1 Message

April 1st, 2022 05:00

Hello,

I just got my work laptop Latitude 7520 with having same problem with missing S3 support. The default activated 's2idle' drained full battery within 24 hours to 0%. Bios version is 1.12.2 and block S3 mode is disabled by default. I have Manjaro installed and tried to patch ACPI DSDT table but that didn't work as well. To me this is unacceptable that paying more than 2000 Euros and can't even get Laptop to suspend to RAM. How am I suppose to take laptop daily back from work if it can't sleep properly and consuming too much power.

I regret changing from Lenovo to Dell. Their keyboards are far superior even on 14 inch laptops. The German keyboard on Latitude is miserable: too small enter key, arrows up & down keys and missing page up and down keys. I figured that I can enable these key with Fn+Arrow which is not a very user friendly solution.

Please Dell fix the issue with S3 state in next BIOS version or tell us how to fix it on Arch Systems. That is one major unacceptable issue.

 

1 Message

April 13th, 2022 04:00

Same issue here.

No deep sleep available. Battery goes to 10% overnight.

Dell Latitude 5520 , Linux kernel 5.10

The ACPI DSDT fix doesn't fully apply to this model.

2 Posts

April 18th, 2022 14:00

Has anyone successfully patched ACPI for the 5420? A bit afraid to brick something as this is a work laptop

5 Posts

June 23rd, 2022 04:00

Just got into my hands a new generation Latitude 5530 with 12th gen Intel CPU. 

Issue remains the same, output from powercfg /a on Windows remains exactly the same.

What is really "funny" from this situation is the fact that if I go to the BIOS' of both the Latitude 5420 as of this Latitude 5430 standing next to me, I find an option in "Power" section called "Block Sleep", this option literally says that if you as a user wish to block Deep Sleep S3 you can enable, but it is OFF and still I get S3 blocked... incredible. 

Dell nor Intel seems really interested into listening to the community, it's a pity the decisions they are taking and forcing the users to take. 

In the meantime, I've purchased a Lenovo T14 Gen2 AMD for my professional activities and I couldn't be happier with it running Linux. Byebye Dell, hope this is my last post "complaining" about basic tech and functionalities that a poweruser's laptop should have. 

Moderator

 • 

25.3K Posts

June 23rd, 2022 04:00

Hello, I see you are looking for technical assistance. If you need our help, you can start a private/direct message with us and we will be happy to assist you.

No Events found!

Top