Start a Conversation

Unsolved

This post is more than 5 years old

44498

July 29th, 2012 13:00

VLAN Routing and Config

I have read through many forums and configurations and am missing something, I hope you guys can tell me what it is. I have a single network 192.168.16.0 VLAN 3. The network has grown and is now subbed out to another company, so vlans were mentioned. I want to create a vlan to separate that company from our network/computers, however they will be sharing our DHCP server and Term Server along with internet connection. I see I have to have a management vlan so I have assigned it to 192.168.11.0 VLAN 1 and the new company 192.168.10.0 VLAN 2. I have not been able to get inter vlan routing to work properly.

running-config                                                            

!Current Configuration:
!
System Description "PowerConnect 6248, 3.3.1.10, VxWorks 6.5"
!
System Software Version 3.3.1.10
!
Cut-through mode is configured as disabled
!

configure

vlan database

vlan 2-3

vlan routing 2 1

vlan routing 3 2

vlan routing 1 3

vlan association subnet 192.168.10.0 255.255.255.0 2

vlan association subnet 192.168.16.0 255.255.255.0 3

exit

stack
member 1 2

exit

ip address 192.168.11.210 255.255.255.0

ip default-gateway 192.168.11.254

ip routing

ip route 0.0.0.0 0.0.0.0 192.168.11.254

ip route 192.168.16.0 255.255.255.0 192.168.16.254

ip route 192.168.10.0 255.255.255.0 192.168.16.254

ip helper-address 192.168.16.1 domain

ip helper-address 192.168.16.1 dhcp

interface vlan 1

routing

exit

interface vlan 2

name "VLAN2"

routing

ip address 192.168.10.210 255.255.255.0

ip helper-address 192.168.16.1 domain

ip helper-address 192.168.16.1 dhcp

exit

interface vlan 3

name "VLAN3"

routing

ip address 192.168.16.210 255.255.255.0

exit

dhcp l2relay
dhcp l2relay vlan 2
!

interface ethernet 1/g2 -24 ### to save space
switchport access vlan 3
exit
!

interface ethernet 1/g25 - 36### to save space
switchport access vlan 2
exit
!

interface port-channel 1 - 24  ### to save space
switchport access vlan 3
exit

interface port-channel 25 - 36 ### to save space
switchport access vlan 2
exit

5 Practitioner

 • 

274.2K Posts

July 30th, 2012 06:00

The basics of VLAN routing would look like this.

console(config)#ip routing

console(config)#interface vlan 2

console(config-if-vlan2)#routing

console(config-if-vlan2)#exit

console(config)#interface vlan 3

console(config-if-vlan3)#routing

console(config-if-vlan3)#exit

From what I can tell you have this, but also have some other configurations added to it. Which is fine, but we may need to look at those commands and see if they are affecting the basic portion of the VLAN routing.

Are all computers in VLAN 2 and 3, connecting to these switches only? The reason I ask is you have not only 36 ports, but 36 port channels configured in access mode. Access mode is for VLAN unaware devices. If any of those ports connect to another network device, they would need to be in General mode.

Are  computers connected to VLAN 2 and 3 ports are able to get a DHCP address?

If you set a static ip address, with the default gateway being the IP address of the VLAN the computer is connected to. Are you then able to Ping between VLANs?

We have Static routes for both VLANs, set to IP address 192.168.16.254, What is this IP Address assigned to?

As a side note, it is always recommended to have the most recent firmware applied to all stack members. This will help ensure the switches are operating smoothly. The firmware can be downloaded here.

www.dell.com/.../powerconnect-6224

Keep us updated,

Thanks.

11 Posts

July 30th, 2012 08:00

You mentioned that I had extra stuff in my config, and at this point I'm not opposed to trashing it and starting over. What's your thought on that?

11 Posts

July 30th, 2012 08:00

Currently I am just trying to get this running in a stand alone operation with no other switches.

Computers on VLAN 3 are able to get DHCP because the server that is running DHCP is also on this VLAN. Computers on VLAN 2 are unable to ping to VLAN 3 even with a static IP Address set.

192.168.16.254 is our gateway, I have also given the gw multiple IP addresses, one for each vlan subnet but have been unsuccessful with pinging other than VLAN 3.

I am currently updating firmware to latest version.

5 Practitioner

 • 

274.2K Posts

July 30th, 2012 08:00

Once the firmware is updated, I Would take a device in VLAN 2, give it a static IP address and try to simply ping VLAN 2. If you can ping VLAN 2, then try to Ping VLAN 3 itself, and not a device on VLAN 3. see if we can manually see where connection is being lost.

11 Posts

July 30th, 2012 08:00

With static IP on VLAN 2 I can ping and get a response from the switch, I can also ping the switch IP assigned to VLAN 3 however that is the extent of the ping. I cannot ping any device on VLAN 3 other than the switch.

5 Practitioner

 • 

274.2K Posts

July 30th, 2012 09:00

Yeah that may be a good things to do. Start out with just basic routing commands, get the routing between VLANs good with static addresses, and then slowly add the other commands in for any static routes, dhcp, dns, etc.

console(config)#ip routing

console(config)#interface vlan 2

console(config-if-vlan2)#name "VLAN2"

console(config-if-vlan2)#routing

console(config-if-vlan2)#ip address 192.168.10.210 255.255.255.0

console(config-if-vlan2)#exit

console(config)#interface vlan 3

console(config-if-vlan3)#name "VLAN3"

console(config-if-vlan3)#routing

console(config-if-vlan3)#ip address 192.168.16.210 255.255.255.0

console(config-if-vlan3)#exit

11 Posts

July 31st, 2012 09:00

Ok here is my current running config. With this config I cannot ping or see switch from VLAN 2 or 3 with a static IP assigned to the client computer.

running-config

!Current Configuration:

!

System Description "PowerConnect 6248, 3.3.4.1, VxWorks 6.5"

!

System Software Version 3.3.4.1

!

Cut-through mode is configured as disabled

!

configure

vlan database

vlan 2-3

vlan routing 2 1

vlan routing 3 2

vlan association subnet 192.168.10.0 255.255.255.0 2

vlan association subnet 192.168.16.0 255.255.255.0 3

exit

stack

member 1 2

exit

ip address 192.168.11.210 255.255.255.0

ip default-gateway 192.168.11.254

ip routing

interface vlan 2

name "VLAN2"

routing

ip address 192.168.10.210 255.255.255.0

exit

interface vlan 3

name "VLAN3"

routing

ip address 192.168.16.210 255.255.255.0

exit

username "admin" password d9b55729e275c9f859a78b94cf4932ce level 15 encrypted

!

interface ethernet 1/g2

switchport access vlan 2

exit

!

interface ethernet 1/g25

switchport access vlan 3

exit

exit

5 Practitioner

 • 

274.2K Posts

July 31st, 2012 11:00

Lets get rid of the vlan association commands

• vlan association subnet 192.168.10.0 255.255.255.0 2

vlan association subnet 192.168.16.0 255.255.255.0 3

I just want to double check and confirm that when you are setting a static IP address for a computer, it would similar to this.

Example for VLAN 2.

IP address = 192.168.10.1

Subnet=255.255.255.0

Gateway = 192.168.10.210

Example for VLAN 3.

IP address = 192.168.16.1

Subnet=255.255.255.0

Gateway = 192.168.16.210

The thing that is important here is that the gateway is set to the IP address of whatever VLAN the computer is accessing.  And not the 192.168.11.254 default gateway.

We can also look and see if the VLANs are showing up on the routing table with the command.

Show ip route.

Thanks

11 Posts

July 31st, 2012 12:00

Ok i have removed the vlan associations and have the computers configured as you mentioned, with the GW as the switch. When I do show ip route it comes back empty with the legend for Route Codes.

11 Posts

July 31st, 2012 13:00

I am able to see my switch when plugged into the correct VLAN, but unable to ping the other VLANS.

192.168.10.1 can ping 192.168.10.210

192.168.16.1 can ping 192.168.16.210

11 Posts

July 31st, 2012 13:00

I guess I have been a little impatient with running commands. Now when running the show ip route I get

192.168.10.0/24 directly connected vlan 2

192.168.16.0/24 directly connected vlan 3

I can also ping from 192.168.16.1 to 192.168.10.1 but cannot the other way around

5 Practitioner

 • 

274.2K Posts

July 31st, 2012 14:00

So VLAN 3 is down, which would mean that either there is no port configured for VLAN 3, but in this case we have g25. Or the port  configured in VLAN 3 is down also.

The computer you have static address assigned for VLAN 3, it is plugged into port 25 correct?

If you do a show interface status command it should show if the port is up or down.

5 Practitioner

 • 

274.2K Posts

July 31st, 2012 14:00

Can you run this command please:

show ip interface

Post the output here.

Thanks

11 Posts

July 31st, 2012 14:00

The vlan 3 State is Up, the laptop went to sleep when I ran the Show cmd. But I have verified that pings are still acting the same and reran the cmd and now have Up Up

11 Posts

July 31st, 2012 14:00

The vlan 3 State is Up, the laptop went to sleep when I ran the Show cmd. But I have verified that pings are still acting the same and reran the cmd and now have Up Up

No Events found!

Top