Start a Conversation



16 Posts


23-11-2021 11:00 AM

Update Failed, Blocked by TPM FW Policy

Followed instructions on a DELL T3620 but can't flash the TPM to newer 1.2 or 2.0.

Any utilities to diagnose or log the update status?

16 Posts

23-11-2021 12:00 PM

At this point, I'm really looking for any custom DELL tech support utilities to diagnose or log the TPM update utility progress. The message "Update Failed, Blocked by TPM FW Policy" isn't detailed enough.

I'm beginning to believe I may have a TPM chip problem, such as the chip thinks it's already been flashed the max amount of times. I'd like to find out what the Self Test values mean: {255, 1, 2, 5...}

16 Posts

23-11-2021 12:00 PM


Yes I've tried about every OS / BIOS / HW / TPM setting combinations and system resets that I can think of. I'm sort of an IT specialist too, so I'm well versed in DELL PC's and have successfully updated other T3620's at my workplace. (we have hundreds). 


I've even tried stepping back the BIOS FW from 2.19.0 all the way back to 2.3.0 and it made no difference. My BIOS has only ever shown TPM 1.2 and not the TPM 1.2/2.0 that some of the documentation references.

47K Posts

23-11-2021 12:00 PM

You have to disable secure boot and deprovision TPM and reset and reboot and and and and and.

Must be run as administrator with clean OS no antivirus.

Its not a ronco one click set and forget.

16 Posts

23-11-2021 17:00 PM

FYI: My motherboard is model 0MWYPT revision A01.

I've seen other T3620's come with 09WH54 rev A00... not sure of the differences.

16 Posts

29-11-2021 07:00 AM

I ordered a "used" motherboard from eBay. Got it for a good price. Hope this one is flashable. I'll report back after I try it.

16 Posts

29-11-2021 17:00 PM

Something else of interest. DELL has already stated it won't have full driver support for the T3620 and Windows 11.

I tested a Windows 11 installation, and although the systems seemed to respond normally, these are the only devices that the installation didn't find drivers for. 

  • PCI Data Acquisition and Signal Processing Controller
  • PCI Memory Controller
  • SM Bus Controller

16 Posts

29-11-2021 17:00 PM

The replacement motherboard came tonight. 0MWYPT revision A02.

It had BIOS revision 2.12.0 installed with TPM 1.2 v5.81.2.1

The TPM 2.0 v1.3.2.8 flash update was successful !!!!!!!!!!

A couple things I noticed. This replacement board BIOS had a "Trusted Execution" option under the Virtualization category that my prior BIOS did not, but it wasn't checked. This system also reports the TPM manufacturer as NTC.



18 Posts

24-01-2023 08:00 AM

any dell explanation/feedback on why it did not work?