Start a Conversation



3 Posts


August 11th, 2021 06:00

Precision 3510, Win 10 recognize wrong graphic card

Hello brothers, I have a problem when fresh (clean) install Win10, it recognized the graphics card as AMD Radeon R9 M360 instead of Firepro 5130, then PC crashes, I had to disable R9 M360 driver because ì i uninstall it, the win 10 autoupdate and crashes again, then I downloaded from Dell a Firepro 5130 driver and proceeded to install but by about 1/2 of the process, PC crashes, I also tried many ways on the net such as: extract files and pause install, turnoff firewall, internet, use DDu, safemode, compatible install, use older win 10 ver, download driver from AMD, dust inspection and cleaning laptop but all failed. someone help me!

7 Technologist


11.7K Posts

August 11th, 2021 06:00

The driver for the Firepro has this warning:

 The Intel graphics driver must be installed before installing the AMD graphics driver.

Have you installed that driver first? The driver is available here.

3 Posts

August 11th, 2021 19:00

Hello JOcean, thank you for your interest. Of course, I followed the instructions from Dell when install the AMD graphic card, I also downloaded original factory image from Dell, install it and ran the program "Dell command update".

August 20th, 2021 08:00

I have the exact same issue with all 12 Precision 3510 laptops after a clean install with Win10 21H1.
Either the laptops startup with a black screen and there's no way I can activate the screen or it starts and shuts down or reboots when trying to enter the pincode to Win10 account.
After disabling the GPU in device manager I can use the laptops. And yes I first installed the Intel GPU drivers. This seems to be an issue relating to either the update or Dell has botched AMD Radeon drivers that don't work. 

2 Posts

November 14th, 2021 19:00

Did you ever solve this? How? thanks

2 Posts

November 14th, 2021 19:00

Did you ever get an answer to this?

1 Message

January 30th, 2022 01:00

Same here on M2800 laptop, I can’t even install any older version of Windows - it came with 7. Windows 10/11 are only usable OSes with AMD card disabled in dev manager

1 Message

June 26th, 2022 07:00

It seems to me that the appearance of the problem is related to some Windows compilation update version 20H1/20H2.

I purchased a used laptop in May 2019, as I recall the problem appeared somewhere around May, June 2020.

Now I have had the opportunity to reproduce the situation due to the failure of the built-in Hynix SDD. When installing a new system, on the new SDD, I selected Windows compilation 19H1 (Version 1903) and the older version 20.Q1 of the AMD graphics card drivers. Everything installed successfully, the graphics driver worked fine, for verification I used Vegas Movie Studio and rendered the movie using the AMD codecs and FirePro card. I then updated the system to 20H1 (Version 2004 - May 2020 Update) and everything was OK. The problem occurred after upgrading to 20H2, probably after downloading the first patches/updates for that version. So a clean build of 20H2 should work, but not 100% because some updates for branches 20H1 and 20H2 are shared, so it may be that only version 20H1, will work properly with AMD.

Tracking this down and finding the specific update that is responsible for the problem is not easy, especially since when restoring system copies you have to juggle boot settings in BIOS/UEFI and "legacy mode".

Currently, I'm successfully test running version 20H2 (build 19042.1766) with the graphics driver version 20.Q1. I have system updates disabled thanks to group policy. I have the latest BIOS version installed.



My suggestion to solve the problem now is to install Windows version 19H1 (version 1903) or 19H2 (version 1909) and graphics driver 20.Q1 or newer (I haven't tested other versions yet, but I don't think they are a problem) and disable feature updates for 365 days in the advanced system update settings. This will allow you to use the graphics card, and receive security updates.

I encourage you to search, to solve the problem, what I have identified is a good lead to start with. Let me remind you that in version 20H1, for example, a new Windows Display Driver Model (WDDM) 2.7 driver appeared.

No Events found!