Start a Conversation

Solved!

Go to Solution

21783

January 10th, 2020 09:00

Precision 7540 will only boot Linux if charger is connected

I recently got a new Precision 7540 laptop for work. The first thing I did was wipe the SSD and install the latest Linux Mint. It runs great, with one caveat. It will only boot if the AC adapter is plugged in. On battery, 9 times out of 10, it won't cold boot. I see the Dell splash screen come and go. I see a message about booting in insecure mode because secure boot is disabled, and that's it. I never get prompted for my disk decryption key, although the keyboard backlight activates if I touch the keyboard. I have to poweroff by holding the power button to get out of this state. If I plug the charger back in and power on again, it comes right back up. Once I've made it to the login screen, I can unplug the charger and everything keeps working normally from there. I've reinstalled without full disk encryption and it doesn't seem to make a difference. I've tried the latest Ubuntu, Kubuntu, Fedora, as well as Ubuntu 18.04.3, all with the same startup issue. The issue is there before I install Nvidia drivers and afterwards, so that seems to have no effect. Ubuntu 18.04 seems to get farther; I actually see the Ubuntu logo with the 5 white dots that turn orange, and then back to white, and then back to orange... for 20 minutes until I hold down the power button, plug in the charger, and power on again. And then it comes right back up!

I spoke with Dell technical support and their stance was that since the laptop shipped with Windows, they can't provide support. So I reinstalled Windows 10, and frustratingly, the problem isn't there. I was hoping it was an obvious hardware problem that could be repaired.

I know Dell ships this model with Ubuntu 18.04 installed, so I know the hardware 'should' be able to work in that configuration. However, Dell has their own customized Ubuntu image. Because my system shipped with Windows, I don't have access to an official Dell Ubuntu image that would likely contain any needed patches/fixes, if the issue truly is limited to software.

My main concern is that I'm coming up on 30 days with this laptop. If I can't gain confidence that it's going to work in the long term, I'd rather send it back and eat the cost of restocking rather than risk being stuck with a laptop that's not fit for purpose. Is anyone out there running a stock (non Dell customized) version of the latest Ubuntu on the Precision 7540? If so, do you see this same issue?

February 18th, 2020 03:00

I have the same issue with a Dell Precision 7730. I have switchable graphics turned off and the most recent bios version.

I also have an identical model which is a Windows 10 pc and it has no issues booting without power.

1 Message

February 20th, 2020 09:00

This happens with the Precision 7530 as well using RHEL 7.x. I discovered the problem while investigating why the WD19DC dock wouldn't supply the proper power to the the laptop.  One of the suggestions was to update to 1.12.1.  The problem manifested itself pretty quickly.  I was using BIOS version 1.10.1.

BTW, all of the Dell docks appear to worthless if you expect to power this kind of laptop from the dock.  Internally, almost all of our developers have had some kind of issue.  Screens go dark, keyboard needs to be disconnected/reconnected.  

Here's the recommended solution to the dock issue which is horrible.  

https://www.dell.com/support/article/us/en/04/sln316239/undersized-power-adapter-alert-when-system-is-connected-to-a-wd15-tb16-tb18dc-wd19-wd19dc-wd19tb-docking-station?lang=en

5 Posts

February 24th, 2020 17:00

Thanks. This worked. I'm also having a 7540 and upgraded the bios from 1.6 to 1.7 when doing a dist-upgrade.

Everything worked with the shipped 18.04 but I wanted 19.10 so I removed the dell repositories from the package list and did a distupgrade. That wasn't a particularly good idea in retrospective.

With this kernel parameter set, everything works like expected again. I'm looking forward for a fix either in the ubuntu kernel, the dell firmware or the microcode. Who it may concern

10 Posts

February 25th, 2020 18:00

Hi Everyone,

Since I started this thread, I thought I should come back and post an update. Dell support reached out to me and has been trying to figure out what's going on for about a month now. So far, the only reliable solution is to downgrade the BIOS. For the 7540, the latest version that works for me is v1.3.3 from September 2019.

Early in the process, Dell supplied me with their stock Ubuntu image. Immediately after the restore, the system works normally on the latest BIOS. However, after applying updates (at the time there were 718 of them) the problem is back. So the latest BIOS can work with an out of date linux install, and older BIOS works with up to date linux install. It seems like it's not just a bad update or a bad BIOS so much as an incompatibility between the two. My understanding from what support has told me is that the specific hardware combination also seems to impact whether the behavior is observed or not.

On that note, my hardware config is:
8 core Xeon E-2286M
32GB ECC RAM
Nvidia RTX3000 w/ 6GB RAM
1TB NVMe SSD

Once the problem was observed with the stock image, Dell asked to replace the laptop so they can have a known affected piece of hardware to troubleshoot. They have been able to reproduce the issue on their end and have been in contact regularly. Hopefully, there will be a resolution soon. This is obviously affecting multiple models and hardware configurations.

Take care,
Dale

 

BTW, my new dock (WD19DC) was waiting for me when I got home today, so we'll see how that goes at the office tomorrow. From what I can see, aside from Intel security mitigations, fixes to dock behavior account for most of the changes in the recent BIOS updates...

March 3rd, 2020 01:00

Had the exact same issue but on Latitude 5591 with BIOS 1.11.1. PC Born with Windows 10, installed Ubuntu 18.04 LTS and upgraded (more than once) bios using updates proposal by Ubuntu.

March 3rd, 2020 05:00

Quick update, bios reverted to 1.10.1 and issue disappeared, bios updated again an issues pops out.

Adding kernel parameters solves the issue. Posting solution:

in /etc/default/grub add dis_ucode_ldr in this way

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash dis_ucode_ldr"

then

sudo update-grub

March 4th, 2020 07:00

dis_ucode_ldr fixes the problem for me as well.  Glad Dell is looking into this... it's ridiculous!

1 Message

March 7th, 2020 00:00

Thank you a lot for your message, it solved my problem:

- Dell 7530, Ubuntu 19.10

- after bios update, loading Ubuntu failed just after second line "Loading initial ramdisk", even in recovery mode

- adding dis_ucode_ldr in grub solves this problem.

 

Just a question: do we lose functionality by adding this option?

 

Best,

2 Posts

March 24th, 2020 15:00

I have the same problem with a pre installed ubuntu 18.04 on my precision 3530. Could you tell me how you added that command in GRUB since it is a read only file?

2 Posts

March 25th, 2020 03:00

I did this and it fixed the startup without power issue. Thank you very much. 

April 1st, 2020 16:00

This does not work for a Dell Precision 7730 with a nvidia P3200 when using "discrete only" graphics as enabled in the bios. If I change to "switchable" graphics I can boot using no power only if I have enabled "intel" with "sudo prime-select intel". If I enable "nvidia" with prime I cannot boot. I am running the latest ubuntu kernel with nvidia 435.21 driver as reported by "nvidia-smi". This laptop is essentially a desktop without the ability to power on from battery.

1 Message

April 11th, 2020 11:00

I had the same problem with my Precision 7730 and the above "grub fix" solved it.

1 Message

April 23rd, 2020 23:00

I had the same problem with my Latitude 5500 - Fedora installed. Problem was fixed via editing grub config like above

April 24th, 2020 06:00

It's great that there is a workaround for this problem, but it's been months without a real fix.  Is Dell going to fix this, or does it only support booting laptops when they are plugged in?

May 8th, 2020 02:00

Issue reproducible also with latest ubuntu version 20.04

No Events found!

Top