Start a Conversation

Solved!

Go to Solution

21783

January 10th, 2020 09:00

Precision 7540 will only boot Linux if charger is connected

I recently got a new Precision 7540 laptop for work. The first thing I did was wipe the SSD and install the latest Linux Mint. It runs great, with one caveat. It will only boot if the AC adapter is plugged in. On battery, 9 times out of 10, it won't cold boot. I see the Dell splash screen come and go. I see a message about booting in insecure mode because secure boot is disabled, and that's it. I never get prompted for my disk decryption key, although the keyboard backlight activates if I touch the keyboard. I have to poweroff by holding the power button to get out of this state. If I plug the charger back in and power on again, it comes right back up. Once I've made it to the login screen, I can unplug the charger and everything keeps working normally from there. I've reinstalled without full disk encryption and it doesn't seem to make a difference. I've tried the latest Ubuntu, Kubuntu, Fedora, as well as Ubuntu 18.04.3, all with the same startup issue. The issue is there before I install Nvidia drivers and afterwards, so that seems to have no effect. Ubuntu 18.04 seems to get farther; I actually see the Ubuntu logo with the 5 white dots that turn orange, and then back to white, and then back to orange... for 20 minutes until I hold down the power button, plug in the charger, and power on again. And then it comes right back up!

I spoke with Dell technical support and their stance was that since the laptop shipped with Windows, they can't provide support. So I reinstalled Windows 10, and frustratingly, the problem isn't there. I was hoping it was an obvious hardware problem that could be repaired.

I know Dell ships this model with Ubuntu 18.04 installed, so I know the hardware 'should' be able to work in that configuration. However, Dell has their own customized Ubuntu image. Because my system shipped with Windows, I don't have access to an official Dell Ubuntu image that would likely contain any needed patches/fixes, if the issue truly is limited to software.

My main concern is that I'm coming up on 30 days with this laptop. If I can't gain confidence that it's going to work in the long term, I'd rather send it back and eat the cost of restocking rather than risk being stuck with a laptop that's not fit for purpose. Is anyone out there running a stock (non Dell customized) version of the latest Ubuntu on the Precision 7540? If so, do you see this same issue?

May 16th, 2020 06:00

Same issue at ubuntu 20.04.

Latitude 5400, BIOS 1.6.5 and this fix solved the problem.

Thanks! 

1 Message

June 2nd, 2020 17:00

Dear, 

I've tried to do that, but the problem still. 
In addition, I cannot unplug my laptop (Precision 7540, Ubuntu) from the charger without shouting it down. It seems my battery also doesn't charge more than 55%. 

Note that I've found the following procedure https://www.dell.com/support/article/en-us/sln308571/laptop-battery-does-not-charge-beyond-55-on-certain-dell-pcs?lang=en

However, my laptop wasn't missing the 'Ownership Date'.

I'd appreciate any guidance in that matter.
Thanks!
Best,
Denis

June 4th, 2020 00:00

Dell just released new BIOS version, at least for my Latitude. Not yet tested if the issue is fixed by removing the parameter proposed

June 4th, 2020 05:00

12 Posts

June 18th, 2020 01:00

I had the same issue on a different DELL model, Latitude 7400, and the solution offered in this post seems to work.

In particular

"Adding kernel parameters solves the issue. Posting solution:

in /etc/default/grub add dis_ucode_ldr in this way

sudo gedit /etc/default/grub 

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash dis_ucode_ldr"

then

sudo update-grub"

Thank you very much. I was almost crazy dealing with this issue.

1 Message

June 25th, 2020 04:00

Happy to see that I'm not the only one.

I recently got a Precision 7540 from work with a Nvidia Quadro T1000 GPU and I installed Ubuntu 20.04 on it (a lighter version). I had the same problem as @dalekuhn : the OS would hang on boot if the PC wasn't on AC.

Adding the "dis_ucode_ldr" boot parameter as @fleaplus suggested did not solve the issue. But deactivating the Nvidia Optimus function in the BIOS did.

I think that the problem comes from the Nvidia GPU, not the BIOS. By the way, I am also forced to use Nvidia proprietary drivers because Nouveau driver is buggy (can't handle two monitors properly).

10 Posts

June 29th, 2020 20:00

Hi Everyone,

 After working with Dell support on this for a while, they released BIOS v1.7.0 which 'seemed' to fix the issue. I say seemed in quotes because I'm not 100% certain. I've since upgraded to BIOS v1.8.2. This version worked at first but I noticed a couple weeks ago that it was broken again with recent Linux updates. There was a new BIOS v1.9.0 available, but the BIOS USB update feature didn't recognize the exe, even though all of the checksums passed. I also notice that BIOS v1.7.0 is no longer available from the Dell website, which actually worked. D'oh! So would the v1.7.0 fix the problem? Or would it get broken by the same update that broke 1.8.2? Don't know, can't test. Why was BIOS v1.7.0 for Precision 7540 removed from the list of older BIOS versions?

 Since there was a new version of Linux Mint, I planned on backing up my files and doing a clean install anyway. I interrupted that process to put Windows back on real quick and installed the v1.9.0 update from there. This did not fix the issue.

 I see that the accepted 'solution' is to disable microcode updates. I'm sorry, but I respectfully disagree that this is a fix. This is a workaround that seems to work for some subset of the people who are experiencing this issue, in return for accepting flaws like Spectre and Meltdown, which the microcode updates are largely meant to mitigate.

 I'll reach back out to Dell support and see what they can do about it.

 Side rant on. If Dell offered high end AMD laptops and workstations, I would have never even looked at the Intel offerings for our engineering department. All of the mitigations and band aids that have other side effects don't make up for the fact that Intel was cheating the whole time. I don't expect Dell to ever admit this, but I suspect the root cause is related to all of the band aid patches Intel requires every time they're caught cheating; skimping on security to get better benchmarks. Dell, you should offer high end AMD systems. I'm not the only one that would buy them. Side rant off.

 

Take care,

Dale

June 30th, 2020 05:00

Hi @dalekuhn ,

I agree wholeheartedly that disabling microcode updates is a band-aid and not a solution.

By the way, fwupdmgr works well for me on this laptop for updating firmware.  No windows required.

I would also like a high end AMD workstation, but not sure I'll be getting a Dell again based on their (lack of) support for this laptop.

Ed

1 Message

July 7th, 2020 00:00

It works perfectly on my Latitude 5491. Thanks a lot @reallucamosca I owe you a beer.

2 Posts

July 11th, 2020 09:00

I did this but the problem is still there

I have already removed "quiet splash" from GRUB_CMDLINE_LINUX_DEFAULT so that I can see all the commands when rebooting, but not much help.

What's the best way of troubleshooting this?

10 Posts

July 13th, 2020 11:00

Thanks for the tip about fwupd (gnome-firmware); this tool made BIOS v1.7.0 available again. After downgrading to v1.7.0 and then upgrading back to v1.9.0, everything is working again. Not sure if it was changing the BIOS, or some other update that got things back on track.

 

Dale

3 Posts

September 5th, 2020 14:00

I've logged in to state that I also have noticed this problem booting current Ubuntu 18.04 (with intel-microcode 3.20200609.0ubuntu0.18.04.1) on a Dell Precision 7530, with current BIOS Revision 1.13.1 (09 Jun 2020).  I'm also confirming the 'dis_ucode_ldr' workaround -- but this is not a proper solution, of course.

3 Posts

September 6th, 2020 13:00

Instead of forcing 'dis_ucode_ldr', a slightly better workaround would be to force the intel-microcode package back to a known-good version; 3.20191115.1ubuntu0.18.04.2 in my case.  That way, at least those microcode updates can be applied.  Then, 'apt-mark hold intel-microcode' until we've got a proper solution.

 

1 Message

September 16th, 2020 01:00

I've been facing the same problem with Ubuntu Mate 20.04 recently and after a couple of days and countless attempts to find the solution (adding dis_ucode_ldr in grub did not help) finally discovered a simple one that has worked for me.
Try editing grub adding the "nomodeset" option in the line "GRUB_CMDLINE_LINUX_DEFAULT" (if present),
so that it reads as follows:
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash nomodeset".
Hope that might help someone as well.

More details on nomodeset here: https://askubuntu.com/questions/207175/what-does-nomodeset-do

12 Posts

November 9th, 2020 02:00

Update: I restored the original settings leaving just "quiet splash" and it seems to work, for the moment.

No Events found!

Top