Start a Conversation

Solved!

Go to Solution

21764

January 10th, 2020 09:00

Precision 7540 will only boot Linux if charger is connected

I recently got a new Precision 7540 laptop for work. The first thing I did was wipe the SSD and install the latest Linux Mint. It runs great, with one caveat. It will only boot if the AC adapter is plugged in. On battery, 9 times out of 10, it won't cold boot. I see the Dell splash screen come and go. I see a message about booting in insecure mode because secure boot is disabled, and that's it. I never get prompted for my disk decryption key, although the keyboard backlight activates if I touch the keyboard. I have to poweroff by holding the power button to get out of this state. If I plug the charger back in and power on again, it comes right back up. Once I've made it to the login screen, I can unplug the charger and everything keeps working normally from there. I've reinstalled without full disk encryption and it doesn't seem to make a difference. I've tried the latest Ubuntu, Kubuntu, Fedora, as well as Ubuntu 18.04.3, all with the same startup issue. The issue is there before I install Nvidia drivers and afterwards, so that seems to have no effect. Ubuntu 18.04 seems to get farther; I actually see the Ubuntu logo with the 5 white dots that turn orange, and then back to white, and then back to orange... for 20 minutes until I hold down the power button, plug in the charger, and power on again. And then it comes right back up!

I spoke with Dell technical support and their stance was that since the laptop shipped with Windows, they can't provide support. So I reinstalled Windows 10, and frustratingly, the problem isn't there. I was hoping it was an obvious hardware problem that could be repaired.

I know Dell ships this model with Ubuntu 18.04 installed, so I know the hardware 'should' be able to work in that configuration. However, Dell has their own customized Ubuntu image. Because my system shipped with Windows, I don't have access to an official Dell Ubuntu image that would likely contain any needed patches/fixes, if the issue truly is limited to software.

My main concern is that I'm coming up on 30 days with this laptop. If I can't gain confidence that it's going to work in the long term, I'd rather send it back and eat the cost of restocking rather than risk being stuck with a laptop that's not fit for purpose. Is anyone out there running a stock (non Dell customized) version of the latest Ubuntu on the Precision 7540? If so, do you see this same issue?

3 Posts

November 17th, 2020 00:00

It seems as with the most recent BIOS Revision 1.14.4 (13 Nov 2020) in combination with most recent intel-microcode package version 3.20201110.0ubuntu0.18.04.2, the issue is resolved: system boots fine, no workarounds or package downgrades necessary anymore. 

 

4 Posts

December 8th, 2020 07:00

last time updated bios firmware

Vendor: Dell Inc.
Version: 1.10.2

alse solved the problem on my p7740

Moderator

 • 

25.2K Posts

February 7th, 2023 23:00

Welcome to Dell Social Media Support.

Could you private message us the Service Tag, so we can look into this for you right away? You could refer to the below link to find the Service Tag: https://dell.to/3x6MksV

1 Message

February 7th, 2023 23:00

I am using OptiPlex 5000 with BIOS 1.8.2 ubuntu 22.04 installed . i tried to upgrade kernel from 5.15.0-58-generic to 6.1.8 . It end up with below message  loading 6.1.8   loading initial ramdisk . It got stuck here.

Grub details


GRUB_DEFAULT='Advanced options for Ubuntu>Ubuntu, with Linux 6.1.8'
GRUB_TIMEOUT_STYLE=menu
GRUB_TIMEOUT=10
GRUB_DISTRIBUTOR=`lsb_release -i -s 2> /dev/null || echo Debian`
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash dis_ucode_ldr"
GRUB_CMDLINE_LINUX=""

No Events found!

Top