Start a Conversation

Unsolved

JD

1 Rookie

 • 

1 Message

592

February 20th, 2024 11:20

SupportAssist 4.0 installer installs version 3.14 on some PC's

We are getting the "SupportAssist is unable to connect to the Internet." error in SupportAssist 3.14.

Dell Support told us that version 4.0 resolves this problem.

Because of this error it is not possible to upgrade to version 4.0 within version 3.14.

So we uninstalled version 3.14 and have downloaded the SupportAssist 4.0 installer.

After installation of this version we can now update our drivers again. Finally!

But on some PC's version 3.14 is installed with this new 4.0 installer. 

Any idea how to fix this?

1 Rookie

 • 

2 Posts

February 20th, 2024 13:08

Same here. Old version tells me it is up to date (version 3.14.2.45116) when I know it isn't. And it continues to give an error when checking for drivers and downloads (see screenshot attached here). This has been occurring for at least 2-3 days. ANYONE got any idea on when this issue will be fixed?

1 Message

March 2nd, 2024 22:02

Support Assist trys to run the downloads & drivers update, fails with error saying can't connect to internet.  It shows the date it last ran as 2/16/24 (the last time I ran it).  Clicking "fix it" in support assist returns "interent is working" (and it is working for other apps on this Win 10 Inspiron 5482.  Under about/version in support assist it displays  "version 3.14 trying to connect to Internet" and spins/never finishes.  I attempted to uninstall support assist and then reinstall it.  The uninstall said "support assist is uninstalling" and never finished.  I then searched for it from windows and it did not appear.  I went to Dell and and downloaded support assist.  the reinstall exe ran but then disappeared (support assist window closed and icon in the tray disappeared).  I rebooted the pc and tried again (downloading, then running the exe).  This time it worked/opened support assist, but the version was still 3.14 with the same error when running downloads and drivers (unable to connect to internet).  Since I was logged into dell, I ran the download & drivers check for my pc from the browser.  It finished and said there were none available.  

No Events found!

Top