Start a Conversation



1 Message


July 3rd, 2019 16:00

XPS 13-9380, SA, pushing Intel Chipset driver

This was posted in a few threads but with no resolution, so I'm starting a new thread.

I have a new (couple months old) XPS 13 9380. Every time I run SA (SupportAssist) it tells me that the Intel Chipset Device Software Driver needs to be updated to version 10.1.17903.8106. However, after installing and restarting, SupportAssist prompts to install it again. It appears that the installation failed, even though there were no errors.

I am upgrading this driver only because SupportAssist has listed it as needing an upgrade; I am not experiencing any system problems. So this is not an emergency, but it would be nice to fix.

The last time I tried to install it I downloaded the exe and ran it directly (Intel-Chipset-Device-Software-Driver_KK6C2_WIN_10.1.17903.8106_A07_01.EXE). After it ran, it prompted me to open the logs, which I did and then saved to a permanent folder. There is a lot in there, but some error messages stand out, e.g. Exception occurred: System.Exception", "Message: An error occurred when calling DriverPackageGetPath." I can send these logs directly to someone from support if needed (I don't want to post them here as I don't know if they contain any PII).

1 Rookie


4.3K Posts

July 3rd, 2019 17:00

The release date on the driver was April 2nd and updated 2 Jul.  You might check for the device and see what version it is currently running.

Chipset drivers can be confusing since they seem to have the same description for different actual devices.

Support assist has had problems in the past by recommending a driver that was already installed.

The install log should have some type of return code as to successful or not.  If it is saying can get some path, perhaps an anti-virus is involved.

I don't know if seeing the log would help, but it is a text file, you could delete anything you think might be personal.  I do not know if you could send it to me directly in a private message.

2 Posts

August 19th, 2019 06:00


Did you found a solution to stop Support Assist prompting for the update? (Intel-Chipset-Device-Software-Driver_KK6C2_WIN_10.1.17903.8106_A07_01.EXE).


Same issue here. Marked as installed, but shows the update as available every day... 



No Events found!