Start a Conversation

Unsolved

D

1 Message

466

October 2nd, 2022 10:00

Vostros 5890 Will Not Aloow Rip of DVD Movies

***** Note: In accordance with the Fair Use Doctrine what I am attempting to do is permitted for my personal use so please spare me any comments about legality as I am well within my rights to do what I am proposing. *****

I have a <1yr old 5890 and I am trying to use to make copies of DVDs that I own so I can place them on a media server in my home so my family can watch on our internal network without having to handle and possibly ruin my disks...kids have a tendency to do that.

The ripping software and process that I use works well on an x86 clone which is also <1yr old running the same Windows 10 OS and release as the 5890. Again no issues with the x86 I built.

I took the external drive I used with my clone system and tried it on the 5890 again no luck. I then tried another DVD drive on the clone which worked fine but when xfrd to the 5890 again get the same issue.

The conclusion I have come to is that Dell has somehow placed a DRM lock or other restriction on the 5890 which is preventing me from legally ripping my disks.

I am reaching out to the community to confirm my suspicions and find a way to resolve the roadblock.

Thank you in advance for your input.

402 Posts

October 5th, 2022 14:00

Can you provide some details about your "ripping software and process" and the errors you receive?

FWIW I also have a 1-year-old 5890. I use MakeMKV regularly to rip DVDs, and except for DVDs that use esoteric copy protection technology (e.g. Disney) it works great.

402 Posts

October 12th, 2022 19:00

I just remembered something which may be relevant, especially since you have the same model as I have.

I had problems getting optical disc authoring utilities like ImgBurn to run properly with the 5890's internal optical drive. The author of ImgBurn advised me to switch the SATA AHCI driver from Intel's to Microsoft's, and it solved my problem with no ill effects. For the 5890 the Intel SATA AHCI driver is part of the Intel Rapid Storage Technology driver package, which enables RAID capability on the system. Don't do the following unless you're sure RAID mode is not turned on in BIOS. To check, restart the system. When the screen blanks, press F2 repeatedly until the Dell logo appears and you see a message in the upper right that you're entering BIOS setup. In BIOS setup, click Storage in the menu on the left. At the top, under "SATA Operation", "AHCI" rather than "RAID On" should be selected. Don't change the setting; just click EXIT at the bottom.

If "RAID On" is selected, there's a procedure to safely switch it off which we can dig up if you need it. If "AHCI" is selected, you can switch to the Microsoft SATA AHCI driver as follows:

  • Once Windows is running again, search for and open Device Manager.
  • Double-click the type "IDE ATA/ATAPI controllers" to reveal the device entry within.
  • Double-click the device entry, which should be something like "Intel(R) 500 Series Chipset Family SATA AHCI Controller" followed by a driver version and date. This should show a Properties window.
  • Click the "Driver" tab, then "Update Driver", "Browse my computer for drivers", and "Let me pick from a list of available drivers on my computer".
  • Select "Standard SATA AHCI Controller" (Microsoft's driver), then "Next".
  • "Windows has successfully updated your drivers" should be displayed, indicating that the Microsoft driver has been installed.
  • Close the window and Driver Manager, and reboot.

8 Wizard

 • 

17K Posts

October 12th, 2022 20:00


@DeadEndK1d wrote:

 

The conclusion I have come to is that Dell has somehow placed a DRM lock or other restriction on the 5890 which is preventing me from legally ripping my disks.

 


No, there is no DRM lock. Keep looking for problem.

I can tell you that those thin laptop optical drives are pretty lame. Check for some of my related posts in XPS Desktop forum.

For software, either MakeMKV or DVDFab should work as that is what I use (with a nice 5.25inch LG BD Burner/Ripper). 

 

No Events found!

Top