Start a Conversation

Unsolved

Closed

EG

21 Posts

534

May 17th, 2023 06:00

Adding new vxrail host to existing host

We have one cluster and i want to add two vxrail host to existing vxrail cluster when add the host first valdation is pass when rich NIC Configuration show this error kindly request please help me ASAP 

 

 

ermiasgirma_0-1684330714863.png

 

Moderator

 • 

631 Posts

May 17th, 2023 10:00

Hi,

Thank you for your question. Which model of device are you adding? Typically this is caused by the name of the distributed virtual switch being different on one of the nodes.

If this issue occurred, please run the below command to obtain all the node's information.

curl -k -H "Content-Type: application/json" -X POST -u 
 
  :
  
    --unix-socket /var/lib/vxrail/nginx/socket/nginx.sock -d '{"query":"query {cluster(moid : \"
   
    \") {host{name hardware{systemInfo{serialNumber}}config{virtualNicManagerInfo{netConfig{nicType selectedVnic}}network{proxySwitch{dvsUuid dvsName hostLag{lagKey lagName uplinkPort{key value}}spec{backing{pnicSpec{pnicDevice uplinkPortKey uplinkPortgroupKey}}}uplinkPort{key value}}}}configManager{networkSystem{networkInfo{netStackInstance{name ipRouteConfig{defaultGateway}}}networkConfig{vnic{device spec{ip{ipAddress subnetMask}distributedVirtualPort{portgroupKey}}}}}}} network{moid name backingType config{key type defaultPortConfig{vlan{vlanId}uplinkTeamingPolicy{uplinkPortOrder{activeUplinkPort standbyUplinkPort inherited}}}distributedVirtualSwitch{name moid}}}}}", "variables":null,"operationName":null}' 
    https://dell.to/42IGrjP
   
  
 

In the command, please replace the value with the below interpretation​​​​​.

  • The value of , , should be replaced based on the running cluster information.
  • The " " is cluster MoRef ID: vc_mob/content/rootFolder/childEntity/hostFolder/childEntity(domain-xx)
  • The " , " is VxRail Manager's root credential

This command displays all the cluster information in JSON format.

Filter the contents of the output, and compare dvsName value of the hosts to identify the host with different DVS name with other hosts. (Even dvsUuid values of the hosts are the same. )  

Correct DVS name of the host in vCenter.

 

If that doesn’t work you may also need to update SSL certificates. https://dell.to/42Lal7g

 

 

Let us know if you have any additional questions.

May 17th, 2023 11:00

Thank you for your quick response. There were three vxrial nodes in one cluster and the vxrial version was 4.07 p 570s. Two new p 670s vxrial nodes were purchased for expansion. I have upgraded all vxrail version to 7.03 One node has successfully joined the cluster. I tried to join the second node and it failed to pass. Thank

May 17th, 2023 22:00

Kindly remind please its urgent   iam appreciate your kind response 

Moderator

 • 

8.5K Posts

May 18th, 2023 05:00

Did you do the steps that I had in my previous response? Also if it is urgent please use phone support. 

No Events found!

Top