Start a Conversation

This post is more than 5 years old


Go to Solution


December 19th, 2016 11:00

Can't install Windows 10 from bootable USB with UEFI - Dell Latitude E7470

Hi there,

I've really been struggling with this: I'm trying to install Windows 10 from Dell USB drive that I've made bootable, but it's only seen in the legacy options in the one-time boot menu. Secure boot is off and UEFI is enabled. I need the USB to be recognized as UEFI in order to install Windows to boot to UEFI. I'm using Rufus to make the bootable drive and I've tried both MBR and GPT partition scheme for UEFI with no luck. Is there any BIOS settings I need to check? 

1 Rookie


4.3K Posts

December 20th, 2016 07:00

One thing folks may not realize is the Flash Drive has to be formatted as FAT 32 in order to boot as UEFI..

It also has to be an x64 version of the OS.

The tool recommended will create such a flash drive but downloading directly to a Flash Drive can be slow.


Updated Videos:



Clean Install:


8 Wizard


47K Posts

December 30th, 2019 08:00

The media must be at least 16 gigs and not larger than 32 gigs and USB 2.0.

This is why I recommend using USB 2.0 optical drive and OEM system builder DVD for reinstall.

It also means that ISO must be burned to DUAL Layer DVD media because the base installer is no longer smaller than 4.7 gigs.

Why the limit?
The 4 GB barrier is a hard limit of FAT32: the file system uses a 32-bit field to store the file size in bytes, and 2^32 bytes = 4 GB (actually, the real limit is 4 GB minus one byte, or 4,294,967,295 bytes, because you can have files of zero length). This means that you cannot copy a file that is larger than 4 GB to any plain-FAT volume. This means that past 1803 the WIM file is TOO LARGE for a FAT32 flash drive.

You can use exFAT or NTFS on newer models, however older systems are NOT able to boot from external boot media using NTFS.

For these models it cannot be exfat and larger than 32 gigs or usb 3.X drive.


The WIM file for WINDOWS 1809 and 1903 and 1909 are TOO LARGE for FAT32.

8 Wizard


47K Posts

August 29th, 2020 17:00

Newer versions of windows





INSTALL.WIM is larger than 4 gigs so it cant be copied to USB flash on 64 bit versions.

This was not an issue with 1803.

Media creation tool seems to do fine with FAT32  16 OR 32 GIG usb2 MAX

Force update now TO 2004

2004 media creation tool.


8 Wizard


47K Posts

August 29th, 2020 17:00

PCI-E M2 Sata is not native to windows for many vendors.  Fixing the BCD may also be required as may be safe mode and use of diskpart.

You have to install F6 mass storage Drivers aka PRE INSTALL drivers or it WILL NOT see the drive.

You CANNOT point to an EXE or ZIP or Cab file it must be extracted to the USB flash.


This driver supports Samsung NVMe SSD 970 PRO, 970 EVO, 970 EVO Plus, 960 PRO, 960 EVO and 950 PRO.

NVMe Driver Installation Guide

Windows had a problem
Inaccessable boot device.
A required CD/DVD driver device driver is missing. If you have a driver floppy disk, CD, DVD, or USB flash drive, please insert it now.
Error 1: Windows Cannot Be Installed to This Disk. The Selected Disk Is of the GPT Partition Style.

Error 2: Windows Cannot Be Installed to This disk. The Selected Disk Has an MBR Partition Table.

Error 3: Windows Cannot Be Installed on Dynamic Disk.

Error 4: Windows Cannot Be Installed to This Disk. This Computer's Hardware May not Support Booting to This Disk.

Error 5: Windows Cannot Be Installed to This Disk. The Disk May Fail Soon.

Error 6: Windows Cannot Be Installed to This Hard Disk Space, Windows Must Be Installed to a Partition Formatted in NTFS.

380 Posts

December 20th, 2016 01:00

Download the Media Creation Tool from Microsoft


and use that to create the bootable Windows installation disk.


December 21st, 2016 09:00

Thank you! It was set as NTFS unti lI saw this and now I can boot with UEFI now.

30 Posts

July 14th, 2017 23:00

How to install with UEFI, USB, and .ISO image:

• Download Rufus:

• Select GPT partition scheme for UEFI:

• Turn off SecureBoot (temporarily)

• Install

• Enjoy

August 2nd, 2017 21:00

I did that and windows still says that must be gpt partition. If it is an .iso file, how am I suppose to format as fat32 vs ntfs?

1 Message

April 27th, 2018 03:00

Use 7zip to expand iso into a folder, run cmd as admin, use diskpart to clean, create primary partition, format fs=fat32 quick, set to active, exit, then, while still in CMD, xcopy  *.* /s  from that folder to your USB.

September 24th, 2018 07:00

 Hi Team


after some inquiry finally for model E6420 did work on Rufus, but just changing in file system to FAT32, Thank you

1 Message

October 13th, 2019 12:00

I Recommend to try other flash drive.

December 27th, 2019 20:00

Since Windows 10 v1909 the ISO is 5GiB and there is a file it's more than 4GiB and FAT32 only support upto 4GiB, if i create a USB Bootable disk using NTFS it's not working, any solution?

1 Message

May 18th, 2020 13:00

My system is Vostro 260, and it only worked with a flash drive formatted as NTFS.

August 18th, 2020 16:00

Thank you for the explanation and links, @speedstep I was finally able to create a bootable thumb drive with the Windows 10 1909 Pro ISO that my e7270 recognized!

However, after installing 1909, the BIOS/UEFI doesn't recognize the M.2 SATA SSD.  It's flat out not visible in the configurations.  Do you have any idea why this might be?  I have tried updating the BIOS to the most recent, rolling back to earlier ones, and several in between, with no change.  The M.2 box is checked as one of the drive types available.  But in system configuration it's not listed. 

August 19th, 2020 08:00

I finally got it to work!  I ran the Dell pre-boot system assessment, and the M.2 checked out OK.  So I compared the boot sequence in this laptop to a known good one.  I ended up having to manually add a boot option.  So in case anyone else runs into this, in the BIOS/UEFI, under Settings\General\Boot Sequence, click Add Boot Option. Pick the File System List that includes, anywhere in that string, the Sata SSD (the Latitude e7270 M.2 is SATA, not PCIe).  Click the ... to the right of File Name, and navigate to this:  \EFI\Microsoft\Boot\bootmgfw.efi  Give the boot option a name and click Ok.  Pick the boot option you just created as the first in the boot sequence.  Apply, and exit. It took extra long to boot up that first time, but I finally got the the initial Windows setup and it's working great!

No Events found!