Start a Conversation

Solved!

Go to Solution

1010

February 24th, 2023 06:00

SGX Not Working

Hello
I have installed the latest (1.21) version BIOS for the computer with Dell Wyse 5070 J4105 processor. I activated SGX. I installed Ubuntu 20.04.5, kernel 5.15.
But it gives SGX error; SGX_ERROR_UNRECOGNIZED_PLATFORM
Any chance we can fix this error?

3 Posts

March 2nd, 2023 01:00

Hello
I removed the Jumper on the motherboard, problem solved

176 Posts

February 24th, 2023 07:00

@Rho The SGX_ERROR_UNRECOGNIZED_PLATFORM error can occur due to various reasons, such as outdated drivers, incorrect system configuration, or unsupported hardware. Here are some steps you can try to resolve the issue:

  1. Check for the latest available graphics drivers for your system and install them.

  2. Ensure that your system meets the minimum hardware requirements for SGX support, including having a compatible processor, chipset, and graphics card.

  3. Make sure that the SGX feature is enabled in the BIOS/UEFI settings of your system.

  4. Verify that the SGX feature is supported by your operating system and that the SGX module is loaded in the kernel.

  5. Try using a different operating system that supports SGX, such as Windows 10 or a Linux distribution that has SGX enabled in the kernel.

  6. If all else fails, you may need to contact Dell support for further assistance.

It's important to keep in mind that SGX support and compatibility can vary depending on the system, operating system, and configuration, so it's important to check the specific requirements and compatibility for your setup.

3 Posts

February 25th, 2023 00:00

Hello Evongsmx
Thank you for the answer.
I don't think the SGX has anything to do with the graphics card. There is no graphics card in the system.
I tried over and over for Ubuntu 18 - 20 and 22. It gives the same error on all of them.
Currently, such a problem does not occur on my other 4 computers with DELL Wyse 5070 J5005 processors. but it gives this error on the computer with J4105 processor. Both computers are using the same BIOS.
I'm wondering if the motherboard of the version with the J4105 processor may have never allocated memory for the SGX?
The image of the error I got for SGX is attached.Ekran görüntüsü 2023-02-23 112955.jpg





346 Posts

April 19th, 2023 02:00

An Intel SGX capable processor
A BIOS that supports Intel SGX and the software enable procedure. Some BIOS manufacturers provide an option to explicitly enable or disable Intel SGX.
A supported Linux distribution that has been booted in UEFI mode. Systems booted in Legacy mode cannot perform the software enable as the procedure depends on EFI variables. A Legacy mode system can be enabled by booting a Linux Live CD in UEFI mode, and then performing the software enable. Intel SGX enabling occurs at the platform, not OS, level.
The EFI filesystem, which should be mounted by default if your Linux system is booted in UEFI mode.

No Events found!

Top