Start a Conversation

Unsolved

I

2 Posts

3309

June 7th, 2020 09:00

Dell XPS 13 9300 - Shutdowns after OS start when unplugged

Hello,

Yesterday I have bought a recent XPS 13 9300, and today found out it sometimes shuts after unplugging. It can be immediate or take some time.

 

Additional problem info:

- It only happens when NOT connected to the charger (AC)

- It only happens when under startup process or sudden load (CPU goes over 3.0GHz what is I think it shouldn't do without charger)

- It shows "ASF2 force off" and then "WDT" errors in BIOS logs

- Max clock speed is 1.5 GHz, min 0.4 GHz, current 3.5 GHz (in BIOS)

- No thermal event logs in BIOS

- Upgrading BIOS (.6 -> .11) or drivers had no effect

- Safe mode does not cause shutdowns (CPU capped at 1.5GHz)

- Boot menu works fine without AC

- Windows Event Manager had no logs about shutdowns or about launches without AC

- All possible dell diagnostics (SupportAssist in BIOS or as an app) show no errors

- Nor full Windows reinstall nor install of Manjaro helped

 

Does anyone have any idea what might cause this?

My thought is that is caused by some kind of CPU management under OSes which windows safe boot can bypass (it doesn't slow down without charger or after unplugging charger and that maybe generates a response to shutdown)

And yes, when I say shutdown I don't mind proper one, the laptop just turns off in instance some times keeping the keyboard lights on

But step Disabling turbo boost OR disabling speed step & shift keeps it stable CANT be reproduced

Moderator

 • 

25.3K Posts

June 7th, 2020 09:00

Thank you! We have received the required details. We will work towards a resolution via private messages to ensure the security of your information. In the meanwhile, you may receive assistance or suggestions from the community members as well.

1 Message

August 11th, 2020 13:00

I have this problem too - seems to be manifesting in the same way.

Did you find a solution?

1 Message

August 19th, 2020 14:00

Can you please share the solution with me, i have the same exact problem and i just bought the device 

1 Message

August 20th, 2020 14:00

I have the exact same problem with a brand new xps13 9300. Any idea how to fix it?

1 Message

September 2nd, 2020 11:00

I have exactly same problem - is something new?

2 Posts

September 13th, 2020 17:00

Disabling C-State control from BIOS  fixed the issue.

Moderator

 • 

109 Posts

September 13th, 2020 20:00

Hello,

That's great news. Thanks for sharing this update with us. Should you need any assistance, feel free to reach out to us. 

2 Posts

September 14th, 2020 05:00

Sorry, but I can't confirm that. I gave my laptop to an authorized centre a month ago and still haven't received it back. They are trying to change the motherboard, although I insisted on a complete laptop replacement.

The solution may be temporary because once I managed to get it fully working without errors for a month and after a break for an additional month it came back again and my fixes didn't help (that's why I gave up)

2 Posts

September 14th, 2020 05:00

I think you need to contact the original post owner @ibvfteh and confirm the issue is resolved on their using the C-State workaround. Then release a BIOS patch. Disabling C-State is just a temporary workaround to make the laptop usable. Not a solution to the actual problem.

Moderator

 • 

25.3K Posts

September 14th, 2020 05:00

Hi,

 

Prajwal here from Dell community.

I'm glad to hear that the issue is resolved after the changes made in BIOS.

As the issue is resolved, we'll be archiving the case from our end.

Feel free to drop us a message if you need any further assistance.
We'll be glad to assist you.

 

Prajwal

1 Message

October 6th, 2020 15:00

Having the exact same problem with same laptop. Spent 2 hours on phone to Dell but still no fix. Has anyone managed to find a solution without disabling C-state? Don't really want to do this as its obviously quite a useful feature.

December 3rd, 2020 21:00


Hi. I have just encountered the same case. I downloaded the intel rapid storage technology driver from Dell home page and installed it then and after disconnecting with the adater my laptop doesn't turn off anymore. Hope this works with your laptop. 

December 3rd, 2020 23:00

Oh No. It still turns off after restarting several times. But disabling C-State has kept it from shutting down. 

2 Posts

May 25th, 2023 03:00

Hi all,

Same issue here, made the pc run from few hours then again, booting didn't work, pressed the button and after 5 sec complete turn-off !

I have tried all (BIOS settings, remove battery, etc...) indeed didn't work...

Last resort: removed old (dried out) cooling paste from the processor. Applied new paste. PC runs like a charm ! No more unexpected shutdowns. 

I just needed to mention this as I never found a final sollution on this topic !

 

Greetings, ER.

No Events found!

Top