Start a Conversation


Go to Solution


10-11-2020 02:00 AM

XPS 13 9310, Ubuntu, deep sleep missing

My computer drains a lot of battery when in sleep mode.

I've tried following the steps outlined in this bug report, tried the diagnosis layed out in this question and disabled the "sign of life" options in the BIOS as described here.

I confirmed my system sleeps in the `s2idle` state. Which I suspect is the problem.

$ sudo journalctl | grep "PM: suspend" | tail -2
May 13 18:41:00 mex kernel: PM: suspend entry (s2idle)
May 13 20:52:36 mex kernel: PM: suspend exit

However I have 2 issues when trying to follow the above guides: Firstly my `/sys/power/mem_sleep` file does not contain a `deep` option:

sudo cat /sys/power/mem_sleep

And secondly I can't seem to edit the file to add a `deep` option:

$ echo deep | sudo tee /sys/power/mem_sleep
tee: /sys/power/mem_sleep: Invalid argument
$ sudo sh -c 'echo deep > /sys/power/mem_sleep'
sh: 1: echo: echo: I/O error

Not being able to close the lid and have the laptop suspend is very annoying. Any help on this would be greatly appreciated.

OS: Ubuntu 20.04, 5.8.0-26-generic / Hardware: Dell XPS 13 9310

Community Manager


53.2K Posts

19-10-2021 06:00 AM

The S3 deep sleep mode is not available on the XPS 13 9310. This is by design.

When using a Dell Ubuntu image, the battery discharge issue was resolved with kernel update to 5.8. However, there will be some amount of battery discharge due to the Connected / Modern Standby feature. If there are any issues with battery draining with the Dell Ubuntu image, reply to the private messages sent to you by the DELL-Cares agent on your unique case number with the Service Tag, issue, etc.



24.6K Posts

10-11-2020 10:00 AM

Thank you! We have received the required details. We will work towards a resolution. In the meantime, you may also receive assistance or suggestions from the community members.

1 Message

11-11-2020 08:00 AM

Dell has removed deep sleep support on newer machines afaik. I have the inspiron 14 7405 and am stuck with s2sleep as well. Battery drain is really bad with it too.

24 Posts

11-11-2020 08:00 AM

I have the identical situation. What do I need to do to be kept in the loop when a resolution is found?

47 Posts

11-11-2020 16:00 PM

I had the same problem running Arch Linux on my XPS 13 9300 model but it has been fixed since I added the `mem_sleep_default=deep` boot option. I also have both "sign of life" options and TPM disabled in the BIOS.

24 Posts

11-11-2020 18:00 PM

That is encouraging news. Any guesses as to how to add the `mem_sleep_default=deep` boot option in Ubuntu 20.04? Google has not been very friendly to me in this case. 


47 Posts

11-11-2020 20:00 PM

Depends on your boot-loader. I use systemd-boot but you are probably using grub, so read or similar.

9 Posts

12-11-2020 01:00 AM

Thanks for all the insights. and sorry to see that so many others share the pain...
I've learned from this thread here that this actually is a firmware issue. where dell chose to not include deep sleep in this computer's firmware. if so i would find that very disappointing, i can't think of a single reason why anyone would appreciate a default battery drain on his suspended laptop. i'm not sure i would have purchased the device if i had known...

@bulletmark If indeed it is a firmware issue, then i doubt the boot option would help. or am i wrong?
also: before you set the boot option, did file `/sys/power/mem_sleep` contain a `deep` option which was just not selected or did it only contain the `s2idle` option? I would assume deep was present, but not selected, so your file would have looked something like this: 

sudo cat /sys/power/mem_sleep
[s2idle] deep


47 Posts

12-11-2020 03:00 AM

Yes, after booting without the `mem_sleep_default=deep` kernel option:


sudo cat /sys/power/mem_sleep
[s2idle] deep


Booting with the that option:


sudo cat /sys/power/mem_sleep
s2idle [deep]


9 Posts

12-11-2020 06:00 AM

yes, that's the difference. 

my file only displays 1 option: 

sudo cat /sys/power/mem_sleep

this is what the new firmware apparently is lacking...

FYI the link i described in the intro text gives alternatives to changing the boot menu

47 Posts

12-11-2020 14:00 PM

There is an option in the 9300 BIOS "Disable Sleep". If I set that to on (i.e. disabled which is not the default setting) then I only get the s2idle option shown in /sys/power/mem_sleep like you. I presume you 9310 guys don't have that BIOS option? If so, then is seems the "disable sleep" BIOS option is default and non-changeable for you which seems odd.

9 Posts

13-11-2020 07:00 AM

I can confirm what @rjl-csun mentioned. On my 9310 I also have the "block sleep" option. It is set to off, but i only have the `s2idle` option available in /sys/power/mem_sleep 


24 Posts

13-11-2020 07:00 AM

I recently upgraded the BIOS (to 1.1.1) and there is an option called "Block Sleep" which says: "This option lets you to block (sic) entering Sleep (S3) mode in the operating system. Note: When Block Sleep is enabled, the system won't go to sleep, Intel Rapid Start will be disabled automatically, and the operating system power option will be blank if it was set to Sleep."

Mine is set to off so I would assume I should have S3 sleep, but my /sys/power/mem_sleep file only shows [s2idle].

24 Posts

14-11-2020 06:00 AM

A final (?) somewhat related followup. The past 2 days I tested s2idle just to see how bad or good it was. I fully charged my battery, did a couple of little things on the machine and closed the lid with the battery at 99%. I'd open it every couple of hours to see how the battery was doing and fire up a couple of programs to confirm all was well. About 20 hours later the battery was at 82%. That seemed pretty good and I decided not having s3deep was not a problem.

But then my final check about 4 hours later, it had dropped from 82% to 17%. I have no idea why? Anybody have a theory? s2idle problem after all? Some other sleep problem? This is very annoying!

9 Posts

16-11-2020 01:00 AM

i can confirm part of what you wrote @rjl-csun 

i tested sleep again for around 24h by closing the lid without power connection. the battery had only dropped to 91% whereas when I started this thread it would be very low or dead after such an amount of time.

now either i had a different set of programs running at the time (and something prevented sleep), or the changes in the bios (disable sleep: off, etc..) helped even though there still is only the `s2idle` sleep option in the mem_sleep file...

As to your subsequent drain, I don't know... 

what would be good software to track battery drain even while sleep? - is that output available somewhere?