Start a Conversation

Solved!

Go to Solution

18135

March 16th, 2022 13:00

XPS 15 9500 4k Video Playback Problems

I have the Dell XPS 15 9500 4k and have been having issues with streaming 4k video.

Basic spec:
9500 4k Touch Screen
Intel 10750H
16 GB RAM
1650 TI


The Problem:
The laptop is now unable to stream 4k from Netflix/Disney Plus. 4k YouTube video very jerky and unwatchable.

I want to see if anyone else has this problem and go over what Dell has done so far. This is our 4th XPS 15 Laptop we bought for work (this is the only 4k model though). Really like them so this isn’t a “slag off Dell” post. Just wanted to write up where I am with it. Sorry for the long post.

When new (bought in late 2021), this laptop played Netflix 4k films fine using the Netflix app. When you go into Netflix and select a film (say 6 Underground), the info shows its Dolby Vision - Atmos. It played the film in full 4k, HDR etc. This can be checked by pressing CTR, SHIFT, ALT, Q when the film is running to pull up the nerd info from Netflix. Here it shows it’s running in 4k etc. Disney Plus app also worked fine in 4k.

Using Edge browser to open Youtube and run a 4k 60 FPS video was also fine. Stats for nerds showed no dropped frames here, great video smooth playback.

A couple of months on I’m not able to play 4k films in the Netflix app, get Netflix Error U7361-1255-8004CD22. Select the film and the info shows its Dolby Vision – Atmos so it should be able to run in 4k but won’t.

YouTube will play the same 4k 60 FPS video but it's jerky and unwatchable, stats for nerds show its dropping frames constantly.

The only thing that’s changed on the laptop is updating the windows updates and the Dell driver updates. As of writing, ALL bios, driver, windows updates are done.

The Intel Graphics Command Centre says the display is NOT HDCP compatible.

I’ve spoken to Dell, they confirmed the machine is HDCP 2.2 complaint. They thought the motherboard was faulty so sent a tech round to replace it. We replaced the mobo and put in the same Hard Drive and booted it up. Netflix was now able to run a 4k film, but it was jerky, out of sync with the sound and basically unwatchable. YouTube 4k test video was just as bad as it was before. The Intel Graphics Command Centre still says the display is not HDCP compatible.

The Dell Support software found a new bios update for the motherboard, so we flash the bios and install it. Reboot the laptop and now Netflix and Disney Plus won’t play the 4k movies. They throw up the same error codes that mean there’s a problem with HDCP (Disney Plus is error code 39 I think)

I decided to do a full Windows restore and wipe the computer and reinstall windows 11. Fresh install with all the relevant updates and the same problems. Same error codes on Netflix and Disney Plus. Same problem on Youtube 4k video playback.

Dell has offered to replace the laptop but as the 9500 is no longer made, they offered the newer 9510. The problem is they don’t have the 4k screen model so was only able to offer the basic entry model. Whilst I appreciate this, I do need the 4k so as of now I’m waiting for that to become available but it's looking like it will be months before a replacement is offered.

I would be happy to keep my current laptop if there was a way to fix it but as of now, we can't seem to do that.

Does anyone else have this issue or do just have a faulty laptop that needs replacing?

54 Posts

October 22nd, 2022 14:00

Well, the reports coming in suggest this issue is now fixed. It took a year but Dell finally got it sorted. So I think I'm happy to mark this problem as resolved.

Thanks to everyone that contributed to this thread and I'm glad the laptops can finally do what they were meant to be able to do.  

Community Manager

 • 

2.3K Posts

February 8th, 2023 06:00

I realize this is an older thread, but in case anyone is still having trouble, please update the system BIOS and it will resolve this.

Here is a link to the latest BIOS Version 1.19.0, but BIOS version 1.18.0 addressed this. 

Moderator

 • 

25.4K Posts

March 17th, 2022 07:00

We tried reaching you on a private message asking for the Service Tag number to ascertain the warranty but did not receive a response. Please feel free to reply to the private message whenever you are available.

54 Posts

March 17th, 2022 08:00

Info sent.

Moderator

 • 

25.4K Posts

March 17th, 2022 08:00

Thank you! We have received the required details. We will work towards a resolution. In the meantime, you may also receive assistance or suggestions from the community members.

2 Posts

March 23rd, 2022 07:00

I am facing exactly the same problem. After some recent updates, when I try to play a video in Netflix, I get the U7361-1255-8004CD22 error. Intel Graphics Command Center shows HDCP not compatible.  Please help. 

54 Posts

March 23rd, 2022 09:00

I still have not found a solution I'm afraid.  As an update, they have offered to replace my 9500 with the new 9510 but for the last few weeks, they do not have the new machine in stock. I've been told to check back in a few weeks to see if stock is available. I'm happy to wait for a suitable replacement to come back into stock and I do appreciate what they are doing but I hope it's only a matter of weeks and not months. 

2 Posts

March 24th, 2022 05:00

I just received a private message from Dell saying "Our records indicate that the system warranty has expired."

However, it was Dell's updates that created the problem. 

March 28th, 2022 12:00

i have the same problem with my Dell XPS 17 9700 4k touch 

6 Posts

April 3rd, 2022 06:00

I have exactly the same problem with my XPS 9700... Followed all the steps, installed various drivers from Intel directly and Dell, nothing helps. I am able to stream via my dedicated Nvidia GPU but this drains the battery + is very buggy. @DELL-Cares Please fix this.

April 4th, 2022 08:00

Did you guys get the solution because I am also facing same problem 

57 Posts

April 5th, 2022 06:00

Also have the same problem.

To my recollection, the built-in display always has shown up as non-HDCP compliant according to the Intel graphics driver, but in the beginning there was no issue (only that dolby vision processing cost so much GPU processing that 4K playback with HDR enabled stuttered constantly and was unusable).

I also tried a lot of DDU and different driver versions, but nothing represented a longterm solution. I was too lazy to reinstall the machine and test with Win 10 again (I am also on Win11).

For a while I found that 4K playback was not possible at all with newer than Dell's officially supported iGPU driver, but now I am running 1660 and it works the same as the official one, but without the huge memory leaks.

I have used the Cyberlink UHD Blu Ray Compatibility Tester, because that checks if the entire system is HDCP 2.2 compliant, which is required for Netflix 4K playback and it is (according to Cyberlink, which has been reliably detecting incompatible displays / docks on all my devices so far).

My workaround: if I attach an external display that is HDCP 2.2 compliant and also detected as such by the Intel driver and restart the Netflix app, it works for a while (an entire movie) until it stops again (possibly after standby or hibernate, but nothing deterministic so far). So this is some really weird software bug either in Windows, Intels driver or Netflix. It seems to me that it gets confused by Intel listing only a non-compliant display, even though technically everything is actually encrypted. If the supposedly non-compliant monitor is no longer the only one, then the problem goes away. Even after detaching the external display and restarting Netflix again it keeps on working for a while. But some time later / the next day it will show the same error again and refuse to work again.

 

Seems to me, that Dell needs to get that Intel GPU driver fixed, because that should really see the display as compliant. Whether this would suffice to permanently solve this I do not know.

But my 9500 and my previous XPS 9Q33 have had tons of other driver / software bugs, so Dells software being severely broken and Dell attempting to solve this by ignorantly swapping HW sadly is nothing new to me.

2 Posts

April 28th, 2022 00:00

Was anyone able to resolve the Error code: U7361-1255-8004CD22 on netflix? 

2 Posts

May 1st, 2022 01:00

This problem wasn't resolved, and the screen does get a little jerky when using chrome browser to watch shows.

May 1st, 2022 08:00

I also have the same model as the OP but running a recent clean install of windows 10 and have the same Netflix 4K error and now Disney+ error 39. It did previously work for the past year so it has to be a recent update either the intel driver, Netflix app, or the HEVC extension. Uninstalling HEVC extension at least enables 1080P in Netflix but does not resolve the disney+ error. Amazon prime video seems to be unaffected.

I called the Dell support line   but they just made me do the bios hardware test and since it passed the test they would not help me any further, instead they tried to make me pay for software support. 

No Events found!

Top