Start a Conversation

Solved!

Go to Solution

28497

June 30th, 2021 07:00

XPS 15 (9500) plugged in but will not recognize it is charging

My laptop has started to not recognize that it is plugged into a power source through all three of its usb type c ports. The only way I have been able to circumvent this issues is by completely powering off my laptop then plugging in the charger, and finally starting the laptop back up. This is the only way I have seemed to be able to get it to charge. Is this some sort of BIOS error going or is there something wrong with my laptop. I use it heavily so I really need a solution to this problem before my shut down trick stops working. I've noticed a few others have this problem on here as well so is this a fix Dell is working on or a result of something else?

Moderator

 • 

16.6K Posts

April 8th, 2022 08:00

DRSch,

Update = After completing troubleshooting, a DELL-Cares agent setup a part exchange.

13 Posts

August 3rd, 2021 17:00

Took me arguing with their techs for two and a half months they replaced my main board twice (after giving bad equipment again) and it seems to work however they improperly reinstalled stuff so I’m still facing issues from the parts they replaced. Sorry but I’m still in the same boat as you. 

1 Message

August 3rd, 2021 17:00

I'm having the very same issue - I see it reported under "Charging issues with XPS 15 9500" but that was closed, blamed on the D6000 docking station, apparently.  I'm using the standard USB-c charger that came with the laptop, not the D6000.

 

Have you found a solution?  Thx

4 Posts

August 7th, 2021 00:00

Have you guys got a fix to this problem? Is this definitely a motherboard problem?

I'm also facing the same problem however it happens after another issue where my laptop is rebooting itself at the Windows login screen or when waking up from Hibernating or Lock Screen: https://www.dell.com/community/XPS/Rebooting-itself-at-Windows-login-screen-then-not-recognising/m-p/8007778#M87838

Were you also have this same issue too?

1 Message

September 20th, 2021 09:00

Dell XPS 15 9500 - Charging issues

10th Gen i7, 64GB, 2TB SSD, NVIDIA 4GB

Having the same issue:

Not Charging - charger not recognized

Need to complete drain battery before any charging happens

PC reboots 2-3 times before I can login. 

Tech remote session checked everything under the moon, BIOS, battery etc. 

Sent a tech out, who replaced my motherboard with a referub..SMH

Gave me a new charger

Worked for 6 hours, then the same issues. 

Spent a good chunk of change on this pc, thought it was a good choice

Switched form Lenovo, clearly that was a mistake.

Dell, you know about this issue, fix it.

1 Rookie

 • 

2.3K Posts

September 20th, 2021 09:00

I hardly think motherboard replacements would do the trick. All three USB Type-C ports cannot go down at the same time. None of my XPS 15 9500 units are showing this behaviour. Around 12 of them on the latest BIOS. 

This is most likely firmware bug or corrupted firmware  All affected users please perform a BIOS recovery. 

How to Recover the BIOS on a Dell Computer or Tablet

If still not working, seek a motherboard replacement.

5 Posts

September 24th, 2021 10:00

Same problem: XPS15 9500 stops charging after sleep. Only way to get it charging again is to power off the laptop, unplug and replug the USB-C.

10/25/21 = Hi, there was an update to the BIOS a few days ago, since then all seems to work well. I hope the issue won't return.

5 Posts

October 2nd, 2021 20:00

Same problem for me as well. XPS 15 9500 running Bios 1.9.1

1 Rookie

 • 

2.3K Posts

October 7th, 2021 06:00

Did any one try the solution I suggested earlier?

How to Recover the BIOS on a Dell Computer or Tablet

11 Posts

October 28th, 2021 09:00

I have tried the BIOS recovery although it doesn't seem to downgrade all aspects of the BIOS such as the 'ME Firmware' - it seems to make the issue less prevalent but it still exists - DELL PLEASE FIX THIS-  will be switching to Mac shortly if it isn't fixed as this has already cost me multiple documents which I have been working on where it will randomly restart after being in sleep for a while (and going into hibernation automatically) - FRUSTRATING! 

1 Message

October 30th, 2021 14:00

Hi could  you link the bios update? the only one I could find was months old, thanks. 

Community Manager

 • 

54K Posts

November 1st, 2021 09:00

BIOS 1.9.1 = Once the BIOS is upgraded, you cannot downgrade the BIOS to version 1.5.2 or earlier. But you should be able to downgrade back to BIOS 1.8.1, 1.7.1, 1.6.1.

2 Posts

November 2nd, 2021 13:00

This solution seems to have worked for me so far.

1 Message

November 14th, 2021 14:00

I had this same problem but it seems to be fixed by moving to the latest BIOS version "BIOS Version: Dell Inc. 1.10.0, 9/28/2021" that seems have been released about November 10, 2021. Previously had  BIOS version 1.9. Symptoms included computer complaining about incorrect charger or not recognizing the charger at all. It would recognize the charger after the battery drained completely and then successfully charge. Working now for two consecutive days.

1 Message

December 1st, 2021 06:00

I updated to the latest BIOS 1.10.0 and this issue still persists. It looks like it has been going on for almost a year now. When can we expect a definitive fix?

No Events found!

Top