Start a Conversation

Solved!

Go to Solution

13280

April 29th, 2019 07:00

XPS 15 9560, BIOS 1.14.2 breaks HDMI port

BIOS Version: 1.14.2 ,1.14.2
Release Date: 25 Apr 2019

File Name: XPS_15_9560_1.14.2.exe

Installing this update stops the HDMI port from working. I tried reinstalling display drivers for Intel and Nvidia without any luck. Rolling back to the previous BIOS update has fixed the issue for me. Is this a known issue?

2 Posts

May 28th, 2019 07:00

I was one of the original posters that 1.14.2 broke my HDMI port.  I didn't roll back but lived with the issue via a puck when in the conference rooms.  I see today that Dell has re-released the BIOS update as 1.14.3!

I'm glad to report that installing 1.14.3 fixed my HDMI port!  So far so good, everything seems to be working.

I will mention that I had to manually download and install the BIOS, the support assistant said I was up-to-date and wasn't going to install anything.  Your experience may vary.  

4 Posts

June 6th, 2019 03:00

es I confirm that the latest bios 1.14.3 fixed my HDMI port as well!

3 Posts

April 30th, 2019 12:00

Reporting the same issue.

Current configuration (before/after update):

- external USB hub attached (left side)

- HDMI cable attached

- USB-C Ethernet adapter attached

About to preform a rollback

1 Message

April 30th, 2019 12:00

Same problem, used the Dell Support page to update drivers and BIOS today and now the HDMI port doesn't work.  Tested my main LCD (AOC E2460S) and a TV in a conference room, both of which worked before.

Note that my normal setup is working with two LCD's plugged into the Dell Thunderbolt dock.

Telling my group to hold off on any further Dell/Intel/BIOS updates until this is sorted out.

3 Posts

April 30th, 2019 13:00

Confirmed:

- Rolling back to version 1.11.0 29 Aug 2018 fixes the monitor issue

May 1st, 2019 07:00

Have you tried the bios for 23rd of Oct 2018? BTW, I tried to contact customer support and got nothing from them. They told me I was out of warranty and they can't talk to me lol. They break the machine with a bios update and then they won't support me, what a joke.

May 1st, 2019 07:00

This is confirmed on my box too.

May 1st, 2019 08:00

I just rolled back my bios to OCT of 2018 and it is working

4 Posts

May 2nd, 2019 02:00

Same here, updated yesterday. And no more HDMI. :-(

3 Posts

May 2nd, 2019 06:00

Yeah, that seems to be the only way to fix it. Roll back to an older BIOS version. Haven't heard anything from support, but as this is an "Urgent" BIOS update it would be good for them to at least let someone know they are working on a fix.

6 Posts

May 2nd, 2019 10:00

April 25 bios update killed the HDMI port then May 02 update and HDMI port is still dead.... does anyone has a fix? i don't think I can roll back the bios

6 Posts

May 2nd, 2019 10:00

Same issue.

Even after second bios update release on May 02 2019 still dead HDMI port.

what is the fix for that, I don't have the old bios files anymore I am sure of that.

3 Posts

May 2nd, 2019 11:00

1 Message

May 3rd, 2019 07:00

I have the same problem after installing the 1.14.2 BIOS. I had to downgrade to the 1.12.1 BIOS to correct the problem.

1 Message

May 3rd, 2019 15:00

I wish I had found your thread early before going through all kinds of frustrating things to try and fix this. Had an important meeting only to have my HDMI port fail on me. Moved to another meeting room, thought maybe it was the TV not working. I don't know if Dell realizes that these type of software failures have real world consequences for people who rely on them and trust that their laptops will work all the time. Sigh. Sorry for venting. I hope Dell fixes this. Seems like every time I do a BIOS update I run into problems. 

No Events found!

Top