Start a Conversation

Solved!

Go to Solution

Closed

21 Posts

48097

June 17th, 2019 10:00

XPS 15-9570, TB16, USB Type-C, no longer charging

Heya,

Notebook is about 3 months old, my TB16 dock worked fine since day one but suddenly as of friday a week ago charging no longer works via the TB16 Dock.

  • I am running Linux with an option to dual boot into windows.
  • Windows behaves the same however
  • Same thing happens when in BIOS and just watching the Battery screen
  • BIOS will report plugged in and charging but percentage goes down.
  • Dock is sometimes detected as 60W (in Bios) first but then switches to 130W quickly - indicates as charging but percentage goes down.
  • Tried co-workers TB16 Dock - same thing
  • Works fine via barrel plug

What I tried

  • Disconnecting the dock for a while
  • Booting with/without dock attached
  • BIOS battery settings (standard/adaptive/quick charge on/off)
  • Holding Dock button for a minute while disconnected from power and notebook
  • Checking the plug on the power brick of the docking station - removing and replugging it while dock was running and while it wasn't

As I am running linux by default I am sure that on the day it stopped working I did not do any bios/driver whatever updates.

As it's also not working in Bios it should be OS/driver agnostic.

Any idea what's wrong or what I could do?

The dock works normally apart from that - usb devices and display link monitor are working fine.

 

21 Posts

August 8th, 2019 00:00

Jesse L,

I just checked and did not receive any private message from you.

Last message I got was "Dell Customer Experience Survey" from DCFAdmin.

Moderator

 • 

16.6K Posts

August 8th, 2019 03:00

Gh0stface,

 

I was needing to know your zip code or country code? 

 

 

21 Posts

August 8th, 2019 05:00

Jesse,

I sent it along with my whole address, anyway that would be A-1100 in Austria.

Thank you

1 Message

August 10th, 2019 00:00

Having exactly the same issues as described in this thread after following the painstaking BIOS flash/driver installation process. Looking at the battery report it appears that it appears to show what the Windows 10 battery monitor does: says the laptop is plugged in and charging while the charge level drains until dead.

Here's the battery-report.html output from running powercfg /batteryreport: https://photos.app.goo.gl/usAGB46zz5uLi1jcA

 

Moderator

 • 

16.6K Posts

August 12th, 2019 11:00

Gh0stface,

 

Did you read the private message I sent to you on Friday? 

 

 

9 Posts

August 12th, 2019 18:00

I'm in the same boat here and have had a support ticket open since 7/22/2019. It has been "escalated" who knows how many times. I had a SupportAssist session to no avail. I've been sent a new dock (didn't work, just like the comments in here explicitly indicate, it's not the dock, it's not the drivers). Tried three or four other suggestions that come three or four days apart. We're going on week 5 here... I've asked for an "escalation" again or for Dell to start the warranty exchange or for a full refund of my purchase price. I'll keep the thread posted. SR #994868017

21 Posts

August 13th, 2019 02:00

Jesse,

I did not receive any messages from you.

Please see the screenshot from my inbox - there is nothing there, I have no idea what's up with Dells PM system or if you are maybe sending it to the wrong person (Gh0stface has a zero instead of an o in it).

 

dell_pm.png

Moderator

 • 

16.6K Posts

August 14th, 2019 11:00

Gh0stface,

 

Did the information provided help resolve the issue?

 

 

9 Posts

August 14th, 2019 18:00

Timeline (All times Eastern)


7/22/2019 3:29P - Support asks for order number, Wattage of docking station (180W), tells me to update drivers (already updated, this was communicated in the opening of the ticket)
7/22/2019 3:58P - Questions answered by me
7/22/2019 7:58P - they ask for a call back number and two hour time slot
7/22/2019 9:00P - availability provided for 7/23 9-11A
7/23/2019 11:00A - No Call
7/23/2019 12:44P - I apologize that we couldn’t call you at the mentioned time due to technical issues. I have scheduled a call back for tomorrow (Wednesday, 7/24/2019) between 8 a.m. and 10 a.m.
7/24/2019 10:51A - No call - I email and ask when they intend to call me
7/24/2019 11:19A - My apologies that we couldn’t call you in between 8 a.m. and 10 a.m. as our shift starts from 10 a.m. CST as informed earlier. I have scheduled a call back for 10am CST, and we tried to call you now and received voice mail.
7/25/2019 11:08A - I am free from 5pm to 7pm CST tomorrow, 7/26/2019
7/25/2019 11:54A - I have scheduled a call back for Saturday i.e., 07/26/2019, our senior technician will call you between 5 p.m. and 7 p.m.
7/26/2019 5:30P-7:30P - Dell rep conducts support assist session with no success. Asks for picture of the dock and serial number with dated information and a reference number along with order
7/28/2019 6:29P - New Docking Station Shipped
7/30/2019 10:00A - Dock Arrives
7/31/2019 8:15A - Dell is informed that the replacement dock has the same issue
7/31/2019 5:07P - ESCALATED to Engineering team
8/2/2019 6:53P - I ask for updates as I've heard nothing
8/6/2019 8:03P - I ask for updates AGAIN - it has sat with the "escalated" team for 7 days. I ask if they are going to drag this out past 8/25 when my warrany expires
8/7/2019 3:42P - Our internal team has suggested few troubleshooting steps to resolve the issue. Kindly perform the below steps and share your observations.

Step 1: BIOS recovery.
Before you begin the BIOS Recovery, ensure that the laptop's battery is charged up to at least 10%.

• Verify that the laptop is powered OFF and disconnect the AC adapter.
• Press and hold the CTRL key + ESC key on the keyboard.
• Plug in the AC adapter to the laptop.
• Release the CTRL key + ESC key on the keyboard once you see the BIOS recovery screen.
• On the BIOS Recovery screen, select Reset NVRAM(if available) and press the Enter key. Select Disabled and press the Enter key if you wish to save the current BIOS settings.
• Select Recover BIOS and press the Enter key to start the recovery process.

Note: Your Dell PC may restart a few times during the process of BIOS recovery.

After performing BIOS recovery, could you please help us know the below information:
• Click on the battery icon on the bottom of the screen and capture a screenshot when the Dock is connected.
• Drain the battery to below 50% and then connect the DOCK and check for the battery status within the OS.
• Under battery check if you get the message: Estimated time to full charge.

Step 2: Update firmware.

Update Thunderbolt firmware.

https://www.dell.com/support/home/us/en/04/drivers/driversdetails?driverid=D0X3R&oscode=WT64A&productcode=dell-dock-wd15


8/8/2019 8:57P - I followed the steps and have the same results. The dock still does not charge the laptop. I've attached the firmware update log
8/8/2019 3:14P - Kindly help me with the battery status in BIOS.

Check battery status in BIOS.
1. Turn off your system.
2. Tap on the F2 key while powering on the system to load the BIOS page.
3. Now on the BIOS page, under Settings, select General and click on Battery Information.

Kindly check battery health and AC Adapter status or take a picture of the screen and send it to us.


8/8/2019 5:22P - Screeshots provided
8/13/2019 7:08A - How many weeks are going to go by before action is taken to fix this? How about Dell just refunds my purchase price of this laptop?

Please take action to either:
• Escalate this to the team that will actually fix this
• Start the process of the warranty claim to send out working hardware
• Refund the full purchase price of this laptop
Giving me one thing to try every 3 or 4 days is not going to resolve this any time soon.


8/13/2019 9:50P - Please accept my deepest apology for the delay, I am waiting for a response from our backend team, kindly provide us 24-48 business hours.


8/14/2019 7:53P - We got an update form our backend team, kindly perform the below steps.

Looking at the BIOS screenshot we are able to clearly see that the system is able to recognize the adapter(DOCK), battery health is excellent and the status is charging. So we don’t see any issues with the system, however perform the below steps
1. Drain the system to below 20% or - do not connect the dock or the adapter and then go into BIOS and check the battery status
2. Connect the DOCK and check the battery status
3. Wait for 30mins in BIOS with the DOCK connected check battery status in BIOS

Please make a video of the first few mins of STEP 1 & 2(without the DOCK connected and with the DOCK connected and a few mins of STEP 3 and share.
Wait for 30 mins and capture the status of the battery with the adapter connected.

 

So you can see that I'm making exceptional strides in the 3.5 weeks. So far, we've established that my battery is fine and that my laptop shows as "Charging" in the BIOS when my AC ADAPTER THAT CAME WITH THE LAPTOP is plugged in...

Moderator

 • 

16.6K Posts

August 15th, 2019 10:00

Gh0stface,

 

Did the information provided help resolve the issue?

 

 

9 Posts

August 19th, 2019 01:00

Hello,

I am also experiencing a similar problem with my XPS 15 9570 not charging via TB16 Dock / USB-C.

Battery charges when

  • Dock is not attached but Notebook AC Adapter is attached
  • Notebook AC Adapter is attached and the Dock is connected afterwards. In this configuration, when I remove the Notebook AC Adapter, Dell Power Manager tells me that the battery is charging, but the battery level keeps going down...

Battery does not charge when

  • Only the dock is attached
  • Dock is attached first and then the Notebook AC Adapter is connected afterwards.

All drivers are up to date, same issue with 2 different docks (240W both).

Is there a root cause and a solution identified by Dell experts?

Thanks for your help.

21 Posts

August 19th, 2019 02:00

Jesse L,

No, the information provided did not help resolve the issue, it still persist.
All drivers/bios/firmware etc. up2date, all bios settings as recommended, dock is fully functional and notebook indicates that it is charging but it percentage of battery still goes down when only the dock is connected.

Exactly the same status as the last 5 pages in this thread.

9 Posts

August 19th, 2019 08:00

Escalated again 8/15/2019 2:12PM - Thank you for uploading videos. I have escalated the case to the backend team and waiting for their response, kindly provide us 24-48 business hours.

21 Posts

August 20th, 2019 03:00

@aptica I also did the discharge to 20% or below and plugin thingy and recorded it.

Same behaviour https://photos.app.goo.gl/WBUyvRnLWX2dPQBK9

I am fairly certain the issue is that the xps 15 identifies the charging power wrongly at first.

It is 60W when you plug it in and only jumps to 130W after a few seconds.

2 Posts

August 20th, 2019 06:00

I don't know if this is part of the issue or not but posting here so smarter people than I can evaluate. 

My XPS 15 has been experiencing all the exact same issues as described in this blog. 

I have downloaded and ran the Dell Thunderbolt Dock (TB16) Firmware Update Utility update from the following website, four different times. 

https://www.dell.com/support/home/us/en/04/product-support/product/dell-thunderbolt-dock-tb16/drivers

In this update, there are a variety of aspects that are being updated, the first two are labeled MST1 and MST2. After each update, the screen shows that the update has been successful and I reboot the machine. However, upon relaunching the update program MST2 which had previously showing it had been updated to the newest version, now shows that it has not been updated.

So, the program update for MST2 isn't being accepted upon reboot.  

No Events found!

Top