Dell Unity: Nadat een OE-upgrade of SP opnieuw is opgestart, wordt de aangepaste beveiligingsbanner niet meer weergegeven in de CLI (op te lossen door Dell)

Samenvatting: Er is een probleem aangetroffen waarbij een aangepaste banner niet meer aanwezig was bij het aanmelden bij Unity CLI of externe uemcli. Dit is gebeurd na recente Dell Unity OE upgrades van 5.1.2. of 5.2.0 t/m 5.2.1.x. De aangepaste beveiligingsbanner werd correct weergegeven in Unisphere bij aanmelding. Telkens wanneer een SP opnieuw wordt opgestart of er een OE-upgrade is en beide SP's in gecontroleerde volgorde opnieuw opstarten, werd het probleem waargenomen. ...

Dit artikel is van toepassing op Dit artikel is niet van toepassing op Dit artikel is niet gebonden aan een specifiek product. Niet alle productversies worden in dit artikel vermeld.

Symptomen

Het probleem is opgelost door de banner opnieuw toe te voegen met behulp van het svc_banner-opdrachtproces. Dit is niet gelukt. Dit is te vinden op pagina 9 en 10 van de documentatie "Dell Unity™ Family Service Commands Technical Notes". Dit is niet gelukt. 

De volgende koppeling toont het aangepaste bannerproces.



https://www.dell.com/support/manuals/en-us/unity-350f/unity_p_svc_cmd_tech_notes/apply-custom-log-on-banners-svc_banner?guid=guid-5a9eeff7-23e6-49a8-8053-03eec9f02aff⟨=en-usHet probleem wordt waargenomen wanneer:
  1. De SP's worden afzonderlijk opnieuw opgestart.
  2. Beide SP's worden opnieuw opgestart als onderdeel van een OE-upgrade met OE 5.1.x en hoger
Er wordt geen klantenbanner weergegeven bij het aanmelden bij sshcli, ipmitool via de Unity servicepoort of bij het gebruik van externe uemcli. De banner van de klant wordt alleen weergegeven in Unisphere voordat u zich aanmeldt.

Oorzaak

Dell Engineering werkt aan een permanente oplossing voor dit probleem dat in een toekomstige OE-code-update zal worden uitgebracht.

Oplossing

Engineering heeft vastgesteld dat er een tijdelijke oplossing is die kan worden gebruikt totdat een volledige oplossing wordt toegevoegd in een toekomstige OE-code. Er is nog geen tijdlijn voor de permanente oplossing. 

De volgende opdracht moet aan elke SP worden gegeven na elke SP-herstart of code-upgrade. Hiermee haalt u de eerder opgeslagen banner uit het niet-vluchtige geheugen in de SP.

Oplossing: 
svc_banner -a
 
Example output:
01:40:30 service@Unity500-R14 spa:~/user# svc_banner -a
INFO: checking system state ... (spa)
INFO: checking system state ... (spb)
INFO: Banner activated! (spb)
INFO: operation successful (spb)!
INFO: Banner activated! (spa)
INFO: operation successful (spa)!
Zodra de banner opnieuw wordt ingevuld vanuit het niet-vluchtige SP-geheugen en is ingeschakeld, kan deze worden gecontroleerd met behulp van:
svc_banner --dump
Kan dezelfde opdracht gebruiken om te controleren op de peer SP

om naar de peer-SP te gaan vanaf de primaire SP: ssh peer
Om terug te gaan naar het primaire SP-type: afsluiten

Opmerking: Deze opdracht kan worden toegevoegd aan aangepaste SP-rebootscripts die een klant gebruikt, zodat de banner automatisch opnieuw wordt geladen.

Getroffen producten

Dell EMC Unity
Artikeleigenschappen
Artikelnummer: 000211513
Artikeltype: Solution
Laatst aangepast: 29 mrt. 2023
Versie:  1
Vind antwoorden op uw vragen via andere Dell gebruikers
Support Services
Controleer of uw apparaat wordt gedekt door Support Services.