Dell Unity:新しいサブネットを持つ管理IPアドレスを割り当てることができません(ユーザー修正可能)

概要: システムの導入時に管理IPアドレスが構成されているか、管理IPアドレス サブネットが変更されています。ゲートウェイを選択すると、サブネットIDが使用されている場合、管理IP設定は失敗します。 これは、Unisphere内またはコマンド ラインで発生する可能性があります。Unisphereおよびコマンド ラインで管理IP構成を変更できないというエラーが表示されます。 Unisphereとコマンド ラインの両方にログインできません。続行して問題を解決するには、いずれかのSPのipmitoolからのアクセスを使用する必要があります。 ...

この記事は次に適用されます: この記事は次には適用されません: この記事は、特定の製品に関連付けられていません。 すべての製品パージョンがこの記事に記載されているわけではありません。

現象

Unisphereまたはsshコマンド ラインで、新しいサブネット/ゲートウェイを使用して管理IPを変更できないというエラーが表示されます。

注:Unisphereとコマンド ラインの両方にログインできません。続行して問題を解決するには、いずれかのSPのipmitoolからのアクセスを使用する必要があります。

記事000022376では、ipmitoolの使用について説明しています。



https://www.dell.com/support/kbdoc/en-us/000022376/dell-emc-unity-using-the-ipmitool-on-unity-systems コマンドの出力を確認します。sshシェルからのsvc_diagは、管理用に構成されたIPアドレスを示しません。

以下のコマンドを使用して以下の設定を確認しても、有効な情報は表示されません。

コマンド: uemcli /net/if/mgmt show

A valid configuration ただし、通常の出力が表示されます。.128サブネット マスクに注目してください。 
uemcli /net/if/mgmt show
Storage system address: 127.0.0.1
Storage system port: 443
HTTPS connection

1:    IP protocol version = ipv4
      Address origin      = static
      IP address          = 10.241.219.230
      Subnet mask         = 255.255.255.128
      Gateway             = 10.241.219.129


--------------------------------------------------------------------------------------------------------------------------------------------------------この場合、次のコマンドを使用して、新しく導入されたシステムの管理アドレスを設定しましたが、失敗しました。 
 
svc_initial_config -f friendlyname -4 "10.242.12.18 255.255.255.240 10.242.12.16"

friendlyname = 必要なUnityシステムの名前

原因

新しいゲートウェイまたは変更されたゲートウェイを使用して管理IPアドレス サブネットを変更すると、無効なゲートウェイが選択されていることがわかりました。

使用されているゲートウェイは、実際にはサブネットのIDでした(すべて0(hostbits))。サブネットIDは無効であり、ネットワーク ルールごとにゲートウェイとして使用することはできません。

各サブネット内の2つの特別なアドレスをエンドポイントとして使用することはできません。
  • 最初の(最低)アドレスは、ネットワーク識別子(サブネットID)です。
  • 最後の(最高)アドレスはサブネット ブロードキャスト アドレスです。
サブネット計算ツールには、必要なホストIPアドレスに対して有効なホスト範囲も表示されます。これには、ゲートウェイIPアドレスの使用が含まれます。

解決方法

管理IPアドレスを正常に設定できる有効なゲートウェイIPアドレスを選択する必要があります。構成が完了すると、Unisphereを再度ログインに使用できます。

対象製品

Dell EMC Unity
文書のプロパティ
文書番号: 000215565
文書の種類: Solution
最終更新: 26 10月 2023
バージョン:  4
質問に対する他のDellユーザーからの回答を見つける
サポート サービス
お使いのデバイスがサポート サービスの対象かどうかを確認してください。