PowerStore: NTPD service failure results in a node reboot
Summary: An unexpected node reboot may be observed when using svc_ntp_ctl command.
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Symptoms
An unexpected node reboot may be observed if the svc_ntp_ctl --set command is used in of the following scenarios:
The node reboots and automatically recovers.
- Executed multiple times on one node via multiple sessions either in parallel or in a short period of time
- Executed multiple times on both nodes either in parallel or in a short period of time
The node reboots and automatically recovers.
Cause
The svc_ntp_ctl --set command may fail to bind the ntpd port internally if another process is holding the port by running concurrent svc_ntp_ctl --set commands or by an NTP server update request.
On PowerStoreOS 3.0 and 3.2, the ntpd service attempts to restart immediately after a failure, so it will quickly exhaust its restart count under this condition and declare the service failed.
Due to the design of the orchestration HA policy, the system proactively initiated a node reboot when the ntpd service failed as part of self-recovery actions.
On PowerStoreOS 3.0 and 3.2, the ntpd service attempts to restart immediately after a failure, so it will quickly exhaust its restart count under this condition and declare the service failed.
Due to the design of the orchestration HA policy, the system proactively initiated a node reboot when the ntpd service failed as part of self-recovery actions.
Resolution
This issue is fixed in PowerStoreOS 3.5.
Workaround to Prevent this Issue from Occurring
To prevent the issue from occurring, run the svc_ntp_ctl --set command one at a time on an appliance, only when needed.
Also, do not run the svc_ntp_ctl --set command while applying NTP server setting updates through the PowerStore Manager UI, REST API, or PSTCLI.
Workaround to Prevent this Issue from Occurring
To prevent the issue from occurring, run the svc_ntp_ctl --set command one at a time on an appliance, only when needed.
Also, do not run the svc_ntp_ctl --set command while applying NTP server setting updates through the PowerStore Manager UI, REST API, or PSTCLI.
Additional Information
- KB 000132575 PowerStore Alerts: Time difference between the node and the following available NTP servers is huge
- Dell EMC PowerStore Service Scripts Guide(pdf) - Check and fix the NTP status (svc_ntp_ctl)
Affected Products
PowerStoreArticle Properties
Article Number: 000215670
Article Type: Solution
Last Modified: 14 Jun 2025
Version: 3
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