PowerProtect DM5500: Error Message errorNum: 5075 from Data Manager UI When Trying to Delete the Storage Unit from the Appliance

Summary: The user may not be able to delete the Storage Unit when the first attempt fails in the middle of the operation (for example, due to a timeout).

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

The user cannot delete the Storage Unit (SU), and if not cleaned up properly, the SU remains on the appliance.

Symptoms found in the logs:

  • Request to delete the SU:
replmgr.2023-07-01.1.log:2023-07-01T21:54:33.482Z INFO [] [https-jsse-nio-127.0.0.1-8452-exec-434] [][][][TRACE_ID:81e05c19fad91c4c][] c.e.brs.replmgr.filter.RestLogFilter.doFilter(46) -  Enter RESTful Msg - Method: DELETE, Path: https://localhost:8443/api/v2/datadomain-mtrees/70ebdeba-07d9-4826-88b2-a8f805b4ac49
  • A snippet of code in discovery indicates that discovery was running, and requests were sending to Data Domain around the same time.
2023-07-01T21:54:56.302Z INFO [] [f2f991e7-06ef-4442-8ccd-ca5e3513a0aa-akka.actor.default-dispatcher-20] [][][][TRACE_ID:888142e41bebeea9;JOB_ID:ab7484ca63a7b948][] [c.e.b.d.a.d.DataDomainResourceDetailsActor.discover(665)] - Resource 5ead6fa7-392e-4101-9d3d-54d77c6f7caf was persisted successfully: <?xml version="1.0" encoding="UTF-8"?><name>cml_bstress_su_cl5_0</name><vendor>
2023-07-01T21:54:56.303Z INFO [] [f2f991e7-06ef-4442-8ccd-ca5e3513a0aa-akka.actor.default-dispatcher-20] [][][][TRACE_ID:888142e41bebeea9;JOB_ID:ab7484ca63a7b948][] [c.e.b.d.a.d.DataDomainResourceDetailsActor.getRelatedElementQueries(408)] - Discovery for the resource [ResourceGroupStorageUnits] complete
Attempting to delete the SU a second time will result in the following UI error:

500: Failed to connect to PowerProtect DD System. errorNum: 5075 errorMessage: the user has insufficient access rights

Cause

As a part of the SU deletion, the original user is reassigned to an internally created user 'PPDM-GEN-USER-FOR-DELETION'. This is required to bypass the DD garbage collection so PowerProtect Data Manager can remove the original user. During the storage unit deletion, the DD API timed out and failed the request. It was observed that DD was busy as the discovery job was running. Since the request failed, PowerProtect Data Manager attempted to revert the user to the original user which fails, leaving the SU user as 'PPDM-GEN-USER-FOR-DELETION’. The revert user operation is not working as expected.

Resolution

Resolution:
PowerProtect Data Manager 19.15 and DM5500 R4

Workaround:
  1. Verify that the SU is assigned to the internal user "PPDM-GEN-USER-FOR-DELETION".
  2. From CLI command, run the following command to confirm that the status is not "D (delete)" and the user is assigned to PPDM-GEN-USER-FOR-DELETION. 
"ddboost storage-unit show su_name
If the first condition is met, that means that the SU passed all the validations during the initial deletion request to get to this stage. The validation includes checking "no remaining copies, associated policies, and topLevelPath" is empty. Hence, it is safe to delete it.
  1.  From CLI, run the following command then wait for the next discovery schedule. Once discovery is complete, check on the Storage page that the SU is no longer visible. 
​​​​ddboost storage-unit delete su_name

Affected Products

PowerProtect DM5500
Article Properties
Article Number: 000216696
Article Type: Solution
Last Modified: 14 Aug 2023
Version:  1
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.