Connectrix B-Series: How to Troubleshoot an SSH Error when Attempting a Supportsave

Summary: Supportsave fails with "Error occurred in SSH."

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

A supportsave fails during SSH authentication.

admin> supportsave

This command collects RASLOG, TRACE, supportShow, core file, and then transfer them to a FTP/SCP/SFTP server or a USB dev
This operation can take several minutes.
OK to proceed? (yes, y, no, n) : [no] y

Host IP or Host Name: 10.xx.xx.10
User Name: admin
Remote Directory: /
Protocol (ftp | scp | sftp): sftp
SCP/SFTP Server Port Number [22] : 
Do you want to continue with CRA (Y/N): [N] 
Password:
Saving support information:
SLOT
SWITCH
MODULE
CLI SIZE
CLI TIME
MODULE TIME LOAD AVERAGE
Error occurred in SSH.
Summary worker: 2, cpu load: 3 upload size: 0 KB, time: 1 load:0.3/0.1/0.1
SupportSave completed (upload failure)

Both SCP and SFTP rely on SSH for authentication. SCP essentially uses SSH under the hood to establish a secure connection between the client (switch) and server (for example SANnav or SFTP server) for file transfers.

When you initiate an SCP transfer, there are two authentication steps:

  • Server Authentication: SSH uses host keys to authenticate the server.
  • User Authentication: In SSH, the client authenticates to the server with a password, key pair, or other methods.

Cause

Assuming that your login credentials are correct then the issue is likely caused by a failure during server authentication.

The switch (SSH client) compares the host key presented by the SSH server (10.xx.xx.10) against the keys stored in its known_hosts file. If there is a mismatch, then authentication fails. 

Resolution

The solution is to clear the erroneous entry from the switch.

Use sshutil delknownhost to clear the SSH (SCP/SFTP) server IP address or hostname from the known hosts table of the device. Only users that have been granted access to use SSH-related tools like sshutil on the Brocade switch can take the following action.

To confirm, use the following command:

sw7:FID128:admin>  sshutil showuser

Should the SCP server connectivity be by any other port than 22 (default SSH) then the port number must also be specified. For example, SSH/SFTP server (10.xx.xx.10:22), use the following syntax:

sw7:FID128:admin> sshutil delknownhost
IP Address/Hostname to be deleted: 10.xx.xx.10

For example, SANnav Server (10.xx.xx.10:6022), use the following syntax:

sw7:FID128:admin> sshutil delknownhost
IP Address/Hostname to be deleted: [10.xx.xx.10]:6022

Affected Products

Connectrix B-Series Hardware, Connectrix B-Series Software
Article Properties
Article Number: 000361107
Article Type: Solution
Last Modified: 04 Dec 2025
Version:  2
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