NetWorker: Backups fail due to not having enough devices to service requests

Summary: This article details an issue about not having enough devices (or target sessions per device) resulting in backup failures.

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

Backup fails with symptoms below that indicate the device is busy and unable to complete backups:

Error: 'ORA-19511: non RMAN, but media manager or vendor specific failure, error text: busy (0:5:2)'
Error:'ORA-19511: Error received from media manager layer, error text: busy (0:5:2)'
Error: '_nwbsa_is_retryable_error received a retryable network error (Severity 0 Number -13) busy'
Error: 'nsrdasv: Failed to acquire user credentials for direct save nsrmmd auth: busy'
Error: 'save: Unable to setup direct save with server nsr_server.domain.com: busy.'
Error: 'hdbbackint: Unable to setup direct save with server nsr_server.domain.com: busy.'
Error: 'lgto_auth for `nsrmmd' failed: busy'

Cause

This issue usually occurs when devices are busy servicing other clients. 

Resolution

Resolve this issue by doing the following:

  1. Disable dynamic nsrmmds:
    NMC > Devices > Storage Nodes > storage node Properties > uncheck 'Dynamic nsrmmds'  
  2. Increase target sessions of the device until the issue is resolved.
  3. Make more volumes (devices) available for backup until the issue is resolved.
  4. Set NSR_MAX_START_RETRIES=100 for each channel.

Affected Products

NetWorker Module for Databases and Applications

Products

NetWorker, NetWorker Module for Databases and Applications, NetWorker Module for SAP
Article Properties
Article Number: 000167090
Article Type: Solution
Last Modified: 25 آذار 2026
Version:  4
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