NetWorker: Backups fail due to not having enough devices to service requests
Summary: This article details an issue about not having enough devices (or target sessions per device) resulting in backup failures.
Symptoms
Backup fails with symptoms below that indicate the device is busy and unable to complete backups:
Error: 'ORA-19511: non RMAN, but media manager or vendor specific failure, error text: busy (0:5:2)'
Error:'ORA-19511: Error received from media manager layer, error text: busy (0:5:2)'
Error: '_nwbsa_is_retryable_error received a retryable network error (Severity 0 Number -13) busy'
Error: 'nsrdasv: Failed to acquire user credentials for direct save nsrmmd auth: busy'
Error: 'save: Unable to setup direct save with server nsr_server.domain.com: busy.'
Error: 'hdbbackint: Unable to setup direct save with server nsr_server.domain.com: busy.'
Error: 'lgto_auth for `nsrmmd' failed: busy'
Cause
This issue usually occurs when devices are busy servicing other clients.
Resolution
Resolve this issue by doing the following:
- Disable dynamic
nsrmmds:
NMC > Devices > Storage Nodes > storage node Properties > uncheck 'Dynamic nsrmmds' - Increase target sessions of the device until the issue is resolved.
- Make more volumes (devices) available for backup until the issue is resolved.
- Set
NSR_MAX_START_RETRIES=100for each channel.