Pääkäyttäjä ei voi kirjautua verkkokäyttöliittymään/komentoriviliittymään 8.x-versiossa, kun oletustoimialue on määritetty

Zusammenfassung: Toimialueen päällekkäinen pääkäyttäjä aiheuttaa ongelmia kirjautumisessa klusteriin verkkokäyttöliittymän ja komentoriviliittymän kautta.

Dieser Artikel gilt für Dieser Artikel gilt nicht für Dieser Artikel ist nicht an ein bestimmtes Produkt gebunden. In diesem Artikel werden nicht alle Produktversionen aufgeführt.

Symptome

Kun klusteriin kirjaudutaan joko verkkokäyttöliittymän tai komentoriviliittymän kautta, näyttöön tulee salasanavirhe.

Tämä koskee OneFS 8.x -versiota, kun toimialueella on päällekkäinen käyttäjä (kuten pääkäyttäjä).

Voit silti kirjautua unix_users-toimialueella:

UNIX_USERS\root

Tarkista, onko kyseinen toimialue määritetty oletustoimialueeksi:

#isi auth ads view --provider-name=<domain> --verbose | grep "Assume Default Domain"
    Assume Default Domain: Yes

 

Ursache

Jos oletustoimialue on määritetty, OneFS ottaa ensin yhteyttä toimialueeseen kyseisen paikallisen käyttäjän todentamista varten. Tässä tapauksessa käytetään root-käyttäjää. Jos käyttäjä on toimialueella, OneFS yrittää todentaa käyttäjän toimialueen kautta.

Jos tili on poistettu käytöstä, näet virheen, kun yrität kirjautua sisään.

 

Lösung

8.x:ssä voit lisätä ei-löydettäviä käyttäjiä mihin tahansa toimialueen ohjauskoneeseen seuraavalla komennolla:

# isi auth ads modify --provider-name=<domain> --add-unfindable-users=<list of users we don't want found(to include domain name and FQDN) --restrict-findable=yes

Varmista, että asetukset on tehty, suorittamalla valtuutusnäkymä uudelleen:

# isi auth ads view --provider-name=<domain> --verbose
--you are looking for this output:
         Unfindable Users: <FQDN>\root, <Domain>\root, 0, root
          Findable Groups: -
           Findable Users: -
        Restrict Findable: Yes

Jotta klusteri suodattaa pois käyttäjät, joita ei löydy, etsittävien rajoitusten on oltava käytössä.

 

Artikeleigenschaften
Artikelnummer: 000050102
Artikeltyp: Solution
Zuletzt geändert: 17 Apr. 2026
Version:  5
Antworten auf Ihre Fragen erhalten Sie von anderen Dell NutzerInnen
Support Services
Prüfen Sie, ob Ihr Gerät durch Support Services abgedeckt ist.