NetWorker:文件系統增量備份失敗 |誤:5029

Zusammenfassung: 在 NetWorker 中進行檔案系統增量備份期間,雖然完整備份成功完成,但會發生間歇性故障。本文說明症狀、原因及解決方法。

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Symptome

增量備份工作失敗,返回代碼 -1,而完整備份成功。記錄檔會顯示類似以下錯誤:

  • MODIFIED_ASOF_TIME:timeval=1735918213;RENAMED_DIRECTORIES:index_lookup=on;BACKUPTIME:lookup_range=1735918230:1735918230;REQUESTED_LEVEL:level=incr; -l incr -q -W 78 -N /data_ecm1 /data_ecm1' for client exited with return code -1
    
    01/05/2025 01:05:39 AM Job 594500 host: savepoint: /data_ecm1 had ERROR indication(s) at completion
    01/05/2025 01:05:39 AM PECMAPP1:/data_ecm1 failed.
    01/05/2025 01:05:44 AM Action backup traditional 'backup' with job id 594425 is exiting with status 'failed', exit code 1

原則記錄包括:

  • ddp_fsync() failed, Err: 5029 - A previous operation on this file has failed with error code: 5029 and no further APIs can be processed until the file is closed
    fsys_fsync(): Sync'ing a file failed [5029]
    _ddp_fsync() Aborting API processing because ddp_fd[...] has previous error[5029] set
    
 
 

Ursache

  • 錯誤 5029 表示 ddp_fsync() 及相關的 DDBoost API 呼叫失敗。
  • 這是隨附於 NetWorker 19.10DDBoost 二進位版本 7.13.0 的已知問題
  • 當以前對檔的操作失敗時,會出現此問題,從而阻止進一步的 API 調用,直到檔關閉。

參考資料:

ddboost_api ERROR: ddp_fstat() failed, Err: 5029 - A previous operation on this file has failed with error code: 5029 and no further APIs can be processed until the file is closed

Lösung

  • 會在 Jira ID 下追蹤此問題:DDOSCFD-20020
  • 此修正程式可在 DDBoost 版本 7.13.1、8.0 和 8.1+ 中取得
  • NetWorker 無法獨立升級 DDBoost;將 NetWorker 升級至:
    • 19.11 (包括 DDBoost 8.0)
    • 19.12 (包括 DDBoost 8.1)

Weitere Informationen

  • 完整備份不受影響;只有增量備份會間歇性失敗。
  • 除了升級到具有已修復 DDBoost 程式庫的版本外,沒有其他因應措施。
  • 監控 Dell 版本資訊,以瞭解其他修補程式或修補程式。
Artikeleigenschaften
Artikelnummer: 000289911
Artikeltyp: Solution
Zuletzt geändert: 25 Nov. 2025
Version:  2
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