NVP-vProxy: VM-Backup kann .vmx-Datei der VM nicht herunterladen HTTP 404 nicht gefunden

Zusammenfassung: vProxy ist nicht in der Lage, eine oder mehrere virtuelle Maschinen zu sichern. vProxy hat keinen Zugriff auf das Herunterladen der .vmx-Dateien aus dem vCenter.

Dieser Artikel gilt für Dieser Artikel gilt nicht für Dieser Artikel ist nicht an ein bestimmtes Produkt gebunden. In diesem Artikel werden nicht alle Produktversionen aufgeführt.

Symptome

NetWorker VMware Protection (NVP) vProxy ist nicht in der Lage, eine oder mehrere virtuelle Maschinen (VM) zu sichern.

Die VM-Backupsitzungsprotokolle zeigen Folgendes an:

YYYY/MM?DD HH:mm:SS ERROR: [@(#) Build number: 288] No contents return in download of "[DATASTORE_NAME] FOLDER/VM_NAME.vmx". HTTP status: "404 Not Found"
YYYY/MM?DD HH:mm:SS ERROR: [@(#) Build number: 288] Failed to download config file "[DATASTORE_NAME] FOLDER/VM_NAME.vmx" using URL "https://vcenter_ip/folder/FOLDER/VM_NAME.vmx?dcPath=datacenter&dsName=DATASTORE_NAME".
YYYY/MM?DD HH:mm:SS INFO: [@(#) Build number: 288] Failed HTTP request took 62.645619ms
YYYY/MM?DD HH:mm:SS TRACE: [@(#) Build number: 288] HTTPRequest: &{GET https://VCENTER_NAME/folder/FOLDER/VM_NAME.vmx?dcPath=datacenter&dsName=DATASTORE_NAME HTTP/1.1 1 1 map[Cookie:[vmware_soap_session=ae40da8f99e1d1585ca2317216080d6c10b7bdaa] Content-Type:[text/plain]] <nil> 0 [] false vcenter_ip map[] map[] <nil> map[] <nil> <nil>}
YYYY/MM?DD HH:mm:SS ERROR: [@(#) Build number: 288] Failed to download VM config file "[DATASTORE_NAME] FOLDER/VM_NAME.vmx" into saveset file "vm-####-config-file-0.cfg".
YYYY/MM?DD HH:mm:SS ERROR: [@(#) Build number: ###] Failed to Initialize Backup Descriptor.

Die Backupsitzungsprotokolle sind an den folgenden Speicherorten verfügbar:

  • Linux-NetWorker-Server: /nsr/logs/policy/POLICY_NAME/WORKFLOW_NAME/
  • Windows NetWorker-Server (Standard): C:\Program Files\EMC NetWorker\nsr\logs\policy\POLICY_NAME\WORKFLOW_NAME
  • vProxy-Appliance: /opt/emc/vproxy/runtime/logs/recycle/vbackupd/DATE/ 

Ursache

Der Backupfehler meldet den HTTP-Fehlercode 404 (nicht gefunden). Weil es nicht möglich ist, auf die .vmx-Datei der VM aus dem vCenter zuzugreifen oder sie herunterzuladen. Dieses Problem tritt außerhalb von NetWorker auf. 


 

Lösung

Geben Sie in einem Webbrowser die .vmx-URL aus dem Backupprotokoll ein. Zum Beispiel:
Zugriff auf die VMX über die URL des Webbrowsers 

Geben Sie dieselben Zugangsdaten ein, die zum Sichern von VMs in NetWorker verwendet werden. 

HINWEIS: Das VMware-Nutzerkonto wird auch in den Backupprotokollen angegeben. Sie können das Nutzerkonto auch in der NetWorker Management Console (NMC) anzeigen. Navigieren Sie zu Protection –> VMware View, klicken Sie mit der rechten Maustaste auf vCenter und klicken Sie auf Modify vCenter.

Wenn es keine Probleme beim Zugriff auf die Datei gibt, wird sie in den Browser heruntergeladen:
VMX-Dateidownloads 

Wenn der Webbrowser auch HTTP 404 meldet, tritt das Problem außerhalb von vProxy oder NetWorker auf. Dieses Problem muss vom VMware-Administrator untersucht werden. Wenn Unterstützung erforderlich ist, muss der VMware-Support eingebunden werden.

Weitere Informationen

Betroffene Produkte

NetWorker
Artikeleigenschaften
Artikelnummer: 000032092
Artikeltyp: Solution
Zuletzt geändert: 29 Mai 2026
Version:  5
Antworten auf Ihre Fragen erhalten Sie von anderen Dell NutzerInnen
Support Services
Prüfen Sie, ob Ihr Gerät durch Support Services abgedeckt ist.