Avamar: MCS empfängt "OutOfMemory"-Meldungen

Zusammenfassung: Der Avamar Management Console Server (MCS) empfängt "OutOfMemory"-Meldungen aufgrund einer großen NVRAM-Datei von einer virtuellen Maschine.

Dieser Artikel gilt für Dieser Artikel gilt nicht für Dieser Artikel ist nicht an ein bestimmtes Produkt gebunden. In diesem Artikel werden nicht alle Produktversionen aufgeführt.

Symptome

Geplante VMware- und physische Backups reagieren anscheinend nicht.

Sie werden möglicherweise im Fenster "Avamar Administrator Activity" als "running" angezeigt, jedoch ohne Änderung der Fortschrittsbytes.

Der Management Console Server (MCS) meldet den Zustand "nicht genügend Arbeitsspeicher" und die Benutzeroberfläche reagiert möglicherweise langsam.

VMware-Clients melden sich über einen längeren Zeitraum nicht an.

Ursache

Beim Sichern virtueller Maschinen lädt der MCS die NVRAM-Dateien (Non-Volatile Random-Access Memory) in die javaheap , um die BIOS-Konfiguration zu lesen.

Die NVRAM-Datei befindet sich am selben Speicherort, an dem auch VMware *.vmdk Dateien, die sich im Datenspeicher befinden.

Gelegentlich wächst die NVRAM-Datei, die in der Regel nur wenige KB groß ist (weniger als 10 KB), auf etwa oder über 1 MB.

Dies reicht aus, um MCS javaheap um aus dem Speicher zu gehen.

 

Lösung

1. Melden Sie sich beim Avamar Utility Node an und laden Sie die admin keys. Anweisungen zum Laden von Schlüsseln finden Sie unter Avamar: So melden Sie sich bei einem Avamar-Server an und laden verschiedene Schlüssel.

2. Überprüfen Sie, ob die javaheap ist bereits auf 1,5 GB eingestellt, was in der folgenden Ausgabe mit "-Xmx1536m" gekennzeichnet ist:

Hinweis: Der Wert "Xmx1536m" kann je nach Speicherauslastung variieren.  
 
ps -elf | grep java | grep mcserver
0 S admin    13623     1  2  76   0 - 556102 -     16:54 pts/0    00:10:16
/usr/java/jre1.6.0_22/bin/java -Xmx1536m -XX:MaxPermSize=256m -server -ea -cp
.:/usr/local/avamar/lib/mcserver.jar:/usr/local/avamar/lib/asn_server.jar:/usr/local/avamar/lib/mail.jar:/usr/local/avamar/lib/activation.jar:/usr/local/avamar/lib/xercesImpl.jar:/usr/local/avamar...<snip>...
6.1.23.jar:/usr/local/avamar/lib/jetty-util-6.1.23.jar:/usr/local/avamar/lib/servlet-api-2.5.jar:/usr/local/avamar/lib/jsp-api-2.1.jar:/usr/local/avamar/lib/jsp-
 

3. Überprüfen Sie, ob "OutOfMemory"-Meldungen im Protokoll gemeldet werden (aufgrund potenziell großer NVRAM):

grep -hi "OutOfMemoryError\|VMware" /usr/local/avamar/var/mc/server_log/mcserver.log*
Exception in thread "Thread-191" java.lang.OutOfMemoryError: Java heap space
        at java.util.Arrays.copyOf(Unknown Source)
        at java.io.ByteArrayOutputStream.write(Unknown Source)
        at
com.avamar.mc.vmware.VmwareVirtualMachineFiles.readVmFile(VmwareVirtualMachineFiles.java:386)
        at
com.avamar.mc.vmware.VmwareVirtualMachineFiles.getVirtualMachineFile(VmwareVirtualMachineFiles.java:109)
        at
com.avamar.mc.vmware.VmwareVirtualCenter.getVirtualMachineFile(VmwareVirtualCenter.java:902)
        at
com.avamar.mc.vmware.VmwareService.getNvramFileContent(VmwareService.java:2596)
        at com.avamar.mc.wo.JobScheduler._gotVmWork(JobScheduler.java:530)
        at com.avamar.mc.wo.JobScheduler.gotVmWork(JobScheduler.java:327)
        at com.avamar.mc.wo.DPNScheduler.gotVmWork(DPNScheduler.java:144)
 

4. Überprüfen Sie, welche Clients über den großen NVRAM verfügen:

grep "nvramContent\=\"null\"" mcserver.log.*
 

In diesem Beispiel werden die Clients "Company_1_Email-PDB reports '"nvramContent="null"':

FINE: MCS to Client(10.n.n.64:39270) Response: <workorder work="backup" type="work" ack="yes" cid="8580a6233796c72a4a73b89f0d2ae5fb644fcbd0" sync="bg" 
wid="NFSSQLCluster-1350439200070" pid="vmimagew" pidnum="3016" msgver="5" sessionid="c61b498fdf57eaca6cadc760a3b7fbf6f7e89aea" 
targetCid="bae291d2ba3d3e3ea77d5394bcaa60da3a072463" targetUUID="500faaf4-8f4b-b5f2-1744-1277d19a79cf" vcCid="3a25059a880e1d22b981c5815858d3dc95312621" 
time="1350442682" customaction="" ><targetlist><path name="[nas_datastore_03] Company_1_Email-PDB/Company_1_Email-PDB.vmdk" backup="true" diskCapacity="85899345920">
</path><path name="[nas_datastore_03_sqldb] Company_1_Email-PDB/Company_1_Email-PDB.vmdk" backup="true" diskCapacity="171798691840"></path>
<path name="[nas_datastore_03_sqllogs] Company_1_Email-PDB/Company_1_Email-PDB.vmdk" backup="true" diskCapacity="32212254720"></path></targetlist><directives> 
<flag type="string" name="encrypt" value="proprietary"  />  <flag type="string" name="encrypt-strength" value="cleartext"  />  <flag type="string" name="expire" 
value="1353034800"  />  <flag type="string" name="retention-type" value="daily,weekly,monthly,yearly"
....
"TRUE"scsi0:2.deviceType = "scsi-hardDisk"scsi0:2.present = "TRUE"scsi0:2.redo = ""migrate.hostlog = "
./Company_1_Email-PDB-b5986b60.hlog"scsi0:0.ctkEnabled = "TRUE"ctkEnabled = "TRUE"sched.scsi0:1.shares = "normal"
ethernet1.virtualDev = "vmxnet3"ethernet1.pciSlotNumber = "192"ethernet1.startConnected = "TRUE"
ethernet1.allowGuestConnectionControl = "TRUE"ethernet1.features = "1"ethernet1.wakeOnPcktRcv = "TRUE"
ethernet1.addressType = "vpx"ethernet1.generatedAddress = "00:00:56:8f:3f:b1"ethernet1.networkName = "
VM Network - 117"ethernet1.present = "TRUE""  nvramContent="null" prevBackup="null" snapshotDesired="always" prevSnapName="null" >
</vmInfo><vmDiskInfoList numDisks="3" > <vmDiskInfo capacityInKB="83886080" vmdkFilename="[nas_datastore_03] Company_1_Email-PDB/Comany_1_Email-PDB.vmdk" 
vmdkBaseFile="[nas_datastore_03] Company_1_Email-PDB/Comany_1_Email-PDB.vmdk" ordinal="1" srcOrdinal="-1" label="Hard disk 1" diskKey="2000" 
datastoreUrl="ds:///vmfs/volumes/e4b3f733-24646679/" datastore="nas_datastore_03"
Hinweis: Es kann mehr als ein Client vorhanden sein, der einen Nullwert meldet nvramcontent Daher müssen alle Instanzen überprüft werden.
 

5. Sobald der Client oder die Clients mit dem großen NVRAM aus den Protokollen identifiziert wurden:

ein. Starten Sie den Client neu, damit er eine neue NVRAM-Datei erstellt.

B. Wenn das Problem für denselben Kunden auftritt, erstellen Sie einen Service-Request beim technischen Support-Team von Dell Technologies.

6. Wenn die Fehlermeldung weiterhin besteht, finden Sie weitere Informationen unter Avamar: Symptomcode 22402 – Beschreibung: Konsolenserverdaten konnten nicht für zusätzliches Troubleshooting auf dem Server (Lösungspfad) gespeichert werden.

Betroffene Produkte

Avamar

Produkte

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Artikeleigenschaften
Artikelnummer: 000036926
Artikeltyp: Solution
Zuletzt geändert: 07 Okt. 2025
Version:  8
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