PowerFlex 3.5: Peer-afbrydelse ved brug af replikering

Zusammenfassung: Efter konfiguration af PowerFlex-replikering er peer-systemstatus "Afkoblet" med fejlmeddelelsen "REMOTE_PEER_MDM_DENIED_MESSAGE_AS_NO_WORKING_CLIENT_CONNECTION_TO_THIS_PEER".

Dieser Artikel gilt für Dieser Artikel gilt nicht für Dieser Artikel ist nicht an ein bestimmtes Produkt gebunden. In diesem Artikel werden nicht alle Produktversionen aufgeführt.

Symptome

Dette problem kan opstå med det samme efter konfiguration af PowerFlex-replikering, men kan også ses efter nogle netværksændringer, eller når Master MDM på begge sider ændres til en bestemt node. 

scli --query_replication_peer_system på den ene side (SiteA) returnerer:

query-all-Replication Peer System returned 1 Replication Peer System nodes.
Replication Peer System ID: 045a1aa61167b20f Replication Peer System internal ID: eef8648500000000 Name: SiteB State: Decoupled, REMOTE_PEER_MDM_DENIED_MESSAGE_AS_NO_WORKING_CLIENT_CONNECTION_TO_THIS_PEER IP: 192.168.89.14,192.168.89.13,192.168.89.18 Port: 7611 Version: N/A
SDR-SDR connectivity status: All connected

"Netstat"-output ser nogenlunde sådan ud:

tcp        0      0 192.168.86.19:50470     192.168.89.14:7611      ESTABLISHED 36766/mdm-3.5.1100.
tcp        0      0 192.168.86.19:50464     192.168.89.14:7611      ESTABLISHED 36766/mdm-3.5.1100.
tcp        0      0 192.168.86.19:50216     192.168.89.14:7611      ESTABLISHED 36766/mdm-3.5.1100.
tcp        0      0 192.168.86.19:50458     192.168.89.14:7611      ESTABLISHED 36766/mdm-3.5.1100.

Bemærk, at der er fire udgående forbindelser til port 7611 på peer-MDM, men der er ingen indgående forbindelser fra SiteB til port 7611 på localhost.

 

En anden side (SiteB) vises som afkoblet, NOT_CONN, for eksempel:

Query-all-Replication Peer System returned 1 Replication Peer System nodes.
Replication Peer System ID: 0966250f2fae770f Replication Peer System internal ID: c0f3862b00000000 Name: SiteA State: Decoupled, NOT_CONN IP: 192.168.86.20,192.168.86.13,192.168.86.19 Port: 7611 Version: 3.5.1100
SDR-SDR connectivity status: All connected

"Netstat"-output på denne side kan se nogenlunde sådan ud:

B -> A
 
tcp       0    157 192.168.89.14:7611      192.168.86.19:50470     ESTABLISHED 446371/mdm-3.5.1100
tcp       0      0 192.168.89.14:7611      192.168.86.19:50216     ESTABLISHED 446371/mdm-3.5.1100
tcp       0      0 192.168.89.14:7611      192.168.86.19:50464     ESTABLISHED 446371/mdm-3.5.1100
tcp       0      0 192.168.89.14:7611      192.168.86.19:50458     ESTABLISHED 446371/mdm-3.5.1100
 
tcp        0      0 192.168.89.14:54460     192.168.86.19:7611      SYN_SENT 446371/mdm-3.5.1100
tcp        0      0 192.168.89.14:54456     192.168.86.19:7611      SYN_SENT 446371/mdm-3.5.1100
tcp        0      0 192.168.89.14:54458     192.168.86.19:7611      SYN_SENT 446371/mdm-3.5.1100
tcp        0      0 192.168.89.14:54454     192.168.86.19:7611      SYN_SENT 446371/mdm-3.5.1100

Der er forbindelser, der kommer fra SiteA (192.168.89.14), og kildeportnumre matcher "netstat"-outputtet på SiteA, men udgående forbindelser er i SYN_SENT tilstand, hvilket betyder, at de ikke kan afslutte TCP-håndtrykket med SiteA og faktisk ikke kan etablere MDM-peering.

 

Indvirkning
Replikering fungerer ikke Afhængigt af grundårsagen fungerer det muligvis slet ikke, eller kun når en bestemt node bliver Master MDM på en af siderne.

Ursache

Dette problem skyldes enten forkert konfiguration af MDM-IP-adresser eller netværksproblemer mellem websteder. Hvis SiteA f.eks. er konfigureret med korrekte IP-adresser, men SiteB blev konfigureret med IP-adresser, der ikke tilhører SiteA MDM'er, kan dette problem opstå.

Hvis der er problemer med netværksforbindelsen (firewall, routing osv.) mellem webstederne, kan kunden også opleve et lignende problem. En anden grund er duplikerede IP'er på en af siderne (det vil sige, at der er to MDM'er, der kører med den samme IP) eller en slags netværksenhed, der opfanger udgående TCP-sessioner (proxy).

I dette særlige tilfælde holdt SiteB MDM TCP-stik åbne mod en af MDM'erne på SiteA, men var ikke forbundet til den MDM, snarere blev forbindelsen kunstigt holdt i live af en af routerne på stien mellem websteder:

Sådan så netstat-output ud på begge websteder:

A -> B
tcp        0      0 192.168.86.19:50470     192.168.89.14:7611      ESTABLISHED 36766/mdm-3.5.1100.
tcp        0      0 192.168.86.19:50464     192.168.89.14:7611      ESTABLISHED 36766/mdm-3.5.1100.
tcp        0      0 192.168.86.19:50216     192.168.89.14:7611      ESTABLISHED 36766/mdm-3.5.1100.
tcp        0      0 192.168.86.19:50458     192.168.89.14:7611      ESTABLISHED 36766/mdm-3.5.1100.
 
B -> A
 
tcp        0      0 192.168.89.14:54460     192.168.86.19:7611      ESTABLISHED 446371/mdm-3.5.1100
tcp        0      0 192.168.89.14:54456     192.168.86.19:7611      ESTABLISHED 446371/mdm-3.5.1100
tcp        0      0 192.168.89.14:54458     192.168.86.19:7611      ESTABLISHED 446371/mdm-3.5.1100
tcp        0      0 192.168.89.14:54454     192.168.86.19:7611      ESTABLISHED 446371/mdm-3.5.1100
tcp6       0    157 192.168.89.14:7611      192.168.86.19:50470     ESTABLISHED 446371/mdm-3.5.1100
tcp6       0      0 192.168.89.14:7611      192.168.86.19:50216     ESTABLISHED 446371/mdm-3.5.1100
tcp6       0      0 192.168.89.14:7611      192.168.86.19:50464     ESTABLISHED 446371/mdm-3.5.1100
tcp6       0      0 192.168.89.14:7611      192.168.86.19:50458     ESTABLISHED 446371/mdm-3.5.1100

Bemærk, at SiteB (192.168.89.14) viser fire ETABLEREDE forbindelser til IP-adressen på SiteA (192.168.86.19) på port 7611, men vi ser ikke det samme i "netstat" -outputtet på SiteA - en slags netværksproxy holdt disse TCP-sessioner i live.

Lösung

Ret peer-MDM IP-konfigurationen. Test forbindelsen mellem lokaliteter på port TCP/7611. Skift Master MDM-ejerskab til forskellige noder i klyngen, og/eller genstart MDM-tjenesten for at lukke gamle sokler.

 

Påvirkede versioner

PowerFlex 3.5 og derover

Fast i version

Ikke relevant - ikke PowerFlex-problem

Betroffene Produkte

PowerFlex Software
Artikeleigenschaften
Artikelnummer: 000195526
Artikeltyp: Solution
Zuletzt geändert: 26 Nov. 2025
Version:  5
Antworten auf Ihre Fragen erhalten Sie von anderen Dell NutzerInnen
Support Services
Prüfen Sie, ob Ihr Gerät durch Support Services abgedeckt ist.