OpenShift 이벤트 코드: 1030노드0004

Zusammenfassung: Filesystem의 남은 inode가 3% 미만입니다.

Dieser Artikel gilt für Dieser Artikel gilt nicht für Dieser Artikel ist nicht an ein bestimmtes Produkt gebunden. In diesem Artikel werden nicht alle Produktversionen aufgeführt.

Symptome

노드의 파일 시스템이 가득 차면 광범위한 영향을 미칩니다. 이 문제로 인해 해당 노드에 예약된 애플리케이션의 일부 또는 전부가 성능 저하에서 완전히 작동 불능 상태가 될 수 있습니다.

관련된 노드 및 파일 시스템에 따라 이 문제는 클러스터의 안정성에 심각한 위협이 될 수 있습니다.

Ursache

NodeFilesystemAlmostOutOfFiles 경고는 NodeFilesystemSpaceFillingUp 경고와 비슷하지만, 파일 시스템이 특정 시간 내에 inode가 부족해질 것이라는 예측을 기반으로 하는 것이 아니라 간단한 정적 임계값을 사용합니다. 이 알림은 사용 가능한 inode의 5%가 남아 있으면 경고 수준에서 트리거되고 사용 가능한 inode의 3%가 남아 있으면 위험 수준에서 트리거됩니다.

Lösung

진단:
경고에서 인스턴스 및 탑재 지점 레이블을 기록해 둡니다. OpenShift 웹 콘솔(→ 메트릭 관찰 → 쿼리 실행)에서 다음 쿼리를 사용하여 이 파일 시스템의 사용 기록을 그래프로 표시할 수 있습니다.
image.png

노드에서 디버그 세션을 열고 표준 Linux 유틸리티를 사용하여 사용 소스를 찾을 수도 있습니다.
image.png

대부분의 경우 inode가 부족한 파일 시스템에는 여전히 사용 가능한 스토리지가 있습니다. inode 부족은 응용 프로그램이 많은 작은 파일을 만들 때 종종 발생합니다.

완화:
파일 시스템에 할당되는 inode 수는 일반적으로 스토리지 크기를 기준으로 합니다. 스토리지 볼륨의 크기를 늘려 문제를 해결하거나 적어도 문제의 부정적인 영향을 지연시킬 수 있습니다. 그렇지 않으면 많은 수의 작은 파일을 만드는 응용 프로그램을 확인한 다음 구성을 조정하거나 전용 저장소를 제공합니다.

지원:
위의 모든 단계를 수행해도 문제를 해결할 수 없는 경우 Dell EMC 기술 지원 부서에 문의하여 추가 조사를 받으십시오.

Betroffene Produkte

APEX Cloud Platform for Red Hat OpenShift
Artikeleigenschaften
Artikelnummer: 000217406
Artikeltyp: Solution
Zuletzt geändert: 13 Feb. 2026
Version:  3
Antworten auf Ihre Fragen erhalten Sie von anderen Dell NutzerInnen
Support Services
Prüfen Sie, ob Ihr Gerät durch Support Services abgedeckt ist.