Openshift-tapahtumakoodi: 1030NODE0004

Zusammenfassung: Tiedostojärjestelmässä on alle 3% inodeja jäljellä.

Dieser Artikel gilt für Dieser Artikel gilt nicht für Dieser Artikel ist nicht an ein bestimmtes Produkt gebunden. In diesem Artikel werden nicht alle Produktversionen aufgeführt.

Symptome

Kun solmun tiedostojärjestelmä täyttyy, sillä on laaja vaikutus. Tämä ongelma voi aiheuttaa sen, että minkä tahansa tai kaikkien kyseiseen solmuun ajoitettujen sovellusten suorituskyky voi heikentyä tai lakata kokonaan toimimasta.

Solmusta ja tiedostojärjestelmästä riippuen tämä ongelma voi olla vakava uhka klusterin vakaudelle.

Ursache

NodeFilesystemAlmostOutOfFiles-hälytys on samanlainen kuin NodeFilesystemSpaceFillingUp-hälytys, mutta sen sijaan, että se perustuisi ennusteeseen, että tiedostojärjestelmästä loppuvat inodeista tietyn ajan kuluessa, se käyttää yksinkertaisia staattisia kynnysarvoja. Hälytys laukaisee varoitustasolla, kun 5% käytettävissä olevista inodeista on jäljellä, ja laukaisee kriittisellä tasolla, kun 3% käytettävissä olevista inodeista on jäljellä.

Lösung

Diagnoosi:
Merkitse ilmentymän ja asennuspisteen tarrat muistiin hälytyksessä. Voit piirtää tämän tiedostojärjestelmän käyttöhistorian käyttämällä seuraavaa kyselyä OpenShift-verkkokonsolissa (tarkkaile → mittareita → suorita kyselyitä):
image.png

Voit myös avata virheenkorjausistunnon solmussa ja etsiä käytön lähteen tavallisilla Linux-apuohjelmilla:
image.png

Huomaa, että monissa tapauksissa tiedostojärjestelmässä, josta inodeista on loppumassa, on edelleen käytettävissä tallennustilaa. Inodien loppuminen johtuu usein, kun sovellus luo useita pieniä tiedostoja.

Lieventäminen:
Tiedostojärjestelmälle varattujen inodien määrä perustuu yleensä tallennustilan kokoon. Voit ehkä ratkaista ongelman tai ainakin viivästyttää ongelman kielteisiä vaikutuksia lisäämällä tallennustilan kokoa. Muussa tapauksessa määritä sovellus, joka luo suuria määriä pieniä tiedostoja, ja säädä sitten sen kokoonpanoa tai anna sille erillinen tallennustila.

Tuki:
Jos ongelma ei ratkea mitkään yllä olevista toimista, ota yhteyttä Dell EMC:n tekniseen tukeen lisätutkimuksia varten.

Betroffene Produkte

APEX Cloud Platform for Red Hat OpenShift
Artikeleigenschaften
Artikelnummer: 000217406
Artikeltyp: Solution
Zuletzt geändert: 13 Feb. 2026
Version:  3
Antworten auf Ihre Fragen erhalten Sie von anderen Dell NutzerInnen
Support Services
Prüfen Sie, ob Ihr Gerät durch Support Services abgedeckt ist.