Avamar: Could not save console server data to server caused by incorrect file permissions

Summary: Could not save console server data to server (Symptom Code 22402) caused by incorrect file permissions in the prefs directory.

Αυτό το άρθρο ισχύει για Αυτό το άρθρο δεν ισχύει για Αυτό το άρθρο δεν συνδέεται με κάποιο συγκεκριμένο προϊόν. Δεν προσδιορίζονται όλες οι εκδόσεις προϊόντων σε αυτό το άρθρο.

Symptoms

This event can be logged as a Dial Home event, an MC UI event or seen in the command line of the Avamar Utility Node:

Symptom: 22402, Desc: Could not save console server data to server.
 

The following error may also be logged in the flush log (/usr/local/avamar/var/mc/server_log/flush.log) on the Avamar Utility Node: 

avtar Error <5137>: Unable to open "var/mc/server_data/mcserver.xml" for backup (code 13: Permission denied).

Cause

If any file in the directory "/usr/local/avamar/var/mc/server_data/prefs" does not have "admin:admin" ownership, flushes fail.

Resolution

Check the ownership of the files in the /usr/local/avamar/var/mc/server_data/prefs/ directory:

1. Log in to the Avamar Utility Node as admin and load the admin keys. For instructions on loading keys see Avamar: How to Log in to an Avamar Server and Load Various Keys.

2. Check the existing ownership:

ls -la /usr/local/avamar/var/mc/server_data/prefs/

See APPENDIX A for sample output.

a. If all file ownership is correctly set to "admin:admin," stop referencing this article and review Avamar: Symptom Code 22402 - Could not save console server data to server (Resolution Path) for additional troubleshooting.

b. If any ownership is not admin:admin, go to Step 3.

3. Switch to the root user: 

su -
 

4. Change to the directory: 

cd /usr/local/avamar/var/mc/server_data/prefs
 

5. Correct the permissions on files that are not "admin:admin":

chown admin:admin <filename> 
 

6. Repeat for each file with incorrect ownership.

7. Restart the Management Console Server (MCS) using Avamar: How to Restart Management Console Server

8. Monitor the MC UI Event Monitor to ensure that MCS flushes are now working.

If flush errors continue, review Avamar: Symptom Code 22402 - Could not save console server data to server (Resolution Path) for additional help.

Additional Information

APPENDIX A: Example output showing mcserver.xml with the correct permissions and mcserver.xml.old with the incorrect permissions:

drwxr-xr-x  2 admin admin  4096 Oct 18 11:44 . 
drwxr-xr-x  7 admin admin  4096 Nov 16 11:45 .. 
-rw-r--r--  1 admin admin 31358 Oct 18 11:44 mcserver.xml 
-rwxr-x---  1 root  root  31366 Oct 18 11:42 mcserver.xml.old 
-rw-r--r--  1 admin admin  4506 Sep 23  2003 preferences.dtd

 

Note: In the example above, the original mcserver.xml file was renamed to mcserver.xml.old because the permissions were owned by root. A new file was copied and permissions changed to admin:admin.

All permissions must be changed to admin:admin for a successful flush.

Επηρεαζόμενα προϊόντα

Avamar

Προϊόντα

Avamar, Avamar Server
Ιδιότητες άρθρου
Article Number: 000165650
Article Type: Solution
Τελευταία τροποποίηση: 01 Οκτ 2025
Version:  8
Βρείτε απαντήσεις στις ερωτήσεις σας από άλλους χρήστες της Dell
Υπηρεσίες υποστήριξης
Ελέγξτε αν η συσκευή σας καλύπτεται από τις Υπηρεσίες υποστήριξης.