SourceOne Email Management - Unable to restore from web search

Summary: Unable to restore from web search as the permissions were not properly migrated while Exchange migration.

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms



After a migration to Exchange 2013 users are unable to restore from web search.
A pop up error will be displayed as follows:
An error occurred while trying to retrieve the list of selected mailbox

Cause

You are unable to restore from web search as you are migrating mailboxes from Exchange 2010 to Exchange 2013. 
Activities do not work on migrated users to Exchange 2013. 
AutoDiscovery is enabled. HTTP over RPC is enabled.
Whilst doing the Exchange migration the permissions were not properly migrated.

Resolution

The following  permissions are required for SourceOne service account and the mailboxes for Exchange 2013.
See the SourceOne Installation Guide for further details.

Send As & Receive As Permissions
********************************
--Grant on single Mailbox
Add-ADPermission -identity <Identity> -user <es1service> -ExtendedRights Receive-As

--Grant on all Mailboxes
Get-Mailbox | Add-Adpermission -User <es1service> -ExtendedRights Receive-As

--Grant on Mailbox Database
Get-MailboxDatabase -identity Mailbox_DataBase_Name | Add-ADPermission -user <es1service> -ExtendedRights Receive-As

Affected Products

SourceOne Email Management

Products

SourceOne, SourceOne Email Management
Article Properties
Article Number: 000057022
Article Type: Solution
Last Modified: 02 Jun 2025
Version:  4
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