Celerra/VNX Unified:Control Stationをフェールオーバー/フェールバックする方法(ユーザーによる修正可能)

Summary: Control Stationのプライマリー/セカンダリーの関係を変更する手順について説明します。

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms


ユーザーは、プライマリーControl StationのIPアドレスを使用してUnisphereにアクセスできません。  
/nas/とnas_コマンドが失敗したか、見つかりません。
nas_checkupがUnisphereにエラーを報告します(メモを参照)。

Cause

複数の問題が原因でCSのフェールオーバーが発生することがあります。

Resolution

/nasmcd/getreasonを使用して、Control Stationのステータスを確認します。(フェールオーバーの状態を示すgetreasonの出力)
 
[nasadmin@VNXLab ~]$ /nasmcd/getreason
11 - slot_0 secondary control station
10 - slot_1 primary control station
 5 - slot_2 contacted
 5 - slot_3 contacted
 5 - slot_4 contacted
 
Control Stationは、複数の方法を使用してフェールバックすることができます。

slot_0の場合は、以下を参照して使用します。
 
slot_0 secondary control station
Would you like to log into the Primary Control Station? (yes or [no]) no
 
[nasadmin@VNXLab ~]$ su
Password:
[root@VNXXLab nasadmin]# /nasmcd/sbin/cs_standby -takeover
Taking over as Primary Control Station...succeeded

(This will take 1-3 minutes.)

slot_1の場合は、以下を参照して使用します。
 
slot_1 primary control station 
 
[nasadmin@BottleCapsCS0 ~]$ su
Password:
[root@VNXLab nasadmin]# /nasmcd/sbin/cs_standby -failover
 
The system will reboot, do you wish to continue? [yes or no]: yes
Failing over from Primary Control Station.
 
Broadcast message from root (pts/2) (Mon Aug 11 17:36:21 2014):
 
The system is going down for reboot NOW!
 
--または--
 
[nasadmin@VNXLab ~]$ su
Password:
[root@VNXLab nasadmin]# reboot

Broadcast message from root (pts/0) (Mon Aug 11 16:59:29 2014):

The system is going down for reboot NOW!
(This will take 1-3 minutes)

Additional Information

nas_checkup error. 
 
Control Station: Check if primary is active
Error HC_CS_14505082897: Slot 0 is not the primary Control Station
処置:
  1. システム上のさまざまなログを使用して、Control Stationのフェールオーバーの原因となった問題を特定します。Control Stationのフェールバックを試行する前に、障害の原因を特定し、その問題が解決されたかどうかを確認します。
  2. スロット1のControl Stationで、/nasmcd/sbin/cs_standby -failbackコマンドを実行します。スロット1のControl Stationが再起動し、スロット0のControl Stationがプライマリーになります。
  3. サービスが完全に起動するまで5分間待ち、nasadminとして両方のControl Stationにログインして、問題が解決されたことを確認します。スロット0のControl Stationにログインすると、正常にログインできるはずです。スロット1のControl Stationにログインすると、スロット1がプライマリーのControl Stationではないと通知されます。

フェールオーバーの状態を示すgetreasonの出力:
 
[nasadmin@VNXLab ~]$ /nasmcd/getreason
11 - slot_0 secondary control station
10 - slot_1 primary control station
 5 - slot_2 contacted
 5 - slot_3 contacted
 5 - slot_4 contacted

Affected Products

VNX2 Series

Products

eNAS, VNX1 Series, VNX2 Series, VNX/VNXe
Article Properties
Article Number: 000025261
Article Type: Solution
Last Modified: 07 Nov 2025
Version:  4
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.