EMC M&R | Watch4net | ViPR SRM - Scheduled Reports Failing when scheduled by specific group of users - Task exits with a failure error code of 11

Summary: This article outlines the reason for scheduled report failing to complete cleanly when exiting with error code 11 and the following line noted in the taskRun log: ReportRestrictionException: report element count restriction. In this instance we are attempting to email the report as a PDF attachment ...

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms



Scheduled Report failing to complete  - upon checking the taskRun logs, the exit status shows:

Execute method (main) exited with a failure error code of 11

Upon checking the stacktrace in the logs the following can be seen:

SEVERE: Scheduled Report `EMC M&R Health` for user `test` could not be sent: Friday, 15 September 2017 13:07:59 o'clock BST SEVERE: Scheduled Report `emailed` for user `test` for type `EMC M&R Health` failed!
 com.watch4net.apg.v2.gui.report.renderer.RenderingException: Failure to render report in PDF.
...
Caused by: com.watch4net.apg.v2.gui.report.renderer.RenderingException: com.watch4net.apg.v2.gui.report.ReportRestrictionException: report element count restriction (limit: 2)
...
Caused by: com.watch4net.apg.v2.gui.report.ReportRestrictionException: report element count restriction (limit: 2)
...

Cause

The cause of this error relates to a Restriction in the role assigned to the user(s)

If the role has a restriction on the Report Elements section which is less than the number of elements in the report, you will see the above error

kA2f1000000FvTtCAK_1_0

Resolution

Increase the number of Report Elements that can be displayed in this role or move the user(s) to a role with a less restrictive number

Affected Products

Storage Software
Article Properties
Article Number: 000050389
Article Type: Solution
Last Modified: 31 Jan 2025
Version:  4
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