Avamar: Exchange VSS-Plug-in – DAG-Backup schlägt aufgrund von PowerShell-Fehlern fehl

Summary: Wissensdatenbank (KB), die Workarounds für Exchange DAG-Backupfehler aufgrund von PowerShell-Fehlern bereitstellt.

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

Exchange-Backups können mit den folgenden Fehlern fehlschlagen:

2014-01-15 11:39:59 avexvss Info <18202>: The Powershell interface already has required permissions.  Will not impersonate with provided credentials.
2014-01-15 11:43:10 avexvss Error <0000>: Error [EXMB1.EMC.com] Connecting to remote server failed with the following error message : The WinRM client cannot complete the operation within the time specified. Check if the machine name is valid and is reachable over the network and firewall exception for Windows Remote Management service is enabled. For more information, see the about_Remote_Troubleshooting Help topic.
2014-01-15 11:43:10 avexvss Error <16954>: Unable to initialize Powershell interface process -- cannot continue.
2014-01-15 11:43:10 avexvss Error <13077>: Unable to complete backup.
 
2014/01/28-23:55:22.12100 [avexvss_snapup_assist]  Failed to initialize PowerShell interface using method 1; unable to launch process- return code: 1314
2014/01/28-23:55:22.12100 [avexvss_snapup_assist]  Attempting impersonation using CreateProcessWithLogonW
2014/01/28-23:55:22.12100 [avexvss_snapup_assist]  Failed to initialize PowerShell interface using method 2; unable to launch process as new user - return code: 1058
2014-01-28 15:55:22 avexvss Error <0000>: Unable to initialize PowerShell interface, verify the user name and password.
2014-01-28 15:55:22 avexvss Error <16957>: Powershell interface unable to logon as new user -- cannot continue.
Andere Variationen können die folgenden sein:
avexvss Error <0000>: Error [emcmbx01.avamar.com] Connecting to remote server failed with the following error message : The WinRM client sent a request to an HTTP server and got a response saying the requested HTTP URL was not available. This is usually returned by a HTTP server that does not support the WS-Management protocol. For more information, see the about_Remote_Troubleshooting Help topic. 
avexvss Error <16954>: Unable to initialize Powershell interface process -- cannot continue.  
...
avexvss Error <0000>: Error [emcmbx01.avamar.com]  Connecting to remote server failed with the following error message : The WinRM client cannot process the request. It cannot determine the content type of the HTTP response from the destination computer. The  content type is absent or invalid. For more information, see the about_Remote_Troubleshooting Help topic.

Cause

Internetinformationsdienste (IIS) befinden sich möglicherweise in einem fehlerhaften Zustand, wenn der Exchange-Client längere Zeit nicht neu gestartet wurde.

Bei Exchange DAG-Verbundbackups blockieren Firewalls möglicherweise den PowerShell-Remotezugriff zwischen DAG-Mitgliedern.

 

Resolution

Befolgen Sie die folgenden Lösungen, um dieses Problem zu beheben:
1. Starten Sie IIS neu.
2. Überprüfen Sie, ob der im Exchange-Datenvolumen angegebene Nutzername und das Kennwort korrekt sind.
3. Überprüfen Sie, ob der PowerShell-Remotezugriff deaktiviert ist, und versuchen Sie, ihn mit dem folgenden PowerShell-Befehl zu aktivieren:
Enable-PSremoting -force 

4. Aktivieren Sie den Windows Remote Management-Service, indem Sie den folgenden PowerShell-Befehl eingeben:
winrm quickconfig  
5. Wenn das Backup weiterhin fehlschlägt oder die Fehlermeldung "Powershell interface unable to logon as new user," Gehen Sie wie folgt vor, um zusätzliches Debugging zu aktivieren:
ein. Erstellen Sie im Bin-Verzeichnis, in dem sich ps_exec.exe befindet, eine Textdatei mit dem Namen "ps_exec.cmd".   Vergewissern Sie sich, dass sie mit der Dateierweiterung ".cmd" und nicht als ".txt" erstellt wurde.
b. ps_exec.cmd bearbeiten; Fügen Sie diese Zeile hinzu:
--debug 
c. Führen Sie das Exchange DAG-Testbackup erneut aus (mit den in das Dataset eingegebenen Zugangsdaten "AvamarBackupUser") und es wird eine neue Protokolldatei namens "ps_exec.log" erstellt.  Dieses Protokoll hilft dabei, alle zusätzlichen Sicherheitsberechtigungen zu identifizieren, die möglicherweise für das Konto "AvamarBackupUser" erforderlich sind.

Melden Sie sich bei jedem der Exchange-Clients als "AvamarBackupUser"-Konto an, öffnen Sie die Exchange-Managementshell und überprüfen Sie die Powershell-Funktionalität mit Befehlen wie:
 
get-mailboxdatabase

Konfigurieren Sie alternativ die Avamar-Cluster-Agent-Services (Exchange-DAG-Verbund) wie folgt neu:

1. Starten Sie das Tool Failover Cluster Manager.
2. Beenden Sie "DELL Avamar Backup cluster client for <DAG_NAME>".
3. Öffnen Sie Services und suchen Sie nach "DELL Avamar Backup Agent for <DAG_NAME>".
4. Wenn dieser Service gestartet wird, beenden Sie ihn.
5. Wählen Sie unter "Properties" die Registerkarte "Log On" aus. Wählen Sie auf dieser Registerkarte die Option "This account" aus und geben Sie die Zugangsdaten für das Konto "AvamarBackupUser" ein.
6. Wählen Sie Übernehmen und OK aus.
7. Wiederholen Sie die Schritte 3–6 auf jedem DAG-Node.
8. Öffnen Sie Failover Cluster Manager und starten Sie "DELL Avamar Backup cluster client for <DAG_NAME>".
 
Dabei werden alle DAG-Nodes mit demselben "AvamarBackupUser"-Konto für "Backup Agent"- und "DELL Avamar Backup Agent for <dagname-Services>" gestartet.  
 
Lassen Sie im Datenvolumen für den DAG-Client die Felder für die Anmeldedaten "AvamarBackupUser" leer, da die oben genannten Verfahren die Eingabe dieser Anmeldedaten negieren.**

*Wenn alle oben genannten Problemumgehungen fehlschlagen, ist die Exchange Management PowerShell oder IIS entweder falsch konfiguriert oder unvollständig. Der Microsoft-Support sollte einbezogen werden, um Fehler zu beheben, neu zu konfigurieren oder die erforderlichen Komponenten neu zu installieren.

Zusätzliche Schritte zur Fehlerbehebung:

Es handelt sich um ein Setup-Problem von Microsoft, wenn es nicht in der Lage ist, PowerShell zu initialisieren und eine Verbindung zum Server herzustellen. Für dieses Problem gibt es mehrere Gründe.

Aus Microsoft-Dokumenten: "PowerShell-Remoting ist auf Windows Server-Plattformen standardmäßig aktiviert. Sie können Enable-PSRemoting verwenden, um PowerShell-Remoting auf *anderen unterstützten Versionen von Windows zu aktivieren und um Remoting erneut zu aktivieren, wenn es deaktiviert wird. Führen Sie diesen Befehl nur einmal auf jedem Server aus, der Befehle empfängt."
* Die Gruppenrichtlinie kann dies außer Kraft setzen.

Auch aus einem Microsoft-Artikel: "Standardmäßig können alle Benutzer die Remote-PowerShell-Funktion verwenden. Trotzdem muss der Benutzer Mitglied einer Managementrolle in AD sein."
*Sie wurde durch die Gruppenrichtlinie deaktiviert oder eingeschränkt.

Wenn Sie über einen funktionierenden Exchange-Server und einen problematischen Server verfügen, verwenden Sie den Befehl "systeminfo" in PowerShell, um Patchlevel zu vergleichen.


1. Überprüfen Sie im IIS-Manager, ob das richtige oder gültige SSL-Zertifikat der "Standardwebsite" und dem "Exchange Back-End" zugewiesen ist. Beide Seiten finden Sie unter "Bindings" -> HTTPS. Entfernen Sie das Häkchen von "SSL erforderlich" in den "SSL-Einstellungen" auf der PowerShell-Website unter "Exchange Back-End". Dadurch wird das SSL-Zertifikat ignoriert und geprüft, ob die PowerShell-Verbindung funktioniert. 2. Führen Sie den Befehl "sin PowerShell" mit Administratorrechten aus und geben Sie das Ergebnis frei:
 
IISRESET
winrm quickconfig

3. Deinstallieren Sie das Windows-Update KB3134758 - 4. Überprüfen und Installieren der Windows-Funktion "Windows PowerShell 2.0 Engine" – 5. Testen Sie die PowerShell-Konnektivität mit dem folgenden Befehl.
 
new-pssession -Authentication "kerberos" -ConfigurationName "Microsoft.Exchange" -Credential "domain\avamarbackupuser"  -ConnectionURI http://ex21.example.com/PowerShell
Weitere Informationen finden Sie unter dem folgenden Link.
Der Microsoft-Support sollte einbezogen werden, um Fehler zu beheben, neu zu konfigurieren oder die erforderlichen Komponenten neu zu installieren.

Additional Information

Für verknüpfte Backups mit dem Avamar Exchange DAG-Client können die Anmeldedatenfelder "AvamarBackupUser" im Datenvolumen leer gelassen werden. Diese Zugangsdaten dürfen nur in den folgenden Situationen im Datenvolumen angegeben werden:
 
  1. Das Konto "AvamarBackupUser" wurde nicht für das Servicekonto "Backup Agent" auf dem Client erstellt oder konfiguriert.
  2. Verbundbackups mit Exchange DAG-Clientname

Das Konto "AvamarBackupUser" muss mit dem Konfigurationstool "AvamarBackupUser" oder gemäß dem Avamar Exchange Client-Handbuch erstellt werden.
 

Affected Products

Avamar, Avamar Plug-in for Exchange VSS
Article Properties
Article Number: 000051325
Article Type: Solution
Last Modified: 25 Sept 2025
Version:  4
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.