Avamar: Exchange VSS-plugin – DAG-sikkerhetskopiering mislykkes på grunn av PowerShell-feil

Summary: Kunnskapsbase (KB) som gir midlertidige løsninger for feil i Exchange DAG-sikkerhetskopiering på grunn av PowerShell-feil.

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

Exchange-sikkerhetskopieringer kan mislykkes med følgende feil:

2014-01-15 11:39:59 avexvss Info <18202>: The Powershell interface already has required permissions.  Will not impersonate with provided credentials.
2014-01-15 11:43:10 avexvss Error <0000>: Error [EXMB1.EMC.com] Connecting to remote server failed with the following error message : The WinRM client cannot complete the operation within the time specified. Check if the machine name is valid and is reachable over the network and firewall exception for Windows Remote Management service is enabled. For more information, see the about_Remote_Troubleshooting Help topic.
2014-01-15 11:43:10 avexvss Error <16954>: Unable to initialize Powershell interface process -- cannot continue.
2014-01-15 11:43:10 avexvss Error <13077>: Unable to complete backup.
 
2014/01/28-23:55:22.12100 [avexvss_snapup_assist]  Failed to initialize PowerShell interface using method 1; unable to launch process- return code: 1314
2014/01/28-23:55:22.12100 [avexvss_snapup_assist]  Attempting impersonation using CreateProcessWithLogonW
2014/01/28-23:55:22.12100 [avexvss_snapup_assist]  Failed to initialize PowerShell interface using method 2; unable to launch process as new user - return code: 1058
2014-01-28 15:55:22 avexvss Error <0000>: Unable to initialize PowerShell interface, verify the user name and password.
2014-01-28 15:55:22 avexvss Error <16957>: Powershell interface unable to logon as new user -- cannot continue.
Andre varianter kan omfatte følgende:
avexvss Error <0000>: Error [emcmbx01.avamar.com] Connecting to remote server failed with the following error message : The WinRM client sent a request to an HTTP server and got a response saying the requested HTTP URL was not available. This is usually returned by a HTTP server that does not support the WS-Management protocol. For more information, see the about_Remote_Troubleshooting Help topic. 
avexvss Error <16954>: Unable to initialize Powershell interface process -- cannot continue.  
...
avexvss Error <0000>: Error [emcmbx01.avamar.com]  Connecting to remote server failed with the following error message : The WinRM client cannot process the request. It cannot determine the content type of the HTTP response from the destination computer. The  content type is absent or invalid. For more information, see the about_Remote_Troubleshooting Help topic.

Cause

Internet Information Services (IIS) kan være i en ugyldig tilstand hvis Exchange-klienten ikke har blitt startet på nytt på lenge.

For Exchange DAG-sikkerhetskopier i forbund kan brannmurer blokkere ekstern PowerShell-tilgang mellom DAG-medlemmer.

 

Resolution

Følg løsningene nedenfor for å løse dette problemet:
1. Start IIS på nytt.
2. Kontroller at brukernavnet og passordet som er angitt i Exchange-datasettet, er riktig.
3. Kontroller om ekstern PowerShell-tilgang er deaktivert, og prøv å aktivere den ved hjelp av følgende PowerShell-kommando:
Enable-PSremoting -force 

4. Aktiver Windows Remote Management-tjenesten ved å skrive inn følgende PowerShell-kommando:
winrm quickconfig  
5. Hvis sikkerhetskopieringen fortsatt mislykkes, eller får feilmeldingen "Powershell interface unable to logon as new user," Gjør følgende for å aktivere ytterligere feilsøking:
en. Opprett en tekstfil kalt "ps_exec.cmd" i papirkurvkatalogen der ps_exec.exe befinner seg.   Bekreft at den er opprettet som filtypen ".cmd" og ikke ".txt".
b. Rediger ps_exec.cmd; Legg til denne linjen:
--debug 
c. Kjør sikkerhetskopieringen av Exchange DAG-testen på nytt (med legitimasjonen for "AvamarBackupUser" angitt i datasettet), og en ny loggfil opprettes kalt "ps_exec.log".  Denne loggen hjelper deg med å identifisere eventuelle andre sikkerhetstillatelser som kan være nødvendige for "AvamarBackupUser"-kontoen.

Logg på hver Exchange-klient som "AvamarBackupUser"-konto, åpne Exchange Management Shell og kontroller PowerShell-funksjonaliteten med kommandoer som:
 
get-mailboxdatabase

Du kan også konfigurere Avamar-klyngeagenttjenestene på nytt (Federated Exchange DAG) på følgende måte:

1. Start Failover Cluster Manager-verktøyet.
2. Stopp "DELL Avamar backup cluster client for <DAG_NAME>."
3. Åpne Tjenester, og finn "DELL Avamar Backup Agent for <DAG_NAME>".
4. Hvis denne tjenesten startes, må du stoppe den.
5. Under egenskaper velger du "Logg på" -fanen. I denne kategorien velger du alternativet "Denne kontoen" og angir legitimasjonen for "AvamarBackupUser" -kontoen.
6. Velg Bruk og OK.
7. Gjenta trinn 3–6 på hver DAG-node.
8. Åpne Failover Cluster Manager, og start "DELL Avamar backup cluster client for <DAG_NAME>".
 
Dermed startes alle DAG-noder med samme "AvamarBackupUser"-konto for både "Backup Agent" og "DELL Avamar Backup Agent for <dagname-tjenester>".  
 
I datasettet for DAG-klienten lar du legitimasjonsfeltene for "AvamarBackupUser" stå tomme, siden fremgangsmåtene ovenfor negerer behovet for å angi denne legitimasjonen.**

*Hvis alle de midlertidige løsningene ovenfor mislykkes, er Exchange Management PowerShell eller IIS enten feilkonfigurert eller ufullstendig. Microsoft Kundestøtte bør engasjeres for å feilsøke, rekonfigurere eller installere de nødvendige komponentene på nytt.

Ekstra feilsøkingstrinn:

Det er et Microsoft-oppsettproblem hvis det ikke er i stand til å initialisere PowerShell og koble til serveren. Det er flere grunner til dette problemet.

Fra Microsoft-dokumenter: "PowerShell remoting er aktivert som standard på Windows Server-plattformer. Du kan bruke Enable-PSRemoting til å aktivere PowerShell-tilbakevending på *andre støttede versjoner av Windows og til å aktivere remoting på nytt hvis det blir deaktivert. Kjør denne kommandoen bare én gang på hver server som mottar kommandoer."
* Gruppepolicy kan overstyre dette.

Også fra en Microsoft-artikkel: "Som standard kan alle brukere bruke den eksterne PowerShell-funksjonen. Likevel må brukeren være medlem av en lederrolle i AD.»
*Det er deaktivert eller begrenset av gruppepolicy.

Hvis du har en fungerende Exchange-server og en problematisk server, bruker du "systeminfo"-kommandoen i PowerShell til å sammenligne oppdateringsnivåer.


1. Kontroller i IIS-behandling om det riktige eller gyldige SSL-sertifikatet er tilordnet "Standard webområde" og "Exchange Back End". Begge nettstedene finner du under "Bindinger" -> HTTPS. Fjern merket fra "SSL kreves" i "SSL-innstillinger" på Powershell-nettstedet under "Exchange Back End." Dette ignorerer SSL-sertifikatet og tester om Powershell-tilkoblingen fungerer. 2. Kjør kommandoen sin Powershell med administratorrettigheter og del resultatet:
 
IISRESET
winrm quickconfig

3. Avinstallere Windows Update KB3134758 – 4. Kontroller og installer Windows-funksjonen "Windows PowerShell 2.0 Engine" - 5. Test PowerShell-tilkoblingen ved hjelp av følgende kommando.
 
new-pssession -Authentication "kerberos" -ConfigurationName "Microsoft.Exchange" -Credential "domain\avamarbackupuser"  -ConnectionURI http://ex21.example.com/PowerShell
Hvis du vil ha hjelp, kan du se koblingen nedenfor.
Microsoft Kundestøtte bør engasjeres for å feilsøke, rekonfigurere eller installere de nødvendige komponentene på nytt.

Additional Information

For forbundssikkerhetskopier som bruker Avamar Exchange DAG-klienten, kan legitimasjonsfeltene for "AvamarBackupUser" stå tomme i datasettet. Denne legitimasjonen må bare angis i datasettet i følgende situasjoner:
 
  1. "AvamarBackupUser"-kontoen er ikke opprettet eller konfigurert for "Backup Agent"-tjenestekontoen på klienten.
  2. Samlede sikkerhetskopier ved hjelp av Exchange DAG-klientnavn

"AvamarBackupUser"-kontoen må opprettes ved hjelp av konfigurasjonsverktøyet "AvamarBackupUser" eller ved å følge klientveiledningen for Avamar Exchange.
 

Affected Products

Avamar, Avamar Plug-in for Exchange VSS
Article Properties
Article Number: 000051325
Article Type: Solution
Last Modified: 25 Sept 2025
Version:  4
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.