Avamar: Exchange VSS-plugin-program – DAG-säkerhetskopiering misslyckas på grund av PowerShell-fel

Summary: Kunskapsbas (KB) som tillhandahåller lösningar för Exchange DAG-säkerhetskopieringsfel på grund av PowerShell-fel.

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

Exchange-säkerhetskopieringar kan misslyckas med följande fel:

2014-01-15 11:39:59 avexvss Info <18202>: The Powershell interface already has required permissions.  Will not impersonate with provided credentials.
2014-01-15 11:43:10 avexvss Error <0000>: Error [EXMB1.EMC.com] Connecting to remote server failed with the following error message : The WinRM client cannot complete the operation within the time specified. Check if the machine name is valid and is reachable over the network and firewall exception for Windows Remote Management service is enabled. For more information, see the about_Remote_Troubleshooting Help topic.
2014-01-15 11:43:10 avexvss Error <16954>: Unable to initialize Powershell interface process -- cannot continue.
2014-01-15 11:43:10 avexvss Error <13077>: Unable to complete backup.
 
2014/01/28-23:55:22.12100 [avexvss_snapup_assist]  Failed to initialize PowerShell interface using method 1; unable to launch process- return code: 1314
2014/01/28-23:55:22.12100 [avexvss_snapup_assist]  Attempting impersonation using CreateProcessWithLogonW
2014/01/28-23:55:22.12100 [avexvss_snapup_assist]  Failed to initialize PowerShell interface using method 2; unable to launch process as new user - return code: 1058
2014-01-28 15:55:22 avexvss Error <0000>: Unable to initialize PowerShell interface, verify the user name and password.
2014-01-28 15:55:22 avexvss Error <16957>: Powershell interface unable to logon as new user -- cannot continue.
Andra variationer kan vara följande:
avexvss Error <0000>: Error [emcmbx01.avamar.com] Connecting to remote server failed with the following error message : The WinRM client sent a request to an HTTP server and got a response saying the requested HTTP URL was not available. This is usually returned by a HTTP server that does not support the WS-Management protocol. For more information, see the about_Remote_Troubleshooting Help topic. 
avexvss Error <16954>: Unable to initialize Powershell interface process -- cannot continue.  
...
avexvss Error <0000>: Error [emcmbx01.avamar.com]  Connecting to remote server failed with the following error message : The WinRM client cannot process the request. It cannot determine the content type of the HTTP response from the destination computer. The  content type is absent or invalid. For more information, see the about_Remote_Troubleshooting Help topic.

Cause

Internet Information Services (IIS) kan vara i ett felaktigt tillstånd om Exchange-klienten inte har startats om på länge.

För federerade Exchange DAG-säkerhetskopieringar kan brandväggar blockera PowerShell-fjärråtkomst mellan DAG-medlemmar.

 

Resolution

Följ lösningarna nedan för att lösa problemet:
1. Starta om IIS.
2. Kontrollera att användarnamnet och lösenordet som anges i Exchange-datauppsättningen är korrekta.
3. Kontrollera om PowerShell-fjärråtkomst är inaktiverat och försök aktivera det med hjälp av följande PowerShell-kommando:
Enable-PSremoting -force 

4. Aktivera Windows fjärrhanteringstjänst genom att skriva följande PowerShell-kommando:
winrm quickconfig  
5. Om säkerhetskopieringen fortfarande inte fungerar eller om felmeddelandet visas "Powershell interface unable to logon as new user," Gör följande för att aktivera ytterligare felsökning:
a. Skapa en textfil med namnet "ps_exec.cmd" i bin-katalogen där ps_exec.exe finns.   Bekräfta att det har skapats som ett .cmd och inte .txt.
b. Redigera ps_exec.cmd; Lägg till den här raden:
--debug 
c. Kör säkerhetskopieringen av Exchange DAG-testet igen (med autentiseringsuppgifterna "AvamarBackupUser" angivna i datauppsättningen) och en ny loggfil skapas med namnet "ps_exec.log".  Loggen hjälper till att identifiera eventuella ytterligare säkerhetsbehörigheter som kan behövas för kontot "AvamarBackupUser".

Logga in på var och en av Exchange-klienterna som ett "AvamarBackupUser"-konto, öppna Exchange Management Shell och kontrollera att Powershell fungerar med kommandon som:
 
get-mailboxdatabase

Du kan också konfigurera om Avamar-klusteragenttjänsterna (federerad Exchange DAG) på följande sätt:

1. Starta verktyget Klusterhanteraren för växling vid fel.
2. Stoppa "DELL Avamar Backup Cluster Client for <DAG_NAME>."
3. Öppna Services och leta reda på "DELL Avamar Backup Agent for <DAG_NAME>".
4. Om den här tjänsten startas, stoppa den.
5. Under egenskaper väljer du fliken "Logga in". På den här fliken väljer du alternativet "Det här kontot" och anger inloggningsuppgifterna för kontot "AvamarBackupUser".
6. Välj Verkställ och OK.
7. Upprepa steg 3–6 på varje DAG-nod.
8. Öppna Failover Cluster Manager och starta DELL Avamar Backup Cluster Client for <DAG_NAME>.
 
Detta gör att alla DAG-noder startas med samma "AvamarBackupUser"-konto för både "Backup Agent" och "DELL Avamar Backup Agent för <dagname-tjänster>".  
 
I datauppsättningen för DAG-klienten lämnar du fälten "AvamarBackupUser" för autentiseringsuppgifter tomma, eftersom de ovan nämnda procedurerna förnekar behovet av att mata in dessa autentiseringsuppgifter.**

* Om alla ovanstående lösningar misslyckas är Exchange Management PowerShell eller IIS antingen felkonfigurerad eller ofullständig. Microsofts support bör anlitas för att felsöka, konfigurera om eller installera om de nödvändiga komponenterna.

Extra felsökningssteg:

Det är ett Microsoft-installationsproblem om det inte går att initiera PowerShell och ansluta till servern. Det finns flera orsaker till detta problem.

Från Microsoft-dokument: "PowerShell-fjärrkommunikation är aktiverat som standard på Windows Server-plattformar. Du kan använda Enable-PSRemoting för att aktivera PowerShell-fjärrkommunikation på *andra versioner av Windows som stöds och för att återaktivera fjärrkommunikation om det inaktiveras. Kör bara det här kommandot en gång på varje server som tar emot kommandon."
* Grupprincip kan åsidosätta detta.

Från en Microsoft-artikel: "Som standard kan alla användare använda PowerShell-fjärrfunktionen. Trots det måste användaren vara medlem i en chefsroll i AD."
*Det har inaktiverats eller begränsats av grupprincip.

Om du har en fungerande Exchange-server och en problematisk server använder du kommandot "systeminfo" i PowerShell för att jämföra korrigeringsnivåer.


1. Kontrollera i IIS-hanteraren om rätt eller giltigt SSL-certifikat har tilldelats "Standardwebbplatsen" och "Exchange-serverdelen". Båda webbplatserna finns under "Bindningar" -> HTTPS. Ta bort bockmarkeringen för "SSL krävs" i "SSL-inställningarna" på Powershell-webbplatsen under "Exchange Back End". Detta ignorerar SSL-certifikatet och testar om Powershell-anslutningen fungerar. 2. Kör kommandot i Powershell med administratörsbehörighet och dela resultatet:
 
IISRESET
winrm quickconfig

3. Avinstallera Windows-uppdateringen KB3134758 – 4. Kontrollera och installera Windows-funktionen "Windows PowerShell 2.0 Engine" – 5. Testa PowerShell-anslutningen med följande kommando.
 
new-pssession -Authentication "kerberos" -ConfigurationName "Microsoft.Exchange" -Credential "domain\avamarbackupuser"  -ConnectionURI http://ex21.example.com/PowerShell
Om du behöver hjälp, se länken nedan.
Microsofts support bör anlitas för att felsöka, konfigurera om eller installera om de nödvändiga komponenterna.

Additional Information

För federerade säkerhetskopieringar med Avamar Exchange DAG-klienten kan autentiseringsfälten "AvamarBackupUser" lämnas tomma i datauppsättningen. Dessa autentiseringsuppgifter får bara anges i datauppsättningen i följande situationer:
 
  1. Kontot "AvamarBackupUser" har inte skapats eller konfigurerats för tjänstkontot "Backup Agent" på klienten.
  2. Samlade säkerhetskopior med Exchange DAG-klientnamn

Kontot "AvamarBackupUser" måste skapas med hjälp av konfigurationsverktyget "AvamarBackupUser" eller genom att följa Avamar Exchange-klientmanualen.
 

Affected Products

Avamar, Avamar Plug-in for Exchange VSS
Article Properties
Article Number: 000051325
Article Type: Solution
Last Modified: 25 Sept 2025
Version:  4
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.