Dell EMC Unity: errore 0x100000a durante il tentativo di upload dell'immagine di aggiornamento .gpg con uemcli -upload (correggibile da Dell EMC)
Summary: L'upload dei file su Dell EMC Unity tramite UEMCLI ha esito negativo per mancanza di spazio sulle partizioni Unity, tuttavia sul sistema Unity vi è spazio libero sufficiente.
This article applies to
This article does not apply to
This article is not tied to any specific product.
Not all product versions are identified in this article.
Symptoms
Aggiornamento di Dell EMC Unity OE
Il tentativo di aggiornare l'array Dell EMC Unity OE con Windows UEMCLI ha esito negativo con un errore 0x100000a generico. Il messaggio visualizzato è "There is not enough free disk space on the client machine to complete this operation" e può anche apparire come Error Code:0x100000a oppure Error Code:0x1000102
C:\Users\admin>uemcli ... -upload -f Unity-4.0.2.8627717.tgz.bin.gpg upgrade
Exit code: 1
Output: Operation failed. Error code: 0x100000a
The system was unable to connect to the storage server. (Error Code:0x100000a)
Il tentativo di aggiornare l'array Dell EMC Unity OE con Windows UEMCLI ha esito negativo con un errore 0x100000a generico. Il messaggio visualizzato è "There is not enough free disk space on the client machine to complete this operation" e può anche apparire come Error Code:0x100000a oppure Error Code:0x1000102
C:\Users\admin>uemcli ... -upload -f Unity-4.0.2.8627717.tgz.bin.gpg upgrade
Exit code: 1
Output: Operation failed. Error code: 0x100000a
The system was unable to connect to the storage server. (Error Code:0x100000a)
Anche nell'array Dell EMC Unity:
service@(none) spb:/$ uemcli ... -upload -f Unity-4.0.2.8627717.tgz.bin.gpg upgrade
Uploaded 1.94 GB of 1.94 GB [ 100.0% ] at 36.44 MB/s
Operation failed. Error code: 0x100000a
The system was unable to connect to the storage server. (Error Code:0x100000a)
Cause
Il sistema Dell EMC Unity necessita di uno spazio due volte e mezzo in più per l'immagine di aggiornamento in queste partizioni:
/cores
/var/tmp (which is from root partition, "/")
Se l'immagine OE è di 2 GB, sono necessari 5 GB di spazio libero in /cores e circa la stessa quantità in /var/tmp. In /var/tmp il sistema può tentare di liberare spazio eliminando immagini obsolete ma, se in /cores non è disponibile spazio sufficiente, l'operazione ha esito negativo con l'errore 0x1000000a.
/cores
/var/tmp (which is from root partition, "/")
Se l'immagine OE è di 2 GB, sono necessari 5 GB di spazio libero in /cores e circa la stessa quantità in /var/tmp. In /var/tmp il sistema può tentare di liberare spazio eliminando immagini obsolete ma, se in /cores non è disponibile spazio sufficiente, l'operazione ha esito negativo con l'errore 0x1000000a.
Resolution
Abilitare SSH sul sistema Dell EMC Unity, quindi accedere come utente "service".
NON eseguire svc_purge_logs -c --force (potrebbe causare riavvii imprevisti dell'SP e persino una non disponibilità dei dati).
Da svc_purge_logs -help:
--clear[-c] --force Attempts to clear space on the root filesystem.
Files will not be removed unless --force is used.
AVVERTENZA: Using this option could cause irreversible
damage to the system.
Una volta effettuato l'accesso all'array Unity, emettere un comando "df -h" per assicurarsi che nella partizione "/" vi siano almeno 4,5 GB di spazio libero. In caso contrario, analizzare le partizioni interne con i comandi df e du.
È inoltre possibile eseguire svc_purge_logs -f per analizzare i report sull'utilizzo del file system risultanti. Eliminare con attenzione i file indesiderati SE si è certi che non siano necessari.
Se nella partizione "/" sono presenti almeno 4,5 GB di spazio libero, è possibile che si sia verificato un problema con la funzionalità di trasferimento di file di grandi dimensioni UEMCLI. Si è verificato un problema con UEMCLI versione 4.0.x basato su Windows che influisce sulla capacità di eseguire l'upload di file di dimensioni prossime a 2 GB (si tratta di un limite nella versione a 32 bit).
Ecco come convalidare l'installazione UEMCLI sul sistema Windows locale.
C:\Users\admin>uemcli -v
Version: 4.0.0.1.2825
Branch: upc-Unity.2.8
Revision: 308352
Per procedere da qui:
Se si verifica questo problema in uemcli sull'array Dell EMC Unity, la ragione più comune è che la partizione /core non dispone di almeno 5 GB di spazio libero.
Se l'array è UnityVSA (virtuale), l'utente deve utilizzare la GUI di Unisphere o il sistema Unity remoto per eseguire l'aggiornamento. Se si tratta di hardware Unity, è possibile utilizzare l'SP peer come segue:
Procedura di aggiornamento mediante l'SP peer su Unity (modelli hardware):
NON eseguire svc_purge_logs -c --force (potrebbe causare riavvii imprevisti dell'SP e persino una non disponibilità dei dati).
Da svc_purge_logs -help:
--clear[-c] --force Attempts to clear space on the root filesystem.
Files will not be removed unless --force is used.
AVVERTENZA: Using this option could cause irreversible
damage to the system.
Una volta effettuato l'accesso all'array Unity, emettere un comando "df -h" per assicurarsi che nella partizione "/" vi siano almeno 4,5 GB di spazio libero. In caso contrario, analizzare le partizioni interne con i comandi df e du.
È inoltre possibile eseguire svc_purge_logs -f per analizzare i report sull'utilizzo del file system risultanti. Eliminare con attenzione i file indesiderati SE si è certi che non siano necessari.
Se nella partizione "/" sono presenti almeno 4,5 GB di spazio libero, è possibile che si sia verificato un problema con la funzionalità di trasferimento di file di grandi dimensioni UEMCLI. Si è verificato un problema con UEMCLI versione 4.0.x basato su Windows che influisce sulla capacità di eseguire l'upload di file di dimensioni prossime a 2 GB (si tratta di un limite nella versione a 32 bit).
Ecco come convalidare l'installazione UEMCLI sul sistema Windows locale.
C:\Users\admin>uemcli -v
Version: 4.0.0.1.2825
Branch: upc-Unity.2.8
Revision: 308352
Per procedere da qui:
- Aggiornare uemcli per Windows alla versione più recente disponibile nelle pagine di supporto.
- Eseguire uemcli dall'SP peer se non è possibile aggiornarlo su Windows
- Utilizzare la GUI di Unisphere
Se si verifica questo problema in uemcli sull'array Dell EMC Unity, la ragione più comune è che la partizione /core non dispone di almeno 5 GB di spazio libero.
Se l'array è UnityVSA (virtuale), l'utente deve utilizzare la GUI di Unisphere o il sistema Unity remoto per eseguire l'aggiornamento. Se si tratta di hardware Unity, è possibile utilizzare l'SP peer come segue:
Procedura di aggiornamento mediante l'SP peer su Unity (modelli hardware):
- Accedere tramite SSH all'array tramite l'account di servizio [esempio: SPA è l'SP gestore e SPB è l'SP peer/secondario]
- Ottenere il file dell'immagine di aggiornamento utilizzando winSCP o sftp in /cores/service (attenzione: da Unity OE 4.5, utilizzare /core/service/user)
- Copiare l'immagine dall'SP primario all'SP peer/secondario:
Fino a Unity OE 4.4.x: scp /cores/service/Unity-4.x.x.xxxxxxx.tgz.bin.gpg peer:/cores/service
Da Unity OE 4.5.x: scp /cores/service/user/Unity-4.x.x.xxxxxxx.tgz.bin.gpg peer:/cores/service/user
Da Unity OE 4.5.x: scp /cores/service/user/Unity-4.x.x.xxxxxxx.tgz.bin.gpg peer:/cores/service/user
- Eliminare l'immagine dall'SP locale (SPA in questo esempio): rm /cores/service/Unity-4.x.x.xxxxxxx.tgz.bin.gpg
- Accedere tramite ssh all'SP peer: ssh peer
- Effettuare l'upload mediante uemcli: uemcli -d peer -u admin -securepassword -no -upload -f /path/to/gpgfile upgrade
- Avviare l'aggiornamento quando necessario utilizzando uemcli o la GUI di Unisphere come previsto
Additional Information
Esempio di upload del file immagine tramite SP peer:
service@(none) spa:~$ sftp anonymous@ftp.emc.com
sftp> get Unity-4.1.2.9257522.tgz.bin.gpg
Fetching /pub/rcm/Unity/Unity-4.1.2.9257522.tgz.bin.gpg to Unity-4.1.2.9257522.tgz.bin.gpg
/pub/rcm/Unity/Unity-4.1.2.9257522.tgz.bin.gpg 100% 2042MB 5.8MB/s 05:54
sftp> bye
service@(none) spa:~$ scp /cores/service/Unity-4.1.2.9257522.tgz.bin.gpg peer:/cores/service (per Unity OE 4.5 o versione successiva, utilizzare /core/service/user)
Unity-4.1.2.9257522.tgz.bin.gpg
service@(none) spa:~$ ssh peer
Last login: Mon May 22 22:39:10 2017 from 128.221.255.100
service@(none) spb:~$ uemcli -d peer -u admin -securepassword -no -upload -f /cores/service/Unity-4.1.2.9257522.tgz.bin.gpg upgrade
(per Unity OE 4.5 o versione successiva, utilizzare /cores/service/user)
Password:
Uploaded 1.99 GB of 1.99 GB [ 100.0% ] -PROCESSING-
Operation completed successfully.
service@(none) spb:~$ logout
Connection to peer closed.
service@(none) spa:~$ uemcli /sys/soft/ver show -detail
1: ID = INST_1
Type = installed
Version = 4.1.1.9138882
Release date = 2017-02-09 14:30:02
Image type =
Reboot required =
Pause allowed =
Image filename =
2: ID = CAND_1 <--- upgrade image is ready to proceed
Type = candidate
Version = 4.1.2.9257522
Release date = 2017-04-11 04:23:24
Image type = software
Reboot required = yes
Pause allowed = yes
Image filename = Unity-4.1.2.9257522.tgz.bin
service@(none) spa:~$ sftp anonymous@ftp.emc.com
sftp> get Unity-4.1.2.9257522.tgz.bin.gpg
Fetching /pub/rcm/Unity/Unity-4.1.2.9257522.tgz.bin.gpg to Unity-4.1.2.9257522.tgz.bin.gpg
/pub/rcm/Unity/Unity-4.1.2.9257522.tgz.bin.gpg 100% 2042MB 5.8MB/s 05:54
sftp> bye
service@(none) spa:~$ scp /cores/service/Unity-4.1.2.9257522.tgz.bin.gpg peer:/cores/service (per Unity OE 4.5 o versione successiva, utilizzare /core/service/user)
Unity-4.1.2.9257522.tgz.bin.gpg
service@(none) spa:~$ ssh peer
Last login: Mon May 22 22:39:10 2017 from 128.221.255.100
service@(none) spb:~$ uemcli -d peer -u admin -securepassword -no -upload -f /cores/service/Unity-4.1.2.9257522.tgz.bin.gpg upgrade
(per Unity OE 4.5 o versione successiva, utilizzare /cores/service/user)
Password:
Uploaded 1.99 GB of 1.99 GB [ 100.0% ] -PROCESSING-
Operation completed successfully.
service@(none) spb:~$ logout
Connection to peer closed.
service@(none) spa:~$ uemcli /sys/soft/ver show -detail
1: ID = INST_1
Type = installed
Version = 4.1.1.9138882
Release date = 2017-02-09 14:30:02
Image type =
Reboot required =
Pause allowed =
Image filename =
2: ID = CAND_1 <--- upgrade image is ready to proceed
Type = candidate
Version = 4.1.2.9257522
Release date = 2017-04-11 04:23:24
Image type = software
Reboot required = yes
Pause allowed = yes
Image filename = Unity-4.1.2.9257522.tgz.bin
Affected Products
Dell EMC Unity FamilyProducts
Dell Unity 300, Dell EMC Unity 300F, Dell EMC Unity 400, Dell EMC Unity 400F, Dell EMC Unity 500, Dell EMC Unity 500F, Dell EMC Unity 600, Dell EMC Unity 600F, Dell EMC Unity Family |Dell EMC Unity All Flash, Dell EMC Unity Family
, Dell EMC Unity Hybrid, Dell EMC UnityVSA Professional Edition/Unity Cloud Edition
...
Article Properties
Article Number: 000052819
Article Type: Solution
Last Modified: 12 Dec 2025
Version: 3
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.