Dell EMC Unity. Ошибка 0x100000a при попытке загрузить образ обновления .gpg с uemcli -upload (исправляется Dell EMC)
Summary: Загрузка файлов в Dell EMC Unity через UEMCLI завершается сбоем из-за нехватки места в разделах Unity, однако в системе Unity достаточно свободного места.
This article applies to
This article does not apply to
This article is not tied to any specific product.
Not all product versions are identified in this article.
Symptoms
Обновление Dell EMC Unity OE
Попытка обновления дискового массива Dell EMC Unity с помощью UEMCLI Windows завершается сбоем со стандартной ошибкой 0x100000a . Отображается сообщение «There is not enough free disk space on the Client machine to complete this operation» и может отображаться как Error Code:0x100000a или Error Code:0x1000102
C:\Users\admin>uemcli ... -upload -f Unity-4.0.2.8627717.tgz.bin.gpg upgrade
Код выхода: 1
Вывод: Operation failed. Error code: 0x100000a
The system was unable to connect to the storage server. (Error Code:0x100000a)
Попытка обновления дискового массива Dell EMC Unity с помощью UEMCLI Windows завершается сбоем со стандартной ошибкой 0x100000a . Отображается сообщение «There is not enough free disk space on the Client machine to complete this operation» и может отображаться как Error Code:0x100000a или Error Code:0x1000102
C:\Users\admin>uemcli ... -upload -f Unity-4.0.2.8627717.tgz.bin.gpg upgrade
Код выхода: 1
Вывод: Operation failed. Error code: 0x100000a
The system was unable to connect to the storage server. (Error Code:0x100000a)
Даже в дисковом массиве Dell EMC Unity:
service@(none) spb:/$ uemcli ... -upload -f Unity-4.0.2.8627717.tgz.bin.gpg upgrade
Uploaded 1.94 GB of 1.94 GB [ 100.0% ] at 36.44 MB/s
Operation failed. Код ошибки: 0x100000a
The system was unable to connect to the storage server. (Error Code:0x100000a)
Cause
Для образа обновления в следующих разделах системе Dell EMC Unity требуется в два с половиной раза больше дискового пространства:
/cores
/var/tmp (который из корневого раздела «/»)
Если образ операционной среды составляет 2 Гбайт, то нам требуется 5 Гбайт свободного пространства в /cores и примерно столько же в /var/tmp. В разделе /var/tmp система может попытаться высвободить место, удалив старые образы, однако в разделе /cores при недостатке пространства произойдет сбой с ошибкой 0x1000000a.
/cores
/var/tmp (который из корневого раздела «/»)
Если образ операционной среды составляет 2 Гбайт, то нам требуется 5 Гбайт свободного пространства в /cores и примерно столько же в /var/tmp. В разделе /var/tmp система может попытаться высвободить место, удалив старые образы, однако в разделе /cores при недостатке пространства произойдет сбой с ошибкой 0x1000000a.
Resolution
Включите SSH в системе Dell EMC Unity, а затем войдите в систему под именем пользователя «service».
НЕ запускайте svc_purge_logs -c --force (это может привести к внезапным перезагрузкам процессора СХД и даже недоступности данных).
Из svc_purge_logs -help:
--clear[-c] --force пытается очистить дисковое пространство в корневой файловой системе.
Файлы не будут удалены, если не использовать --force.
ПРЕДУПРЕЖДЕНИЕ. Применение данного ключа может нанести системе необратимый
ущерб.
После входа в дисковый массив Unity выполните команду «df -h», чтобы удостовериться в том, что в разделе «/» не менее 4,5 Гбайт свободного пространства. Если нет, проверьте внутренние разделы с помощью команд df и du.
Можно также запустить svc_purge_logs -f для рассмотрения полученных отчетов об использовании файловой системы. Аккуратно удалите ненужные файлы, ЕСЛИ вы уверены в том, что они не требуются.
Если в корневом разделе «/» доступно не менее 4,5 Гбайт свободного дискового пространства, возможно, вы столкнулись с проблемой, связанной с функционированием передачи файлов большого объема в UEMCLI. В UEMCLI версии 4.0.x на базе Windows возникла проблема, которая влияет на возможность загрузки файлов размером около 2 Гбайт (это 32-разрядное ограничение).
Ниже приведены инструкции по проверке установки UEMCLI в локальной системе Windows.
C:\Users\admin>uemcli -v
Version: 4.0.0.1.2825
Branch: upc-Unity.2,8
Revision: 308352
Продолжить с этого места:
Если данная проблема возникает в uemcli в дисковом массиве Dell EMC Unity, наиболее распространенная причина заключается в том, что в разделе /cores свободно менее 5 Гбайт.
Если дисковый массив является виртуальным (UnityVSA), пользователь должен использовать графический интерфейс пользователя Unisphere или удаленную систему Unity для выполнения обновления. Если это оборудование Unity, соседний одноранговый процессор СХД можно использовать следующим образом:
Процедура обновления с помощью соседнего однорангового процессора СХД в Unity (модели оборудования):
НЕ запускайте svc_purge_logs -c --force (это может привести к внезапным перезагрузкам процессора СХД и даже недоступности данных).
Из svc_purge_logs -help:
--clear[-c] --force пытается очистить дисковое пространство в корневой файловой системе.
Файлы не будут удалены, если не использовать --force.
ПРЕДУПРЕЖДЕНИЕ. Применение данного ключа может нанести системе необратимый
ущерб.
После входа в дисковый массив Unity выполните команду «df -h», чтобы удостовериться в том, что в разделе «/» не менее 4,5 Гбайт свободного пространства. Если нет, проверьте внутренние разделы с помощью команд df и du.
Можно также запустить svc_purge_logs -f для рассмотрения полученных отчетов об использовании файловой системы. Аккуратно удалите ненужные файлы, ЕСЛИ вы уверены в том, что они не требуются.
Если в корневом разделе «/» доступно не менее 4,5 Гбайт свободного дискового пространства, возможно, вы столкнулись с проблемой, связанной с функционированием передачи файлов большого объема в UEMCLI. В UEMCLI версии 4.0.x на базе Windows возникла проблема, которая влияет на возможность загрузки файлов размером около 2 Гбайт (это 32-разрядное ограничение).
Ниже приведены инструкции по проверке установки UEMCLI в локальной системе Windows.
C:\Users\admin>uemcli -v
Version: 4.0.0.1.2825
Branch: upc-Unity.2,8
Revision: 308352
Продолжить с этого места:
- Обновите Windows UEMCLI до последней версии, доступной на страницах поддержки.
- Запустите uemcli с соседнего однорангового процессора СХД, если обновление uemcli в Windows невозможна
- Используйте графический интерфейс пользователя Unisphere
Если данная проблема возникает в uemcli в дисковом массиве Dell EMC Unity, наиболее распространенная причина заключается в том, что в разделе /cores свободно менее 5 Гбайт.
Если дисковый массив является виртуальным (UnityVSA), пользователь должен использовать графический интерфейс пользователя Unisphere или удаленную систему Unity для выполнения обновления. Если это оборудование Unity, соседний одноранговый процессор СХД можно использовать следующим образом:
Процедура обновления с помощью соседнего однорангового процессора СХД в Unity (модели оборудования):
- Выполните вход по SSH в массив с помощью сервисной учетной записи [Пример. SPA — управляющий процессор СХД, а SPB — соседний/дополнительный одноранговый процессор СХД]
- Скачайте файл образа обновления с помощью winSCP или sftp в /cores/service (Внимание! В Unity OE 4.5 и выше используйте /cores/service/user)
- Скопируйте образ с основного процессора СХД на соседний/дополнительный одноранговый процессор СХД:
В Unity OE до версий 4.4.x включительно: scp /cores/service/Unity-4.x.x.xxxxxxx.tgz.bin.gpg peer:/cores/service
В Unity OE начиная с версий 4.5.x: scp /cores/service/user/Unity-4.x.x.xxxxxxx.tgz.bin.gpg peer:/cores/service/user
В Unity OE начиная с версий 4.5.x: scp /cores/service/user/Unity-4.x.x.xxxxxxx.tgz.bin.gpg peer:/cores/service/user
- Удалите образ из локального процессора СХД (в данном примере СХД A): rm /cores/service/Unity-4.x.xxxxxxxx.tgz.bin.gpg
- Подключение по ssh к соседнему одноранговому процессору СХД: ssh peer
- Выполните загрузку с помощью uemcli : uemcli -d peer -u admin -securepassword -no -upload -f /path/to/gpgfile upgrade
- При необходимости запустите обновление с помощью uemcli или графического пользовательского интерфейса Unisphere в соответствии с расписанием
Additional Information
Пример загрузки файла образа с помощью соседнего однорангового процессора СХД:
service@(none) spa:~$ sftp anonymous@ftp.emc.com
sftp> get
Unity-4.1.2.9257522.tgz.bin.gpg Fetching /pub/rcm/Unity/Unity-4.1.2.9257522.tgz.bin.gpg to
Unity-4.1.2.9257522.tgz.bin.gpg /pub/rcm/Unity/Unity-4.1.2.9257522.tgz.bin.gpg 100% 2042MB 5.8MB/s 05:54
sftp> bye
service@(none) Spa:~$ scp /cores/service/Unity-4,1.2,9257522.tgz.bin.gpg peer:/cores/service (для Unity OE 4.5 и выше используйте /cores/service/user)
Unity-4,1.2,9257522.tgz.bin.gpg
service@(none) Spa:~$ ssh peer
Last login: Mon May 22 22:39:10 2017 from 128.221.255.100
service@(none) spb:~$ uemcli -d peer -u admin -securepassword -no -upload -f /cores/service/Unity-4.1.2.9257522.tgz.bin.gpg upgrade
(для Unity OE 4.5 и выше используйте /cores/service/user)
Password:
Uploaded 1.99 GB of 1.99 GB [ 100.0% ] -PROCESSING-
Operation completed successfully.
service@(none) spb:~$ logout
Connection to peer closed.
service@(none) spa:~$ uemcli /sys/soft/ver show -detail
1: ID = INST_1
Type = installed
Version = 4.1.1.9138882
Release date = 2017-02-09 14:30:02
Image type =
Reboot required =
Pause allowed =
Image filename =
2: ID = CAND_1 <--- upgrade image is ready to proceed
Type = candidate
Version = 4.1.2.9257522
Release date = 2017-04-11 04:23:24
Image type = software
Reboot required = yes
Pause allowed = yes
Image filename = Unity-4.1.2.9257522.tgz.bin
service@(none) spa:~$ sftp anonymous@ftp.emc.com
sftp> get
Unity-4.1.2.9257522.tgz.bin.gpg Fetching /pub/rcm/Unity/Unity-4.1.2.9257522.tgz.bin.gpg to
Unity-4.1.2.9257522.tgz.bin.gpg /pub/rcm/Unity/Unity-4.1.2.9257522.tgz.bin.gpg 100% 2042MB 5.8MB/s 05:54
sftp> bye
service@(none) Spa:~$ scp /cores/service/Unity-4,1.2,9257522.tgz.bin.gpg peer:/cores/service (для Unity OE 4.5 и выше используйте /cores/service/user)
Unity-4,1.2,9257522.tgz.bin.gpg
service@(none) Spa:~$ ssh peer
Last login: Mon May 22 22:39:10 2017 from 128.221.255.100
service@(none) spb:~$ uemcli -d peer -u admin -securepassword -no -upload -f /cores/service/Unity-4.1.2.9257522.tgz.bin.gpg upgrade
(для Unity OE 4.5 и выше используйте /cores/service/user)
Password:
Uploaded 1.99 GB of 1.99 GB [ 100.0% ] -PROCESSING-
Operation completed successfully.
service@(none) spb:~$ logout
Connection to peer closed.
service@(none) spa:~$ uemcli /sys/soft/ver show -detail
1: ID = INST_1
Type = installed
Version = 4.1.1.9138882
Release date = 2017-02-09 14:30:02
Image type =
Reboot required =
Pause allowed =
Image filename =
2: ID = CAND_1 <--- upgrade image is ready to proceed
Type = candidate
Version = 4.1.2.9257522
Release date = 2017-04-11 04:23:24
Image type = software
Reboot required = yes
Pause allowed = yes
Image filename = Unity-4.1.2.9257522.tgz.bin
Affected Products
Dell EMC Unity FamilyProducts
Dell Unity 300, Dell EMC Unity 300F, Dell EMC Unity 400, Dell EMC Unity 400F, Dell EMC Unity 500, Dell EMC Unity 500F, Dell EMC Unity 600, Dell EMC Unity 600F, Dell EMC Unity Family |Dell EMC Unity All Flash, Dell EMC Unity Family
, Dell EMC Unity Hybrid, Dell EMC UnityVSA Professional Edition/Unity Cloud Edition
...
Article Properties
Article Number: 000052819
Article Type: Solution
Last Modified: 12 Dec 2025
Version: 3
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.