ECS: Parameters for ECS upgrades when a Native Migration (Transformation) is in progress

Summary: Parameters for ECS upgrades when a Native Migration (Transformation) is in progress.

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

Upgrade from ECS 3.1.x to ECS 3.2.x.

Parameters for ECS upgrades from ECS 3.1.x.x to ECS 3.2.x.x when a Native Migration (Transformation) is in progress.

If a customer wants an ECS Native Migration to use an encrypted bucket, the encrypted bucket is created outside the Native Migration process. By doing this, the legacy Centera data are clear text (not encrypted) as it was on the Centera. Simultaneously, new data written to the same bucket is encrypted. This is especially helpful for application servers which cannot support multiple Centera/CAS archive targets and the customer wants to switch over to encryption at rest. Regardless of application server capabilities, this allows the same Pool and or Bucket to be used for new writes and as the migration target. New writes are also encrypted.

If an ECS Transformation is in progress with the parameters detailed above. The ECS upgrade is performed from ECS 3.1.x to ECS 3.2.x and is possible the migrated data can become corrupt.

CAS and Centera are synonymous as well as Native Migration and Transformation.

Cause

Native Migration and Upgrade process issue.

Resolution

The solution is not to upgrade the ECS code while a Native Migration (Transformation) is in progress.

The most likely case is a Remote Proactive Services (RPS) team member prompted the engineer to review this KB. Also, if the situation matches what is detailed in the issue section, they open another SR. So that ECS CS and ECS Engineering can determine if it is advisable to upgrade the ECS now. Or to wait for the current phase of the Transformation to complete.

Regardless of the parameters detailed in the Issue section, if a Native Migration (Transformation) is in progress, the RPS Team creates another Service Request. So that ECS CS and ECS Engineering can determine if the upgrade can proceed. Or if it must wait for the current migration phase to complete.

For anyone else encountering this Knowledge Base Article (KB), if needed, contact Dell Customer Service and reference this KB, 527746.

Affected Products

Elastic Cloud Storage

Products

ECS Appliance, ECS Appliance Hardware Gen1 U-Series, ECS Appliance Software with Encryption, ECS Appliance Software without Encryption, Elastic Cloud Storage
Article Properties
Article Number: 000053002
Article Type: Solution
Last Modified: 20 Feb 2023
Version:  3
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