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Article Number: 000054812


Avamar: Windows File System Restore Fails with "Unable to BackupWrite" and "The data is invalid"

Summary: Windows file system restore fails with errors: Avtar Error <5737>: I/O and error: Unable to BackupWrite(4) "D:Temp_file_name_.xlsx" (code 13: The data is invalid). This article addresses the issue "code 13: The data is invalid" that may be seen during an Avamar restore operation. ...

Article Content


Symptoms

The restore job of some .xlsx and .pdf files fails with the following errors on the log file:
2017-01-18 11:34:54 avtar Error <5737>: I/O error: Unable to BackupWrite(4) "D:\Temp\_file_name_.xlsx" (code 13: The data is invalid).
2017/01/18-10:34:54.05100 [avtar]  restdata: BackupRead content is valid
2017-01-18 11:34:54 avtar Error <5189>: Error restoring path "D:\aaaaa\bbbbbb\cccccc\xxxx\_file_name_.xlsx" to "D:\Temp\".
2017-01-18 11:34:54 avtar Error <5263>: Restore of "D:\aaaaa\bbbbbb\cccccc\xxxx\_file_name_.xlsx" failed

The affected files are restored, but Excel or Acrobat Reader cannot open the files as they seem to be corrupted.

Example of an error message when attempting to open the file:

"Excel cannot open the file 'filename.xlsx' because the file format for the file extension is not valid. Verify that the file has not been corrupted and that the file extension matches the format of the file."

Other .xlxs or .pdf files from the same restore job are restored and can be opened.

Cause

This behavior is due to a combination of restored files with different file headers, NTFS, and FAT32, to an NTFS partition by the same restore job.

The files mentioned in the warnings have a FAT32 file header. These files were created on an old Windows 2003 server with FAT32 partitions and then moved to a system with NTFS partitions.

Resolution

This issue was identified as a code issue in the avtar binary and it was already addressed. The current Avamar versions should not experience this issue.

If the issue is seen on any of the current Avamar versions, it can be worked around with these steps:
  1. Before the restore operation, add the flag --x06=4096 in the avtar.cmd file in the agent path <client-install-folder>\var.
  2. Run the restore of those FAT32 files and then remove the flag after the restore.
 
Note:
  • The flag was designed to restore files with FAT32 headers to an NTFS partition.
  • That flag can only be used for FAT32 file types and fails to restore NTFS file types.
  • Once the FAT32 file restore is completed, the flag must be removed from the avtar.cmd file and used again only when required.

Article Properties


Affected Product

Avamar

Product

Avamar, Avamar Client for Windows

Last Published Date

10 Apr 2024

Version

3

Article Type

Solution