DPA: Newly installed Agent cannot connect to the DPA Application server
Summary: This article explains the fix when the newly installed Agent cannot connect to the Data Protection Advisor (DPA) Application server.
Symptoms
A newly installed Agent on a Red Hat Enterprise Linux server starts up, but does not appear in the DPA Application. In the UI going to Admin -> System -> Configure System Settings -> Data Collection Agents, the Agent is not listed.
When examining the DPA Application server log, we observed the following messages:
2016-08-01 17:58:23,164 WARN [com.emc.dpa.agent.AgentServiceBean] (EJB default - 108) Unable to connect to agent node01.emc.com on port 3741 2016-08-01 17:59:08,671 WARN [com.emc.dpa.agent.AgentServiceBean] (EJB default - 132) Unable to connect to agent node01.emc.com on port 3741
When examining the newly installed Agent's log file, we observed the following messages:
DBG2 2141.2141 20160729:223409 com.http - debug_function(): CURL: [info] CAfile: /etc/pki/tls/certs/ca-bundle.crt CApath: none DBG2 2141.2141 20160729:223409 com.http - debug_function(): CURL: [info] TLSv1.2 (OUT), TLS header, Certificate Status (22): DBG2 2141.2141 20160729:223409 com.http - debug_function(): CURL: [ssl:send] DBG2 2141.2141 20160729:223409 com.http - debug_function(): CURL: [info] TLSv1.2 (OUT), TLS handshake, Client hello (1): DBG2 2141.2141 20160729:223409 com.http - debug_function(): CURL: [ssl:send] DBG2 2141.2141 20160729:223524 com.http - debug_function(): CURL: [info] Unknown SSL protocol error in connection to 192.168.0.1:9002 DBG2 2141.2141 20160729:223524 com.http - debug_function(): CURL: [info] Closing connection 0 DBG1 2141.2141 20160729:223524 com.http - httpSendRequest(): CURL error: [35] Unknown SSL protocol error in connection to 192.168.0.1:9002 ERR 2141.2141 20160729:223524 agent.config - initAgentConfig(): Failed to register agent with the server. Waiting to retry...
Cause
The cause of this issue is not known now.
Current suspicion is that either firewall or networking issues, or both on the affected node causes this.
Resolution
In the one instance where this was observed a workaround was found.
During initial setup of the node the firewall (iptables) was configured to allow connections to the node on port 3741 TCP. It was found that the issue disappeared when the firewall (iptables) was also configured to also allow traffic on port 3741 UDP. Once port 3741 UDP was opened, on startup the Agent connected to the DPA Application. Also of note, after initial Agent startup and connection, the firewall was configured to again close port 3741 UDP and the Agent continued to function normally (even after another shutdown and startup).
Contact Dell Technologies Technical Support for further details or information.