SourceOne E-Mail-Management: Bei der Suche in ElasticSearch-Indizes wird der Fehler angezeigt: Der Abfrageservice kann den Suchvorgang nicht starten.

Summary: SourceOne E-Mail-Management: Bei der Suche in ElasticSearch-Indizes wird der Fehler angezeigt: Der Abfrageservice kann den Suchvorgang nicht starten.

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Symptoms



Ein Nutzer, der mithilfe von Websearch oder Discovery Manager nach Elasticsearch-Indizes sucht, erhält den folgenden Fehler: Abfrageservice kann den Suchvorgang
nicht startenDer Nutzer sucht in ElasticSearch-Indizes und erhält die Fehlermeldung abhängig vom Datumsbereich, der im Suchparameter oder im ausgewählten zugeordneten Ordner verwendet wird. Einige Datumsbereiche oder zugeordnete Ordner funktionieren möglicherweise ohne Probleme.
Die betroffenen Indizes werden in dem Fehler angezeigt, der in der Websearch- oder Discovery Manager-Schnittstelle angezeigt wird.
Der folgende Fehler wird im ExJbQuery-Protokoll des Servers angezeigt, der die Suche durchführt:

CoExESQueryPlugin::CreateSearchAlias|FEHLER|Systemaufruf fehlgeschlagen. (0x86040100) Gebunden an unbekannten Typ.  (0x80028027) [ExJBQuery.exe, ExElasticsearchClient.cpp(4239). CExElasticsearchClient::CreateAlias]
CoExESQueryPlugIn::CreateSearchAlias|FEHLER|Fehler beim Erstellen eines Suchalias.  Error: 0x80028027|CoExESQueryPlugIn.cpp(2822)
CoExESQueryPlugin::BuildQuery|FEHLER|Systemaufruf fehlgeschlagen. (0x86040100) [ExJBQuery.exe, CoExESQueryPlugIn.cpp(2783). CoExESQueryPlugIn::CreateSearchAlias] >Systemaufruf fehlgeschlagen. (0x86040100) Gebunden an unbekannten Typ.  (0x80028027) [ExJBQuery.exe, ExElasticsearchClient.cpp(4239). CExElasticsearchClient::CreateAlias] |CoExESQueryPlugIn.cpp(601)|
CoExAsQuery::Volltext ausführen|FEHLER|Systemaufruf fehlgeschlagen. (0x86040100) [ExJBQuery.exe, CoExESQueryPlugIn.cpp(449). CoExESQueryPlugIn::ExecuteQuery] >Systemaufruf fehlgeschlagen. (0x86040100) [ExJBQuery.exe, CoExESQueryPlugIn.cpp(2783). CoExESQueryPlugIn::CreateSearchAlias] >Systemaufruf fehlgeschlagen. (0x86040100) Gebunden an unbekannten Typ.  (0x80028027) [ExJBQuery.exe, ExElasticsearchClient.cpp(4239). CExElasticsearchClient::CreateAlias] |CoExAsQuery.cpp(924)
CExQueryThread::ExecuteInThread|FEHLER|Suche konnte nicht ausgeführt werden: (0x80028027)|ExQueryThread.cpp(315)

 

Cause

Das Problem wird dadurch verursacht, dass ein oder mehrere in der Suche enthaltene ElasticSearch-Indexsätze im ElasticSearch-Cluster fehlen, sodass der JBQuery-Service die Suche nicht starten kann.

Das Überprüfen des Status des betroffenen Indexes in der SourceOne-Konsole spiegelt möglicherweise nicht den korrekten Status wider. Beispielsweise kann es als verfügbar angezeigt werden, obwohl es im ElasticSearch-Cluster nicht verfügbar ist.

Wenn Sie die Ausführlichkeit der EXJBquery aktivieren, können Sie das folgende Ereignis sehen. Beachten Sie, dass es sich hierbei um ein Informationsereignis handelt.
 
CExJSONDocument::Initialisieren|AUSFÜHRLICH| - JSON = <{"error":"IndexMissingException[[8658614702553635661_-433678426_200105_001] fehlt]","status":404}>|CExJSONDocument.cpp(124)

Resolution

NutzerInnen können versuchen, den betroffenen Index, der in der Discovery Manager- oder Websearch-Schnittstelle angezeigt wird, mithilfe der SourceOne-Konsole neu zu erstellen. Dadurch wird der Index im ElasticSearch-Cluster neu erstellt.

Wenn der Benutzer überprüfen möchte, ob weitere Indizes in der ElasticSearch fehlen, können zwei Methoden verwendet werden.

Methode 1
Aktivieren Sie die Indexvalidierung und konfigurieren Sie sie mit Modus 1.
Führen Sie einen manuellen oder geplanten Scan für alle ElasticSearch-Archivordner durch.
Überprüfen und beheben Sie die Fehler in der Konsole, indem Sie eine "Neuerstellung"
ausführen. Hinweis: Anweisungen zur Verwendung von "Index Validation" finden Sie im "SourceOne-Administrationshandbuch"

Methode 2
Aktivieren Sie die Ausführlichkeit des EXJBquery-Service.
Führen Sie eine Suche in Websearch oder DM durch, einschließlich aller von ElasticSearch zugeordneten Ordner.
Die Suche sollte keinen Datumsbereich enthalten, sodass in allen ElasticSearch-Indexsätzen gesucht wird.
Wenn in der Websuchkonsole der Fehler "Abfragedienst kann den Suchvorgang nicht starten" angezeigt wird, müssen Sie herausfinden, welche Indizes betroffen sind.
Überprüfen Sie unter Operations/Job Management, auf welchem Server die Suche durchgeführt wurde.
Prüfen Sie, ob in der Datei ExJBQuery.log das folgende Ereignis auftritt:
CExJSONDocument::Initialisieren|AUSFÜHRLICH| - JSON = <{"error":"IndexMissingException[[8658614702553635661_-433678426_200105_001] fehlt]","status":404}>|CExJSONDocument.cpp(124)|Job-ID: 455555; Name der Aktivität: Search_2_8_2019_10_33_22_8240; 
Hinweis: Die Ablaufverfolgung muss aktiviert sein, um den obigen Eintrag anzuzeigen.
Erstellen Sie die im Protokolleintrag angegebenen Indexsätze neu.
 

Affected Products

SourceOne Email Management

Products

SourceOne, SourceOne Email Management
Article Properties
Article Number: 000055957
Article Type: Solution
Last Modified: 26 May 2025
Version:  4
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