SourceOne Email management : La recherche dans les index ElasticSearch affiche l’erreur : Le service de requête ne parvient pas à démarrer le processus de recherche.
Summary: SourceOne Email management : La recherche dans les index ElasticSearch affiche l’erreur : Le service de requête ne parvient pas à démarrer le processus de recherche.
This article applies to
This article does not apply to
This article is not tied to any specific product.
Not all product versions are identified in this article.
Symptoms
Un utilisateur effectuant une recherche dans les index ElasticSearch à l’aide de Websearch ou de Discovery Manager obtient l’erreur suivante : Le service de requête ne parvient pas à démarrer le processus
de rechercheL’utilisateur effectue une recherche dans les index ElasticSearch et reçoit l’erreur en fonction de la plage de dates utilisée dans le paramètre de recherche ou le dossier mappé sélectionné. Certaines plages de dates ou certains dossiers mappés peuvent fonctionner sans problème.
Les index concernés s’affichent dans l’erreur affichée dans l’interface Websearch ou Discovery Manager.
L’erreur suivante peut être détectée dans le journal ExJbQuery du serveur effectuant la recherche :
CoExESQueryPlugIn ::CreateSearchAlias|ERREUR|Échec de l’appel système. (0x86040100) Lié à un type inconnu. (0x80028027) [ExJBQuery.exe, ExElasticsearchClient.cpp(4239). CExElasticsearchClient ::CreateAlias]
CoExESQueryPlugIn ::CreateSearchAlias|ERREUR|Échec de la création de l’alias de recherche. Error: 0x80028027|CoExESQueryPlugIn.cpp(2822)
CoExESQueryPlugIn ::BuildQuery|ERREUR|Échec de l’appel système. (0x86040100) [ExJBQuery.exe, CoExESQueryPlugIn.cpp(2783). CoExESQueryPlugIn ::CreateSearchAlias] >System call failed. (0x86040100) Lié à un type inconnu. (0x80028027) [ExJBQuery.exe, ExElasticsearchClient.cpp(4239). CExElasticsearchClient ::CreateAlias] |CoExESQueryPlugIn.cpp(601)|
CoExAsQuery ::ExecuteFullText|ERREUR|Échec de l’appel système. (0x86040100) [ExJBQuery.exe, CoExESQueryPlugIn.cpp(449). CoExESQueryPlugIn ::ExecuteQuery] >System call failed. (0x86040100) [ExJBQuery.exe, CoExESQueryPlugIn.cpp(2783). CoExESQueryPlugIn ::CreateSearchAlias] >System call failed. (0x86040100) Lié à un type inconnu. (0x80028027) [ExJBQuery.exe, ExElasticsearchClient.cpp(4239). CExElasticsearchClient ::CreateAlias] |CoExAsQuery.cpp(924)
CExQueryThread ::ExecuteInThread|ERREUR|La recherche n’a pas pu s’exécuter : (0x80028027)|ExQueryThread.cpp(315)
Cause
Le problème est dû au fait qu’un ou plusieurs ensembles d’index ElasticSearch inclus dans la recherche sont manquants dans le cluster ElasticSearch, de sorte que le service JBQuery ne peut pas démarrer la recherche.
La vérification de l’état de l’index concerné dans la console SourceOne peut ne pas refléter l’état correct. Par exemple, il peut apparaître comme disponible même s’il n’est pas disponible dans le cluster ElasticSearch.
En activant la verbosité de l’EXJBquery, nous pouvons voir l’événement suivant. Notez qu’il s’agit d’un événement d’information.
La vérification de l’état de l’index concerné dans la console SourceOne peut ne pas refléter l’état correct. Par exemple, il peut apparaître comme disponible même s’il n’est pas disponible dans le cluster ElasticSearch.
En activant la verbosité de l’EXJBquery, nous pouvons voir l’événement suivant. Notez qu’il s’agit d’un événement d’information.
CExJSONDocument ::Initialize|VERBOSE| - JSON = <{"error » :"IndexMissingException[[8658614702553635661_-433678426_200105_001] missing] »,"status » :404}>|CExJSONDocument.cpp(124)
Resolution
L’utilisateur peut essayer de « reconstruire » l’index affecté indiqué dans l’interface Discovery Manager ou Websearch à l’aide de la console SourceOne. Cela recréera l’index dans le cluster ElasticSearch.
Si l’utilisateur souhaite vérifier s’il manque d’autres index dans ElasticSearch, deux méthodes peuvent être utilisées.
Méthode 1
Activez la validation de l’index et configurez-la à l’aide du Mode 1.
Exécutez une analyse manuelle ou planifiée sur tous les dossiers d’archives ElasticSearch.
Vérifiez et corrigez les erreurs dans la console lors de l’exécution d’une « reconstruction ».
Remarque : Reportez-vous au « SourceOne Administration guide » pour obtenir des instructions sur l’utilisation de « Index Validation »
Méthode 2
Activez la verbosité du service EXJBquery.
Effectuez une recherche dans Websearch ou DM, y compris dans tous les dossiers mappés ElasticSearch.
La recherche ne doit pas inclure de plage de dates, elle recherchera donc dans tous les ensembles d’index ElasticSearch.
Si l’erreur « Le service de requête n’a pas pu démarrer le processus de recherche » s’affiche dans la console Websearch, vous devez savoir quels index sont concernés.
Vérifiez sous Operations/Job Management quel serveur a exécuté la recherche.
Recherchez l’événement suivant dans le fichier ExJBQuery.log :
Si l’utilisateur souhaite vérifier s’il manque d’autres index dans ElasticSearch, deux méthodes peuvent être utilisées.
Méthode 1
Activez la validation de l’index et configurez-la à l’aide du Mode 1.
Exécutez une analyse manuelle ou planifiée sur tous les dossiers d’archives ElasticSearch.
Vérifiez et corrigez les erreurs dans la console lors de l’exécution d’une « reconstruction ».
Remarque : Reportez-vous au « SourceOne Administration guide » pour obtenir des instructions sur l’utilisation de « Index Validation »
Méthode 2
Activez la verbosité du service EXJBquery.
Effectuez une recherche dans Websearch ou DM, y compris dans tous les dossiers mappés ElasticSearch.
La recherche ne doit pas inclure de plage de dates, elle recherchera donc dans tous les ensembles d’index ElasticSearch.
Si l’erreur « Le service de requête n’a pas pu démarrer le processus de recherche » s’affiche dans la console Websearch, vous devez savoir quels index sont concernés.
Vérifiez sous Operations/Job Management quel serveur a exécuté la recherche.
Recherchez l’événement suivant dans le fichier ExJBQuery.log :
CExJSONDocument ::Initialize|VERBOSE| - JSON = <{"error » :"IndexMissingException[[8658614702553635661_-433678426_200105_001] missing] »,"status » :404}>|CExJSONDocument.cpp(124)|ID de la tâche : 455555; Nom de l’activité : Search_2_8_2019_10_33_22_8240 ;
Remarque : Le traçage doit être activé pour voir l’entrée ci-dessus.
Reconstruisez les jeux d’index indiqués dans l’entrée de log.
Affected Products
SourceOne Email ManagementProducts
SourceOne, SourceOne Email ManagementArticle Properties
Article Number: 000055957
Article Type: Solution
Last Modified: 26 May 2025
Version: 4
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.