Управление электронной почтой SourceOne: Поиск по индексам ElasticSearch показывает ошибку: Службе запросов не удается запустить процесс поиска.

Summary: Управление электронной почтой SourceOne: Поиск по индексам ElasticSearch показывает ошибку: Службе запросов не удается запустить процесс поиска.

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms



Пользователь, выполняющий поиск по индексам ElasticSearch с помощью Websearch или Discovery Manager, получает сообщение об ошибке: Службе запросов не удается запустить процесс
поискаПользователь выполняет поиск по индексам ElasticSearch и получает ошибку в зависимости от диапазона дат, используемого в параметре поиска или выбранной сопоставленной папке. Некоторые диапазоны дат или сопоставленные папки могут работать без проблем.
Затронутые индексы отображаются в сообщении об ошибке в интерфейсе веб-поиска или диспетчера обнаружения.
В журнале ExJbQuery сервера, выполняющего поиск, можно увидеть следующую ошибку:

CoExESQueryPlugIn::CreateSearchAlias|ОШИБКА|Сбой системного вызова. (0x86040100) Привязан к неизвестному типу.  (0x80028027) [ExJBQuery.exe, ExElasticsearchClient.cpp(4239). CExElasticsearchClient::CreateAlias]
CoExESQueryPlugIn::CreateSearchAlias|ОШИБКА|Не удалось построить псевдоним поиска.  Error: 0x80028027|CoExESQueryPlugIn.cpp(2822)
CoExESQueryPlugIn::BuildQuery|ОШИБКА|Сбой системного вызова. (0x86040100) [ExJBQuery.exe, CoExESQueryPlugIn.cpp(2783). CoExESQueryPlugIn::CreateSearchAlias] >Сбой системного вызова. (0x86040100) Привязан к неизвестному типу.  (0x80028027) [ExJBQuery.exe, ExElasticsearchClient.cpp(4239). CExElasticsearchClient::CreateAlias] |CoExESQueryPlugIn.cpp(601)|
CoExAsQuery::ExecuteFullText|ОШИБКА|Сбой системного вызова. (0x86040100) [ExJBQuery.exe, CoExESQueryPlugIn.cpp(449). CoExESQueryPlugIn::ExecuteQuery] >Сбой системного вызова. (0x86040100) [ExJBQuery.exe, CoExESQueryPlugIn.cpp(2783). CoExESQueryPlugIn::CreateSearchAlias] >Сбой системного вызова. (0x86040100) Привязан к неизвестному типу.  (0x80028027) [ExJBQuery.exe, ExElasticsearchClient.cpp(4239). CExElasticsearchClient::CreateAlias] |CoExAsQuery.cpp(924)
CExQueryThread::ExecuteInThread|ОШИБКА|Не удалось выполнить поиск: (0x80028027)|ExQueryThread.cpp(315)

 

Cause

Проблема вызвана тем, что один или несколько наборов индексов ElasticSearch, включенных в поиск, отсутствуют в кластере ElasticSearch, поэтому сервис JBQuery не может запустить поиск.

Проверка состояния затронутого индекса в консоли SourceOne может отражать неверное состояние. Например, он может отображаться как доступный, несмотря на то, что он недоступен в кластере ElasticSearch.

Включив Детализацию EXJBquery, мы можем увидеть следующее событие. Обратите внимание, что это информационное мероприятие.
 
CExJSONDocument::Инициализация|МНОГОСЛОВНЫЙ| - JSON = <{"error":"IndexMissingException[[8658614702553635661_-433678426_200105_001] missing]","status":404}>|CExJSONDocument.cpp(124)

Resolution

Пользователь может попытаться «перестроить» затронутый индекс, отображаемый в Discovery Manager или интерфейсе Websearch, используя консоль SourceOne. Это воссоздаст индекс в кластере ElasticSearch.

Если пользователь хочет проверить, отсутствуют ли какие-либо другие индексы в ElasticSearch, можно использовать два метода.

Способ 1
Включите проверку индекса и настройте ее в режиме 1.
Запустите сканирование вручную или по расписанию для всех папок архива ElasticSearch.
Проверьте и исправьте ошибки в консоли, выполнив «Rebuild»
Примечание. Инструкции по использованию функции «Проверка индекса» см.

в руководстве по администрированию SourceOneСпособ 2
Включите подробный характер службы EXJBquery.
Выполните поиск в WebSearch или DM, включая все сопоставленные папки ElasticSearch.
Поиск не должен включать какой-либо диапазон дат, поэтому поиск будет выполняться во всех наборах индексов ElasticSearch.
Если в консоли Websearch отображается ошибка «Сервису запросов не удается запустить процесс поиска», необходимо выяснить, какие индексы затронуты.
Проверьте, на каком сервере был выполнен поиск, в разделе Operations/Job Management.
Проверьте наличие следующего события в файле ExJBQuery.log:
CExJSONDocument::Инициализация|МНОГОСЛОВНЫЙ| - JSON = <{"error":"IndexMissingException[[8658614702553635661_-433678426_200105_001] missing]","status":404}>|CExJSONDocument.cpp(124)|Идентификатор задания: 455555; Название мероприятия: Search_2_8_2019_10_33_22_8240; 
Примечание. Чтобы увидеть запись выше, необходимо включить трассировку.
Восстановите наборы индексов, указанные в записи журнала.
 

Affected Products

SourceOne Email Management

Products

SourceOne, SourceOne Email Management
Article Properties
Article Number: 000055957
Article Type: Solution
Last Modified: 26 May 2025
Version:  4
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.